aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-02-11 08:23:13 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-02-11 08:23:13 +0000
commit1d929848ed09a54d8d35d3d5303bf8c925b740f9 (patch)
treeba0eefefe57055b4f2e1c5d309fa7760e5b9918e /lang
parentdf8bd0d0061f1f9ba6f1270eeb5c659f860a669d (diff)
downloadports-1d929848ed09a54d8d35d3d5303bf8c925b740f9.tar.gz
ports-1d929848ed09a54d8d35d3d5303bf8c925b740f9.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python34/Makefile30
1 files changed, 16 insertions, 14 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 42795cd57191..246a52f4cfc1 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -35,16 +35,16 @@ MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support
PLIST_SUB= ABI=${ABIFLAGS} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC LIBFFI
-OPTIONS_DEFAULT= IPV6 NLS PYMALLOC THREADS LIBFFI
+OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC THREADS TSC
+OPTIONS_DEFAULT= IPV6 LIBFFI NLS PYMALLOC THREADS
OPTIONS_RADIO= HASH
OPTIONS_RADIO_HASH= FNV SIPHASH
OPTIONS_SUB= yes
+LIBFFI_DESC= Use libffi from ports instead of bundled version
NLS_DESC= Enable gettext support for the locale module
PYMALLOC_DESC= Enable specialized mallocs
TSC_DESC= Enable processor timestamp counter profiling
-LIBFFI_DESC= Use libffi from ports instead of bundled version
HASH_DESC= Hash Algorithm (PEP-456)
FNV_DESC= Modified Fowler-Noll-Vo Algorithm
@@ -52,15 +52,20 @@ SIPHASH_DESC= SipHash24 Algorithm
FNV_CONFIGURE_ON= --with-hash-algorithm=fnv
SIPHASH_CONFIGURE_ON= --with-hash-algorithm=siphash24
+
DEBUG_CONFIGURE_WITH= pydebug
IPV6_CONFIGURE_ENABLE= ipv6
+LIBFFI_CONFIGURE_ON= --with-system-ffi
+LIBFFI_LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
+
# Use CPPFLAGS over CFLAGS due to -I ordering, causing elementtree and pyexpat
# to break in Python 2.7, or preprocessor complaints in Python >= 3.3
# Upstream Issue: http://bugs.python.org/issue6299
+
NLS_USES= gettext
-NLS_LIBS= -L${LOCALBASE}/lib -lintl
NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LIBS= -L${LOCALBASE}/lib -lintl
NLS_CONFIGURE_ENV_OFF= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
PYMALLOC_CONFIGURE_WITH= pymalloc
@@ -68,6 +73,7 @@ PYMALLOC_CONFIGURE_WITH= pymalloc
THREADS_CONFIGURE_WITH= threads
THREADS_CFLAGS= ${PTHREAD_CFLAGS}
THREADS_LDFLAGS= ${PTHREAD_LIBS}
+
TSC_CONFIGURE_WITH= tsc
.include <bsd.port.options.mk>
@@ -80,22 +86,18 @@ ABIFLAGS:= m${ABIFLAGS}
ABIFLAGS:= d${ABIFLAGS}
.endif
-.if ${PORT_OPTIONS:MLIBFFI}
-CONFIGURE_ARGS+= --with-system-ffi
-LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
-.else
-.if ${ARCH} == i386
-# http://bugs.python.org/issue22521
-BROKEN= You must use libffi from ports on i386
-.endif
-.endif
-
.if !empty(ABIFLAGS)
PLIST_FILES+= bin/python3.4%%ABI%%
PLIST_FILES+= bin/python3.4%%ABI%%-config
PLIST_FILES+= libdata/pkgconfig/python-3.4%%ABI%%.pc
.endif
+# http://bugs.python.org/issue22521
+# http://bugs.python.org/issue23042
+.if ${ARCH} == i386 && !${PORT_OPTIONS:MLIBFFI}
+BROKEN= You must use libffi from ports on i386. Enable the LIBFFI option
+.endif
+
.if ${ARCH} == sparc64
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif