aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-12-12 02:44:21 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-12-12 02:44:21 +0000
commit59ff92cfbdcea83ec3b162b338d6e3b9c3025735 (patch)
treea436a17c6fe16d9d67358d8cfd2513bfee3900e3 /lang
parent99930980e9f1e9d89fd5dfae0c6061c2547da8e7 (diff)
downloadports-59ff92cfbdcea83ec3b162b338d6e3b9c3025735.tar.gz
ports-59ff92cfbdcea83ec3b162b338d6e3b9c3025735.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/ofc/Makefile8
-rw-r--r--lang/ofc/distinfo6
-rw-r--r--lang/ofc/pkg-plist14
3 files changed, 21 insertions, 7 deletions
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index f19b8e06fb32..1f57e49304a7 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -6,15 +6,19 @@
#
PORTNAME= ofc
-PORTVERSION= 0.7.1
+PORTVERSION= 0.8.0
CATEGORIES= lang
MASTER_SITES= http://ofc.dvoudheusden.net/download/
MAINTAINER= vanilla@FreeBSD.org
COMMENT= The Objective-C Foundation Classes library
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ freetype.9:${PORTSDIR}/print/freetype2
+USE_SDL= sdl
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
diff --git a/lang/ofc/distinfo b/lang/ofc/distinfo
index cd6bc3d77ec5..fb980af5eb87 100644
--- a/lang/ofc/distinfo
+++ b/lang/ofc/distinfo
@@ -1,3 +1,3 @@
-MD5 (ofc-0.7.1.tar.gz) = 4f5dd5190b1b1d8f68a924610e72f856
-SHA256 (ofc-0.7.1.tar.gz) = 17b269d1a30fc89bcf80ec0385a004f0ab5db15a5f01952a8b225d64a0ee3f61
-SIZE (ofc-0.7.1.tar.gz) = 775199
+MD5 (ofc-0.8.0.tar.gz) = df954a1a6cd11796506ea0589f3bf3d1
+SHA256 (ofc-0.8.0.tar.gz) = 5e02c1bffae669d323188a179385d3a3178b6a3b4213e5aa2c45646d81d9f307
+SIZE (ofc-0.8.0.tar.gz) = 901787
diff --git a/lang/ofc/pkg-plist b/lang/ofc/pkg-plist
index fb092a229bc6..fdb3bcfdc231 100644
--- a/lang/ofc/pkg-plist
+++ b/lang/ofc/pkg-plist
@@ -30,16 +30,21 @@ include/ofc/DDouble.h
include/ofc/DDoubleArray.h
include/ofc/DDrawable.h
include/ofc/DFSM.h
+include/ofc/DFTPClient.h
include/ofc/DFile.h
include/ofc/DFixedPoint.h
+include/ofc/DFont.h
include/ofc/DFraction.h
include/ofc/DGZipFile.h
include/ofc/DGraph.h
+include/ofc/DGraphicScreen.h
include/ofc/DHTTPClient.h
include/ofc/DHashTable.h
+include/ofc/DImage.h
include/ofc/DImageHeader.h
include/ofc/DInt.h
include/ofc/DIntArray.h
+include/ofc/DJPEGImage.h
include/ofc/DKey.h
include/ofc/DLRnd.h
include/ofc/DLexer.h
@@ -48,7 +53,9 @@ include/ofc/DLog.h
include/ofc/DLogger.h
include/ofc/DLong.h
include/ofc/DMD5.h
+include/ofc/DMRnd.h
include/ofc/DObjcTokenizer.h
+include/ofc/DPNGImage.h
include/ofc/DParsable.h
include/ofc/DPropertyTree.h
include/ofc/DQueuable.h
@@ -56,6 +63,8 @@ include/ofc/DRandomable.h
include/ofc/DRegEx.h
include/ofc/DRnd.h
include/ofc/DSHA1.h
+include/ofc/DSHA256.h
+include/ofc/DSimpleFont.h
include/ofc/DScore.h
include/ofc/DScreenHandler.h
include/ofc/DShort.h
@@ -82,6 +91,7 @@ include/ofc/DTextable.h
include/ofc/DTimer.h
include/ofc/DTokenizer.h
include/ofc/DTree.h
+include/ofc/DTrueTypeFont.h
include/ofc/DUDPClient.h
include/ofc/DUDPServer.h
include/ofc/DURL.h
@@ -94,6 +104,6 @@ include/ofc/warning.h
lib/libofc.a
lib/libofc.la
lib/libofc.so
-lib/libofc-0.7.so
-lib/libofc-0.7.so.1
+lib/libofc-0.8.so
+lib/libofc-0.8.so.0
@dirrm include/ofc