aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-29 20:58:03 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-29 20:58:03 +0000
commitcb8d6c382f3376fd1355e81546d38d75b2703a8c (patch)
tree5397bafdbe2b13f1133a3300ca425bab3f0940d8 /lang
parent2ecac6688584df78d95e545a1b9ea627fec88ed3 (diff)
downloadports-cb8d6c382f3376fd1355e81546d38d75b2703a8c.tar.gz
ports-cb8d6c382f3376fd1355e81546d38d75b2703a8c.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/ghc/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 104c1c48e637..ec53ae67f256 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -24,7 +24,13 @@ BOOT_DIST4= ghc-${PORTVERSION}-i386-unknown-freebsd4-boot${EXTRACT_SUFX}:boot
BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
BOOT_DIST= ghc-${PORTVERSION}-i386-unknown-freebsd6-boot${EXTRACT_SUFX}:boot
+USE_AUTOTOOLS= autoconf:259:env
USE_BZIP2= yes
+LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
+
+USE_PERL5= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
OPTIONS= PROFILE "Compile for profiling as well" on
@@ -45,13 +51,6 @@ IGNORE= unsupported at the moment
IGNORE= unsupported at the moment
.endif
-USE_AUTOTOOLS= autoconf:259:env
-LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-
-USE_PERL5= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
PLIST_SUB+= GHC_VERSION=${PORTVERSION}
.if defined(WITHOUT_PROFILE)
PLIST_SUB+= PROFILE="@comment "