aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-27 22:09:15 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-27 22:09:15 +0000
commit56c5e147c5396562dca765fc853f6536e148caf3 (patch)
tree109572ce53c493535c15b3fea78d257250399f06 /lang
parent81ac72867fea511ae2ea47fc25f31fdab9b56331 (diff)
downloadports-56c5e147c5396562dca765fc853f6536e148caf3.tar.gz
ports-56c5e147c5396562dca765fc853f6536e148caf3.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/fpc/Makefile.units2
-rw-r--r--lang/gcc-aux/Makefile.common2
-rw-r--r--lang/ghc/bsd.cabal.mk2
-rw-r--r--lang/gnat-aux/Makefile.common2
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php52/Makefile.ext4
-rw-r--r--lang/php53/Makefile.ext4
7 files changed, 10 insertions, 10 deletions
diff --git a/lang/fpc/Makefile.units b/lang/fpc/Makefile.units
index 3bedf197ec54..3d83adcbf317 100644
--- a/lang/fpc/Makefile.units
+++ b/lang/fpc/Makefile.units
@@ -139,7 +139,7 @@ USE_FIREBIRD= yes
.endif
.if ${PKGNAMESUFFIX} == "-iconvenc"
-USE_ICONV= yes
+USES+= iconv
.endif
.if ${PKGNAMESUFFIX} == "-ide"
diff --git a/lang/gcc-aux/Makefile.common b/lang/gcc-aux/Makefile.common
index 834ff8bdd45f..b491618c4ebc 100644
--- a/lang/gcc-aux/Makefile.common
+++ b/lang/gcc-aux/Makefile.common
@@ -9,7 +9,7 @@ ONLY_FOR_ARCHS= i386 amd64
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
USE_PERL5_BUILD= yes
ALL_TARGET= default
MAKE_JOBS_SAFE= yes
diff --git a/lang/ghc/bsd.cabal.mk b/lang/ghc/bsd.cabal.mk
index 39ef7366e4e0..88f9e56d460b 100644
--- a/lang/ghc/bsd.cabal.mk
+++ b/lang/ghc/bsd.cabal.mk
@@ -99,7 +99,7 @@ CONFIGURE_ARGS+= --with-c2hs=${C2HS_CMD}
.if defined(EXECUTABLE)
LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
-USE_ICONV= yes
+USES+= iconv
.endif
.if defined(USE_CABAL)
diff --git a/lang/gnat-aux/Makefile.common b/lang/gnat-aux/Makefile.common
index aeb9a22eaf87..17414119c29d 100644
--- a/lang/gnat-aux/Makefile.common
+++ b/lang/gnat-aux/Makefile.common
@@ -9,7 +9,7 @@ ONLY_FOR_ARCHS= i386 amd64
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
USE_PERL5_BUILD= yes
ALL_TARGET= default
MAKE_JOBS_SAFE= yes
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 52ad9db482df..24cb5a06dfa8 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -128,7 +128,7 @@ CONFIGURE_ARGS+=--enable-hash \
.if ${PHP_MODNAME} == "iconv"
CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
.endif
.if ${PHP_MODNAME} == "imap"
@@ -427,7 +427,7 @@ CONFIGURE_ARGS+=--with-xmlrpc \
--with-libxml-dir=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc
diff --git a/lang/php52/Makefile.ext b/lang/php52/Makefile.ext
index 8822180a7b68..61238449d000 100644
--- a/lang/php52/Makefile.ext
+++ b/lang/php52/Makefile.ext
@@ -136,7 +136,7 @@ CONFIGURE_ARGS+=--enable-hash
CONFIGURE_ARGS+=--with-iconv=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
.endif
.if ${PHP_MODNAME} == "imap"
@@ -481,7 +481,7 @@ CONFIGURE_ARGS+=--with-xmlrpc \
--with-libxml-dir=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 5ab590dc81ae..506597091cbe 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -127,7 +127,7 @@ CONFIGURE_ARGS+=--enable-hash \
.if ${PHP_MODNAME} == "iconv"
CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
.endif
.if ${PHP_MODNAME} == "imap"
@@ -432,7 +432,7 @@ CONFIGURE_ARGS+=--with-xmlrpc \
--with-libxml-dir=${LOCALBASE} \
--with-iconv-dir=${LOCALBASE}
-USE_ICONV= yes
+USES+= iconv
USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc