aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-04-17 00:18:05 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-04-17 00:18:05 +0000
commit877b8a533b44bb6324ebbaf65cd80a60d1572003 (patch)
treee1a018208ceade04ca56a70c5184978cac51853e /lang
parentd12f14432cc492205cefb505a3c1320dd0f4e31a (diff)
downloadports-877b8a533b44bb6324ebbaf65cd80a60d1572003.tar.gz
ports-877b8a533b44bb6324ebbaf65cd80a60d1572003.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/modula-3-lib/Makefile4
-rw-r--r--lang/modula-3/Makefile4
-rw-r--r--lang/python-devel/Makefile8
3 files changed, 7 insertions, 9 deletions
diff --git a/lang/modula-3-lib/Makefile b/lang/modula-3-lib/Makefile
index e6854379fdcb..514e4dd7129a 100644
--- a/lang/modula-3-lib/Makefile
+++ b/lang/modula-3-lib/Makefile
@@ -73,11 +73,11 @@ libdir= lib/m3/FreeBSD2
major= 6
# Support building on systems with or without X11 installed.
-.ifdef NO_X11
+.ifdef WITHOUT_X11
PLIST= ${WRKDIR}/PLIST.noX11
.else
pre-fetch:
- @${ECHO_MSG} "To build this port without X11, define \"NO_X11\"."
+ @${ECHO_MSG} "To build this port without X11, define \"WITHOUT_X11\"."
USE_XLIB= yes
PLIST= ${WRKDIR}/PLIST
diff --git a/lang/modula-3/Makefile b/lang/modula-3/Makefile
index 3cf1ef0249ad..1ce14f3901a4 100644
--- a/lang/modula-3/Makefile
+++ b/lang/modula-3/Makefile
@@ -33,11 +33,11 @@ major= 6
temp_prefix= ${WRKSRC}/installed
# Support building on systems with or without X11 installed.
-.ifdef NO_X11
+.ifdef WITHOUT_X11
PLIST= ${WRKDIR}/PLIST.noX11
.else
pre-fetch:
- @${ECHO_MSG} "To build this port without X11, define \"NO_X11\"."
+ @${ECHO_MSG} "To build this port without X11, define \"WITHOUT_X11\"."
PLIST= ${WRKDIR}/PLIST
MAN1+= formsedit.1 replayheap.1 showheap.1 shownew.1 showthread.1
diff --git a/lang/python-devel/Makefile b/lang/python-devel/Makefile
index 311e9a39b235..954c1d45a6ea 100644
--- a/lang/python-devel/Makefile
+++ b/lang/python-devel/Makefile
@@ -36,9 +36,8 @@ SETUP_FILE= Setup
#
# This option is enabled by default.
#
-WITH_THREADS?= yes
LIBC_R!= /sbin/ldconfig -r | grep c_r || true
-.if ${LIBC_R} != "" && defined(WITH_THREADS) && ${WITH_THREADS} == yes
+.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-thread
CFLAGS+= -D_THREAD_SAFE
CONFIGURE_ENV+= LDFLAGS="-pthread ${LDFLAGS}"
@@ -57,8 +56,7 @@ PLIST_GMP= ${PKGDIR}/PLIST.gmp
# to a web tree checker, to a collection of simple scripts that are useful
# while extending or managing Python.
#
-WITH_TOOLS?= yes
-.if defined(WITH_TOOLS) && ${WITH_TOOLS} == yes
+.if !defined(WITHOUT_TOOLS)
PLIST_TOOLS= ${PKGDIR}/PLIST.Tools
.endif
@@ -99,7 +97,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el ${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/Misc/COPYRIGHT ${PREFIX}/share/doc/python
@${MKDIR} ${PREFIX}/lib/python1.5/site-packages
-.if defined(WITH_TOOLS) && ${WITH_TOOLS} == yes
+.if !defined(WITHOUT_TOOLS)
@cd ${WRKSRC}; tar cf - Tools | \
(cd ${PREFIX}/lib/python1.5; tar xf -)
.endif