aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-08-14 04:14:19 +0000
committerSteve Wills <swills@FreeBSD.org>2011-08-14 04:14:19 +0000
commitac5b382b59ecd722297771766ae4fe8a3239e19b (patch)
tree3f95a40cb322ac007c68123049172736434ecc6a /lang
parentc7fa2c68482c835ea9c61e04029cc15d8b7bd4c3 (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/p5-POE-Component-Hailo/Makefile29
-rw-r--r--lang/p5-POE-Component-Hailo/distinfo2
-rw-r--r--lang/p5-POE-Component-Hailo/files/patch-Makefile.PL.in16
-rw-r--r--lang/p5-POE-Component-Hailo/pkg-descr5
-rw-r--r--lang/p5-POE-Component-Hailo/pkg-plist7
6 files changed, 60 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 13d827a7b1e6..bbc03ed85c75 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -213,6 +213,7 @@
SUBDIR += p5-JavaScript-Value-Escape
SUBDIR += p5-List-MoreUtils
SUBDIR += p5-Modern-Perl
+ SUBDIR += p5-POE-Component-Hailo
SUBDIR += p5-Parse-Perl
SUBDIR += p5-Perl6-Subs
SUBDIR += p5-Pugs-Compiler-Rule
diff --git a/lang/p5-POE-Component-Hailo/Makefile b/lang/p5-POE-Component-Hailo/Makefile
new file mode 100644
index 000000000000..79c50de159d5
--- /dev/null
+++ b/lang/p5-POE-Component-Hailo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: POE-Componenet-Hailo
+# Date created: 2011-07-19
+# Whom: milki <milki@rescomp.berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Hailo
+PORTVERSION= 0.10
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:HINRIK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.berkeley.edu
+COMMENT= A non-blocking wrapper around Hailo
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-Hailo>=0:${PORTSDIR}/textproc/p5-Hailo
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Hailo.3
+
+.include <bsd.port.mk>
diff --git a/lang/p5-POE-Component-Hailo/distinfo b/lang/p5-POE-Component-Hailo/distinfo
new file mode 100644
index 000000000000..c244fb24634c
--- /dev/null
+++ b/lang/p5-POE-Component-Hailo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (POE-Component-Hailo-0.10.tar.gz) = 2fb1a36b2bf4ed1b055be0427be95fad441f5c9bbc42dbc0f216d01d3f558edc
+SIZE (POE-Component-Hailo-0.10.tar.gz) = 12258
diff --git a/lang/p5-POE-Component-Hailo/files/patch-Makefile.PL.in b/lang/p5-POE-Component-Hailo/files/patch-Makefile.PL.in
new file mode 100644
index 000000000000..443861cf9f7b
--- /dev/null
+++ b/lang/p5-POE-Component-Hailo/files/patch-Makefile.PL.in
@@ -0,0 +1,16 @@
+--- Makefile.PL.new 2011-07-29 07:05:19.000000000 -0700
++++ Makefile.PL 2011-07-29 07:06:44.000000000 -0700
+@@ -48,5 +48,12 @@
+
+ WriteMakefile(%WriteMakefileArgs);
+
++package MY;
+
+-
++sub init_PM {
++ my $self = shift;
++ $self->SUPER::init_PM(@_);
++ # Do not install the README and README.pod
++ delete $self->{PM}{"README.pod"};
++ delete $self->{PM}{"README"};
++}
diff --git a/lang/p5-POE-Component-Hailo/pkg-descr b/lang/p5-POE-Component-Hailo/pkg-descr
new file mode 100644
index 000000000000..b5c882c113ca
--- /dev/null
+++ b/lang/p5-POE-Component-Hailo/pkg-descr
@@ -0,0 +1,5 @@
+POE::Component::Hailo is a POE component that provides a non-blocking wrapper
+around Hailo. It accepts the events listed under "INPUT" and emits the events
+listed under "OUTPUT".
+
+WWW: http://search.cpan.org/dist/POE-Component-Hailo/
diff --git a/lang/p5-POE-Component-Hailo/pkg-plist b/lang/p5-POE-Component-Hailo/pkg-plist
new file mode 100644
index 000000000000..6103a50d4c93
--- /dev/null
+++ b/lang/p5-POE-Component-Hailo/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/POE/Component/Hailo.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Hailo/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Hailo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE