aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-02-18 17:53:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-02-18 17:53:53 +0000
commitc70027929c625a6c7a644180cb76d4bdfcf68a9c (patch)
treef1b6b8247bd5625e6389d008814bb35ab4ac68e1 /lang
parent02e663d404dab2d7e03c52ba8aa40a5c0efd8bb7 (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python25/Makefile2
-rw-r--r--lang/python25/files/patch-CVE-2012-084514
-rw-r--r--lang/python26/Makefile2
-rw-r--r--lang/python26/files/patch-CVE-2012-084514
-rw-r--r--lang/python27/Makefile2
-rw-r--r--lang/python27/files/patch-CVE-2012-084514
-rw-r--r--lang/python31/Makefile2
-rw-r--r--lang/python31/files/patch-CVE-2012-084515
-rw-r--r--lang/python31/pr-patch23
-rw-r--r--lang/python32/Makefile2
-rw-r--r--lang/python32/files/patch-CVE-2012-084546
11 files changed, 131 insertions, 5 deletions
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 6cf4d9f83670..d8d22f3e06f6 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python25
PORTVERSION= 2.5.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python25/files/patch-CVE-2012-0845 b/lang/python25/files/patch-CVE-2012-0845
new file mode 100644
index 000000000000..a205a7de0ea5
--- /dev/null
+++ b/lang/python25/files/patch-CVE-2012-0845
@@ -0,0 +1,14 @@
+--- Lib/SimpleXMLRPCServer.py.orig 2011-06-11 19:46:23.000000000 +0400
++++ Lib/SimpleXMLRPCServer.py 2012-02-15 12:50:23.000000000 +0400
+@@ -486,7 +486,10 @@
+ L = []
+ while size_remaining:
+ chunk_size = min(size_remaining, max_chunk_size)
+- L.append(self.rfile.read(chunk_size))
++ chunk = self.rfile.read(chunk_size)
++ if not chunk:
++ break
++ L.append(chunk)
+ size_remaining -= len(L[-1])
+ data = ''.join(L)
+
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 9cf3a9ba3883..5b5ad11f5af9 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python26
PORTVERSION= 2.6.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python26/files/patch-CVE-2012-0845 b/lang/python26/files/patch-CVE-2012-0845
new file mode 100644
index 000000000000..a205a7de0ea5
--- /dev/null
+++ b/lang/python26/files/patch-CVE-2012-0845
@@ -0,0 +1,14 @@
+--- Lib/SimpleXMLRPCServer.py.orig 2011-06-11 19:46:23.000000000 +0400
++++ Lib/SimpleXMLRPCServer.py 2012-02-15 12:50:23.000000000 +0400
+@@ -486,7 +486,10 @@
+ L = []
+ while size_remaining:
+ chunk_size = min(size_remaining, max_chunk_size)
+- L.append(self.rfile.read(chunk_size))
++ chunk = self.rfile.read(chunk_size)
++ if not chunk:
++ break
++ L.append(chunk)
+ size_remaining -= len(L[-1])
+ data = ''.join(L)
+
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 384423adf231..8e24a7fb28d0 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python27
PORTVERSION= 2.7.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python27/files/patch-CVE-2012-0845 b/lang/python27/files/patch-CVE-2012-0845
new file mode 100644
index 000000000000..a205a7de0ea5
--- /dev/null
+++ b/lang/python27/files/patch-CVE-2012-0845
@@ -0,0 +1,14 @@
+--- Lib/SimpleXMLRPCServer.py.orig 2011-06-11 19:46:23.000000000 +0400
++++ Lib/SimpleXMLRPCServer.py 2012-02-15 12:50:23.000000000 +0400
+@@ -486,7 +486,10 @@
+ L = []
+ while size_remaining:
+ chunk_size = min(size_remaining, max_chunk_size)
+- L.append(self.rfile.read(chunk_size))
++ chunk = self.rfile.read(chunk_size)
++ if not chunk:
++ break
++ L.append(chunk)
+ size_remaining -= len(L[-1])
+ data = ''.join(L)
+
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index f4b9260ca7f1..22935d91857c 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python31
PORTVERSION= 3.1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python31/files/patch-CVE-2012-0845 b/lang/python31/files/patch-CVE-2012-0845
new file mode 100644
index 000000000000..9a381c22e345
--- /dev/null
+++ b/lang/python31/files/patch-CVE-2012-0845
@@ -0,0 +1,15 @@
+diff --git a/Lib/xmlrpc/server.py b/Lib/xmlrpc/server.py
+--- Lib/xmlrpc/server.py
++++ Lib/xmlrpc/server.py
+@@ -476,7 +476,10 @@
+ L = []
+ while size_remaining:
+ chunk_size = min(size_remaining, max_chunk_size)
+- L.append(self.rfile.read(chunk_size))
++ chunk = self.rfile.read(chunk_size)
++ if not chunk:
++ break
++ L.append(chunk)
+ size_remaining -= len(L[-1])
+ data = b''.join(L)
+
diff --git a/lang/python31/pr-patch b/lang/python31/pr-patch
new file mode 100644
index 000000000000..7f8e8b5c286b
--- /dev/null
+++ b/lang/python31/pr-patch
@@ -0,0 +1,23 @@
+
+--- python31ppc.diff begins here ---
+Index: files/patch-Modules-_ctypes-libffi-src-powerpc-ffitarget.h
+===================================================================
+RCS file: files/patch-Modules-_ctypes-libffi-src-powerpc-ffitarget.h
+diff -N files/patch-Modules-_ctypes-libffi-src-powerpc-ffitarget.h
+--- /dev/null 1 Jan 1970 00:00:00 -0000
++++ files/patch-Modules-_ctypes-libffi-src-powerpc-ffitarget.h 17 Nov 2011 05:09:15 -0000
+@@ -0,0 +1,11 @@
++--- Modules/_ctypes/libffi/src/powerpc/ffitarget.h.orig 2011-11-16 20:32:42.000000000 -0800
+++++ Modules/_ctypes/libffi/src/powerpc/ffitarget.h 2011-11-16 20:33:23.000000000 -0800
++@@ -78,6 +78,8 @@
++ FFI_SYSV,
++ FFI_GCC_SYSV,
++ FFI_LINUX64,
+++ FFI_LINUX,
+++ FFI_LINUX_SOFT_FLOAT,
++ FFI_DEFAULT_ABI = FFI_SYSV,
++ #endif
++
+--- python31ppc.diff ends here ---
+
+
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 7b4b52a1f6bf..32ed1a2e65f6 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python32
PORTVERSION= 3.2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python32/files/patch-CVE-2012-0845 b/lang/python32/files/patch-CVE-2012-0845
new file mode 100644
index 000000000000..e30dbe1e4532
--- /dev/null
+++ b/lang/python32/files/patch-CVE-2012-0845
@@ -0,0 +1,46 @@
+diff --git a/Lib/test/test_xmlrpc.py b/Lib/test/test_xmlrpc.py
+--- Lib/test/test_xmlrpc.py
++++ Lib/test/test_xmlrpc.py
+@@ -519,12 +519,7 @@
+
+ def tearDown(self):
+ # wait on the server thread to terminate
+- self.evt.wait(4.0)
+- # XXX this code does not work, and in fact stop_serving doesn't exist.
+- if not self.evt.is_set():
+- self.evt.set()
+- stop_serving()
+- raise RuntimeError("timeout reached, test has failed")
++ self.evt.wait()
+
+ # disable traceback reporting
+ xmlrpc.server.SimpleXMLRPCServer._send_traceback_header = False
+@@ -671,6 +666,13 @@
+ server = xmlrpclib.ServerProxy("http://%s:%d/RPC2" % (ADDR, PORT))
+ self.assertEqual(server.add("a", "\xe9"), "a\xe9")
+
++ def test_partial_post(self):
++ # Check that a partial POST doesn't make the server loop: issue #14001.
++ conn = http.client.HTTPConnection(ADDR, PORT)
++ conn.request('POST', '/RPC2 HTTP/1.0\r\nContent-Length: 100\r\n\r\nbye')
++ conn.close()
++
++
+ class MultiPathServerTestCase(BaseServerTestCase):
+ threadFunc = staticmethod(http_multi_server)
+ request_count = 2
+diff --git a/Lib/xmlrpc/server.py b/Lib/xmlrpc/server.py
+--- Lib/xmlrpc/server.py
++++ Lib/xmlrpc/server.py
+@@ -476,7 +476,10 @@
+ L = []
+ while size_remaining:
+ chunk_size = min(size_remaining, max_chunk_size)
+- L.append(self.rfile.read(chunk_size))
++ chunk = self.rfile.read(chunk_size)
++ if not chunk:
++ break
++ L.append(chunk)
+ size_remaining -= len(L[-1])
+ data = b''.join(L)
+