aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-13 13:30:42 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-13 13:30:42 +0000
commitbb34de42c0ccac8e962cab97e064965d23f081de (patch)
treedd40b82023ab94a6839b4f4d440c3cd5cab978ee /lang
parent533c87fa4d98c0e6100d18f59559906241ed4230 (diff)
downloadports-bb34de42c0ccac8e962cab97e064965d23f081de.tar.gz
ports-bb34de42c0ccac8e962cab97e064965d23f081de.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/diveintopython/Makefile4
-rw-r--r--lang/eperl/Makefile3
-rw-r--r--lang/fesi/Makefile2
-rw-r--r--lang/icc/Makefile4
-rw-r--r--lang/icc7/Makefile4
-rw-r--r--lang/ifc/Makefile4
-rw-r--r--lang/ifc7/Makefile4
-rw-r--r--lang/kawa/Makefile2
-rw-r--r--lang/sml-nj/Makefile2
9 files changed, 15 insertions, 14 deletions
diff --git a/lang/diveintopython/Makefile b/lang/diveintopython/Makefile
index a9b427b85c94..88f3426b0842 100644
--- a/lang/diveintopython/Makefile
+++ b/lang/diveintopython/Makefile
@@ -42,9 +42,9 @@ post-patch:
do-install:
@ ${MKDIR} ${DIPDLDIR}
- @ cd ${WRKSRC} && find *.html *.css images \
+ @ cd ${WRKSRC} && ${FIND} *.html *.css images \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
- @ cd ${WRKDIR}/py && find * \
+ @ cd ${WRKDIR}/py && ${FIND} * \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.for format in html html-flat pdf text word help xml common examples
@ ${INSTALL_DATA} \
diff --git a/lang/eperl/Makefile b/lang/eperl/Makefile
index 89e8648f25ba..675baab58bc5 100644
--- a/lang/eperl/Makefile
+++ b/lang/eperl/Makefile
@@ -35,7 +35,8 @@ test:
@(cd ${WRKSRC}; ${MAKE} test)
post-patch:
- @${FIND} ${WRKSRC} -type f -name "*.[ch]" | xargs ${GREP} -l strnstr | \
+ @${FIND} ${WRKSRC} -type f -name "*.[ch]" | \
+ ${XARGS} ${GREP} -l strnstr | \
${XARGS} ${PERL} -pi -e 's|strnstr|ePerl_strnstr|g'
do-install:
diff --git a/lang/fesi/Makefile b/lang/fesi/Makefile
index cd146ad04f7f..76eb52532412 100644
--- a/lang/fesi/Makefile
+++ b/lang/fesi/Makefile
@@ -24,7 +24,7 @@ JDK_VERSION= 1.1.8
WRKSRC= ${WRKDIR}/${PORTNAME}
post-extract:
- @(cd ${WRKSRC} && find * -type d -exec ${CHMOD} 755 {} \;)
+ @(cd ${WRKSRC} && ${FIND} * -type d -exec ${CHMOD} 755 {} \;)
do-install:
@${MKDIR} ${PREFIX}/share/java/classes ${PREFIX}/share/java/fesi
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index c7fb741a3b8e..5307be6e9df8 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -85,9 +85,9 @@ pre-patch:
# Remove unneeded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
- xargs -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
- @${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+ @${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
@${CHMOD} a-x ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/Errormatch.txt
# Use the Linux ABI for the binaries
.for i in iccbin iccfilt icid icpcbin icpi mcpcom profmerge proforder xiar xild
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index c7fb741a3b8e..5307be6e9df8 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -85,9 +85,9 @@ pre-patch:
# Remove unneeded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
- xargs -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
- @${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+ @${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
@${CHMOD} a-x ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/Errormatch.txt
# Use the Linux ABI for the binaries
.for i in iccbin iccfilt icid icpcbin icpi mcpcom profmerge proforder xiar xild
diff --git a/lang/ifc/Makefile b/lang/ifc/Makefile
index d78eabe30757..22ac742f92ea 100644
--- a/lang/ifc/Makefile
+++ b/lang/ifc/Makefile
@@ -77,9 +77,9 @@ pre-patch:
# Remove unneeded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
- xargs -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
- @${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+ @${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
# Use the Linux ABI for the binaries
.for i in ifcbin fpp icid f90com profmerge proforder xiar xild
@brandelf -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
diff --git a/lang/ifc7/Makefile b/lang/ifc7/Makefile
index d78eabe30757..22ac742f92ea 100644
--- a/lang/ifc7/Makefile
+++ b/lang/ifc7/Makefile
@@ -77,9 +77,9 @@ pre-patch:
# Remove unneeded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
- xargs -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
- @${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+ @${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
# Use the Linux ABI for the binaries
.for i in ifcbin fpp icid f90com profmerge proforder xiar xild
@brandelf -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
diff --git a/lang/kawa/Makefile b/lang/kawa/Makefile
index 7d8f16a523f9..bc3c22ab0659 100644
--- a/lang/kawa/Makefile
+++ b/lang/kawa/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ARGS= --enable-kawa-frontend
GNU_CONFIGURE= yes
pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi \
-e 's|sed |gsed |g;' \
-e 's|JAR = jar|JAR = ${JAR}|g;'
perl -pi -e 's|{JAVAC-javac}|{JAVAC-${JAVAC}}|g;' \
diff --git a/lang/sml-nj/Makefile b/lang/sml-nj/Makefile
index a5820da3364a..e8453ee486e7 100644
--- a/lang/sml-nj/Makefile
+++ b/lang/sml-nj/Makefile
@@ -65,7 +65,7 @@ do-install:
${SED} -e "s,^BIN_DIR=.*\$$,BIN_DIR=${SML_BINDIR}," \
< ${WRKDIR}/bin/.run-sml > ${SML_BINDIR}/.run-sml
${CHMOD} 755 ${SML_BINDIR}/.run-sml
- cd ${WRKDIR} && tar -cf - `find . -name x86-unix` | \
+ cd ${WRKDIR} && tar -cf - `${FIND} . -name x86-unix` | \
tar -C ${SML_BASE} -xf -
cd ${WRKDIR} && tar -cf - `${SCRIPTDIR}/get-cm ${WRKDIR}` | \
tar -C ${SML_BASE} -xf -