aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-13 02:43:12 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-13 02:43:12 +0000
commit5928a4a676925af42aff7424ff1a42ee29ae4d48 (patch)
tree85f718541981020c26b52ac8de6422462b59531d /lang
parent0158c347cf1d783723808b5962f68462dfdfea2a (diff)
downloadports-5928a4a676925af42aff7424ff1a42ee29ae4d48.tar.gz
ports-5928a4a676925af42aff7424ff1a42ee29ae4d48.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/rakudo/Makefile22
1 files changed, 20 insertions, 2 deletions
diff --git a/lang/rakudo/Makefile b/lang/rakudo/Makefile
index f0afc0512c64..cad2a1958e0e 100644
--- a/lang/rakudo/Makefile
+++ b/lang/rakudo/Makefile
@@ -21,6 +21,26 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
icudata:${PORTSDIR}/devel/icu
+# amd64 i386 sparc
+# 9-current pass gcc
+# 8-stable gcc pass
+# 7-stable pass pass
+# 6-stable icu icu
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == 'i386' && ${OSVERSION} >= 900000
+BROKEN= internal gcc bugs
+.endif
+
+.if ${ARCH} == 'i386' && ${OSVERSION} >= 800000 && ${OSVERSION} <= 900000
+BROKEN= internal gcc bugs
+.endif
+
+.if ${OSVERSION} < 700000
+BROKEN= dependency devel/icu is broken on 6.x
+.endif
+
USE_BISON= build
USE_PERL5= 5.8.0+
USE_GMAKE= yes
@@ -53,6 +73,4 @@ x-generate-plist:
.include "${.CURDIR}/../parrot/Makefile.common"
-.include <bsd.port.pre.mk>
-
.include <bsd.port.post.mk>