aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-28 22:58:33 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-28 22:58:33 +0000
commitb13d6b97033bf5856ecfeb0fc16b97e6b5b96e48 (patch)
tree98abe2da85ac50fe6184511cafc395b8dce0887c /lang
parente4310886316328ef68ba40cc6d736d2b85dd35a2 (diff)
downloadports-b13d6b97033bf5856ecfeb0fc16b97e6b5b96e48.tar.gz
ports-b13d6b97033bf5856ecfeb0fc16b97e6b5b96e48.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile3
-rw-r--r--lang/rust/files/patch-src__libuv__gyp_uv.py12
2 files changed, 15 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index e26bcf38875a..ad68dea2ec7f 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rust
PORTVERSION= 0.11.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://static.rust-lang.org/dist/:src \
http://static.rust-lang.org/stage0-snapshots/:bootstrap
@@ -59,5 +60,7 @@ post-install:
@${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/manifest
@${STRIP_CMD} `${GREP} -v -e '^@dirrm' -e '^man' -e 'rlib$$' \
${PLIST} | ${SED} 's:^:${STAGEDIR}${PREFIX}/:'`
+ @${STRIP_CMD} `${GREP} -v -e '^@dirrm' -e '^man' -e 'rlib$$' \
+ -e '\.a$$' ${PLIST} | ${SED} 's:^:${STAGEDIR}${PREFIX}/:g'`
.include <bsd.port.post.mk>
diff --git a/lang/rust/files/patch-src__libuv__gyp_uv.py b/lang/rust/files/patch-src__libuv__gyp_uv.py
new file mode 100644
index 000000000000..fdb69da9c7c5
--- /dev/null
+++ b/lang/rust/files/patch-src__libuv__gyp_uv.py
@@ -0,0 +1,12 @@
+--- ./src/libuv/gyp_uv.py.orig 2014-06-28 04:53:11.000000000 +0900
++++ ./src/libuv/gyp_uv.py 2014-07-17 12:32:13.000000000 +0900
+@@ -96,6 +96,9 @@
+
+ if sys.platform == 'darwin' and '-DOS=android' in sys.argv[1:]:
+ sys.platform='linux'
++
++ if sys.platform.startswith('freebsd'):
++ args.append('--no-parallel')
+
+ gyp_args = list(args)
+ print gyp_args