aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-07-03 07:16:03 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-07-03 07:16:03 +0000
commitc5c25db059b5d2e78fad19262e39456c98f76abb (patch)
tree0a3483bff944db6d3c5c37b2edf6bf23238b409a /lang
parent43633b07257d53e1729d29ba9af6c60a77175a06 (diff)
downloadports-c5c25db059b5d2e78fad19262e39456c98f76abb.tar.gz
ports-c5c25db059b5d2e78fad19262e39456c98f76abb.zip
lang/cint: Unbreak build with GCC 9
G__cpp_list.cxx: In function 'int G__list_49_0_10(G__value*, const char*, G__param*, int)': G__cpp_list.cxx:707:109: error: 'std::__cxx11::list<int, std::allocator<int> >::iterator' {aka 'struct std::_List_iterator<int>'} has no member named 'operator=='; did you mean 'operator='? 707 | G__letint(result7, 103, (long) ((list<int,allocator<int> >::iterator*) G__getstructoffset())->operator==(*(list<int,allocator<int> >::iterator*) libp->para[0].ref)); | ^~ | operator= G__cpp_list.cxx: In function 'int G__list_49_0_11(G__value*, const char*, G__param*, int)': G__cpp_list.cxx:713:109: error: 'std::__cxx11::list<int, std::allocator<int> >::iterator' {aka 'struct std::_List_iterator<int>'} has no member named 'operator!='; did you mean 'operator='? 713 | G__letint(result7, 103, (long) ((list<int,allocator<int> >::iterator*) G__getstructoffset())->operator!=(*(list<int,allocator<int> >::iterator*) libp->para[0].ref)); | ^~ | operator= http://pb2.nyi.freebsd.org/data/120i386-default-PR238330/2019-06-09_20h27m22s/logs/errors/cint-5.18.00_12.log While here make the build abort fast on build errors instead of carrying on like nothing happened. PR: 238907 Reported by: antoine (via exp-run in PR 238330)
Notes
Notes: svn path=/head/; revision=505728
Diffstat (limited to 'lang')
-rw-r--r--lang/cint/Makefile3
-rw-r--r--lang/cint/files/patch-cint_lib_prec__stl_list14
-rw-r--r--lang/cint/files/patch-cint_lib_prec__stl_map11
-rw-r--r--lang/cint/files/patch-cint_lib_prec__stl_multimap11
-rw-r--r--lang/cint/files/patch-cint_lib_prec__stl_multiset11
-rw-r--r--lang/cint/files/patch-cint_lib_prec__stl_set11
6 files changed, 60 insertions, 1 deletions
diff --git a/lang/cint/Makefile b/lang/cint/Makefile
index 4c1497f24bb1..97c20c30a486 100644
--- a/lang/cint/Makefile
+++ b/lang/cint/Makefile
@@ -35,7 +35,8 @@ OPTIONS_DEFINE= DOCS
post-patch:
${REINPLACE_CMD} 's,#!/bin/bash,#!${LOCALBASE}/bin/bash,' ${WRKSRC}/cint/lib/dll_stl/setup
- ${REINPLACE_CMD} 's,make ,${GMAKE} ,' ${WRKSRC}/cint/lib/*/setup
+ ${REINPLACE_CMD} -e 's,make ,${GMAKE} ,' -e '/${GMAKE}/ s,$$, || exit 1,' \
+ ${WRKSRC}/cint/lib/*/setup
do-configure:
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${LOCALBASE}/bin/bash configure __have_the_proper_shell@
diff --git a/lang/cint/files/patch-cint_lib_prec__stl_list b/lang/cint/files/patch-cint_lib_prec__stl_list
new file mode 100644
index 000000000000..a721ff084f86
--- /dev/null
+++ b/lang/cint/files/patch-cint_lib_prec__stl_list
@@ -0,0 +1,14 @@
+--- cint/lib/prec_stl/list.orig 2019-07-03 06:45:32 UTC
++++ cint/lib/prec_stl/list
+@@ -96,9 +96,11 @@ class list {
+ iterator operator++(int a);
+ iterator& operator--();
+ iterator operator--(int a);
++#if defined(G__GNUC_VER) && G__GNUC_VER<9000
+ bool operator==(const iterator& x) ;
+ #ifndef G__HPUX
+ bool operator!=(const iterator& x) ;
++#endif
+ #endif
+ #if defined(G__VISUAL) && (G__MSC_VER>=1600)
+ private:
diff --git a/lang/cint/files/patch-cint_lib_prec__stl_map b/lang/cint/files/patch-cint_lib_prec__stl_map
new file mode 100644
index 000000000000..95a9fa3fdac6
--- /dev/null
+++ b/lang/cint/files/patch-cint_lib_prec__stl_map
@@ -0,0 +1,11 @@
+--- cint/lib/prec_stl/map.orig 2019-07-03 06:37:58 UTC
++++ cint/lib/prec_stl/map
+@@ -115,7 +115,7 @@ class map {
+ iterator operator++(int a);
+ iterator& operator--();
+ iterator operator--(int a);
+-#if defined (G__VISUAL) || (defined(G__GNUC_VER) && G__GNUC_VER>=3004) || defined(G__INTEL_COMPILER)
++#if defined (G__VISUAL) || (defined(G__GNUC_VER) && G__GNUC_VER>=3004 && G__GNUC_VER<9000) || defined(G__INTEL_COMPILER)
+ bool operator==(const iterator& x) ;
+ bool operator!=(const iterator& x) ;
+ #endif
diff --git a/lang/cint/files/patch-cint_lib_prec__stl_multimap b/lang/cint/files/patch-cint_lib_prec__stl_multimap
new file mode 100644
index 000000000000..048446256460
--- /dev/null
+++ b/lang/cint/files/patch-cint_lib_prec__stl_multimap
@@ -0,0 +1,11 @@
+--- cint/lib/prec_stl/multimap.orig 2019-07-03 06:42:35 UTC
++++ cint/lib/prec_stl/multimap
+@@ -112,7 +112,7 @@ class multimap {
+ iterator operator++(int a);
+ iterator& operator--();
+ iterator operator--(int a);
+-#if defined (G__VISUAL) || (defined(G__GNUC) && G__GNUC_VER>=3004)
++#if defined (G__VISUAL) || (defined(G__GNUC) && G__GNUC_VER>=3004 && G__GNUC_VER<9000)
+ bool operator==(const iterator& x) ;
+ bool operator!=(const iterator& x) ;
+ #endif
diff --git a/lang/cint/files/patch-cint_lib_prec__stl_multiset b/lang/cint/files/patch-cint_lib_prec__stl_multiset
new file mode 100644
index 000000000000..33f956fa22be
--- /dev/null
+++ b/lang/cint/files/patch-cint_lib_prec__stl_multiset
@@ -0,0 +1,11 @@
+--- cint/lib/prec_stl/multiset.orig 2019-07-03 06:43:37 UTC
++++ cint/lib/prec_stl/multiset
+@@ -105,7 +105,7 @@ class multiset {
+ iterator operator++(int a);
+ iterator& operator--();
+ iterator operator--(int a);
+-#if defined (G__VISUAL) || (defined(G__GNUC) && G__GNUC_VER>=3004)
++#if defined (G__VISUAL) || (defined(G__GNUC) && G__GNUC_VER>=3004 && G__GNUC_VER<9000)
+ bool operator==(const iterator& x) ;
+ bool operator!=(const iterator& x) ;
+ #endif
diff --git a/lang/cint/files/patch-cint_lib_prec__stl_set b/lang/cint/files/patch-cint_lib_prec__stl_set
new file mode 100644
index 000000000000..608b3d06ad48
--- /dev/null
+++ b/lang/cint/files/patch-cint_lib_prec__stl_set
@@ -0,0 +1,11 @@
+--- cint/lib/prec_stl/set.orig 2019-07-03 06:41:45 UTC
++++ cint/lib/prec_stl/set
+@@ -105,7 +105,7 @@ class set {
+ iterator operator++(int a);
+ iterator& operator--();
+ iterator operator--(int a);
+-#if defined (G__VISUAL) || (defined(G__GNUC) && G__GNUC_VER>=3004)
++#if defined (G__VISUAL) || (defined(G__GNUC) && G__GNUC_VER>=3004 && G__GNUC_VER<9000)
+ bool operator==(const iterator& x) ;
+ bool operator!=(const iterator& x) ;
+ #endif