aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-11-01 23:49:56 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-11-01 23:49:56 +0000
commitf231f045727a3e52f179497a7ca3673e48993659 (patch)
tree41446c5fce16b3df26a3721bb21ae700e65dd068 /lang
parentc23a257c5eabf74a88a39e76b5c25dff00127baf (diff)
downloadports-f231f045727a3e52f179497a7ca3673e48993659.tar.gz
ports-f231f045727a3e52f179497a7ca3673e48993659.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php53-extensions/Makefile2
-rw-r--r--lang/php53/Makefile19
-rw-r--r--lang/php53/Makefile.ext46
-rw-r--r--lang/php53/files/patch-sapi_apache2filter_config.m411
-rw-r--r--lang/php53/files/patch-sapi_apache2handler_config.m411
-rw-r--r--lang/php53/pkg-plist4
6 files changed, 54 insertions, 39 deletions
diff --git a/lang/php53-extensions/Makefile b/lang/php53-extensions/Makefile
index 5555bbee321e..f9b6e0a5408c 100644
--- a/lang/php53-extensions/Makefile
+++ b/lang/php53-extensions/Makefile
@@ -16,6 +16,7 @@ IGNORE_WITH_PHP=5 52
USE_PHP_BUILD= yes
NO_BUILD= yes
+NO_MTREE= yes
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
@@ -111,7 +112,6 @@ XSL_DESC= XSL support (Implies DOM)
ZIP_DESC= ZIP support
ZLIB_DESC= ZLIB support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.for opt in ${OPTIONS_DEFINE}
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index e231091841c0..9df1f44f3735 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -18,7 +18,7 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS= \
--with-layout=GNU \
@@ -51,9 +51,8 @@ LINKTHR_DESC= Link thread lib (for threaded extensions)
CONFLICTS= php52-5* php5-5*
-MAN1= php-config.1 phpize.1
+DESTDIRNAME= INSTALL_ROOT
-NO_STAGE= yes
.include <bsd.port.pre.mk>
PATCH_DIST_STRIP= -p1
@@ -77,7 +76,6 @@ PATCH_SITES+= http://choon.net/opensource/php/:mail
.if ${PORT_OPTIONS:MCLI}
PHP_SAPI+= cli
PLIST_SUB+= CLI=""
-MAN1+= php.1
.else
PLIST_SUB+= CLI="@comment "
CONFIGURE_ARGS+=--disable-cli
@@ -93,7 +91,6 @@ CONFIGURE_ARGS+=--disable-cgi
.if ${PORT_OPTIONS:MFPM}
PHP_SAPI+= fpm
-MAN8+= php-fpm.8
USE_RC_SUBR+= php-fpm
CONFIGURE_ARGS+=--enable-fpm \
--with-fpm-user=${WWWOWN} \
@@ -180,16 +177,8 @@ test: build
@(cd ${WRKSRC} && ${MAKE} test)
post-install:
- @${INSTALL_DATA} ${WRKSRC}/php.ini-development ${PREFIX}/etc
- @${INSTALL_DATA} ${WRKSRC}/php.ini-production ${PREFIX}/etc
- @${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
- @${TOUCH} ${PREFIX}/include/php/ext/php_config.h
-.if ${PORT_OPTIONS:MFPM}
- @${CP} -n ${PREFIX}/etc/php-fpm.conf.default ${PREFIX}/etc/php-fpm.conf || ${TRUE}
-.endif
-.if ${PORT_OPTIONS:MAPACHE}
- @${CAT} ${PKGMESSAGE}
-.endif
+ @${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \
+ ${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc
.else
.include "${MASTERDIR}/Makefile.ext"
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index cf2d461c3fb7..8b488f0c822a 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--enable-ctype
.endif
.if ${PHP_MODNAME} == "curl"
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--with-curl=${LOCALBASE}
.endif
@@ -87,9 +87,9 @@ USE_OPENSSL= yes
.endif
.if ${PHP_MODNAME} == "gd"
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libfreetype.so.9:${PORTSDIR}/print/freetype2 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so.11:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+=--with-gd \
--with-freetype-dir=${LOCALBASE} \
@@ -114,7 +114,7 @@ USES+= gettext
.endif
.if ${PHP_MODNAME} == "gmp"
-LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
+LIB_DEPENDS+= libgmp.so.10:${PORTSDIR}/math/gmp
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
.endif
@@ -133,7 +133,7 @@ USES+= iconv
.if ${PHP_MODNAME} == "imap"
OPTIONS_DEFINE= SSL
OPTIONS_DEFAULT= SSL
-LIB_DEPENDS+= c-client4.9:${PORTSDIR}/mail/cclient
+LIB_DEPENDS+= libc-client4.so.9:${PORTSDIR}/mail/cclient
CONFIGURE_ARGS+=--with-imap=${LOCALBASE} \
--with-pcre-dir=${LOCALBASE}
@@ -174,7 +174,7 @@ PHP_HEADER_DIRS=libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
.endif
.if ${PHP_MODNAME} == "mcrypt"
-LIB_DEPENDS+= mcrypt.8:${PORTSDIR}/security/libmcrypt
+LIB_DEPENDS+= libmcrypt.so.8:${PORTSDIR}/security/libmcrypt
CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
@@ -182,7 +182,7 @@ USE_AUTOTOOLS= libltdl
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds-msdblib
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -297,7 +297,7 @@ CONFIGURE_ARGS+=--enable-posix
.endif
.if ${PHP_MODNAME} == "pspell"
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= libaspell.so.16:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
@@ -311,7 +311,7 @@ CONFIGURE_ARGS+=--with-readline=/usr
.endif
.if ${PHP_MODNAME} == "recode"
-LIB_DEPENDS+= recode.3:${PORTSDIR}/converters/recode
+LIB_DEPENDS+= librecode.so.3:${PORTSDIR}/converters/recode
CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.endif
@@ -338,7 +338,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS+= libnetsnmp.so.30:${PORTSDIR}/net-mgmt/net-snmp
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -375,7 +375,7 @@ CONFIGURE_ARGS+=--with-sqlite3=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "sybase_ct"
-LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libct.so.4:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-sybase-ct=${LOCALBASE}
.endif
@@ -395,7 +395,7 @@ CONFIGURE_ARGS+=--enable-sysvshm
.if ${PHP_MODNAME} == "tidy"
CONFIGURE_ARGS+=--with-tidy=${LOCALBASE}
-LIB_DEPENDS+= tidy-0.99.0:${PORTSDIR}/www/tidy-lib
+LIB_DEPENDS+= libtidy-0.99.so.0:${PORTSDIR}/www/tidy-lib
.endif
.if ${PHP_MODNAME} == "tokenizer"
@@ -480,12 +480,12 @@ USE_BDB= 40+
WITH_BDB_HIGHEST= yes
. endif
. if ${PORT_OPTIONS:MGDBM}
-LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so.4:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MQDBM}
-LIB_DEPENDS+= qdbm.14:${PORTSDIR}/databases/qdbm
+LIB_DEPENDS+= libqdbm.so.14:${PORTSDIR}/databases/qdbm
CONFIGURE_ARGS+=--with-qdbm=${LOCALBASE}
. endif
@@ -507,7 +507,7 @@ CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MT1LIB}
-LIB_DEPENDS+= t1.5:${PORTSDIR}/devel/t1lib
+LIB_DEPENDS+= libt1.so.5:${PORTSDIR}/devel/t1lib
CONFIGURE_ARGS+=--with-t1lib=${LOCALBASE}
. endif
@@ -528,7 +528,7 @@ LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
.if ${PHP_MODNAME} == "mbstring"
. if ${PORT_OPTIONS:MREGEX}
-LIB_DEPENDS+= onig.1:${PORTSDIR}/devel/oniguruma4
+LIB_DEPENDS+= libonig.so.1:${PORTSDIR}/devel/oniguruma4
CONFIGURE_ARGS+=--with-onig=${LOCALBASE}
. else
CONFIGURE_ARGS+=--disable-mbregex
@@ -563,11 +563,11 @@ post-extract:
.if ${PHP_MODNAME} == "odbc"
.if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= libiodbc.so.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-iodbc=${LOCALBASE}
.else
-LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.endif
@@ -575,19 +575,19 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.if ${PHP_MODNAME} == "pdo_dblib"
.if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds-msdblib
.else
-LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libct.so.4:${PORTSDIR}/databases/freetds
.endif
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
.if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= libiodbc.so.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-pdo-odbc=iODBC,${LOCALBASE}
.else
-LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
.endif
diff --git a/lang/php53/files/patch-sapi_apache2filter_config.m4 b/lang/php53/files/patch-sapi_apache2filter_config.m4
new file mode 100644
index 000000000000..ce71383f9fa4
--- /dev/null
+++ b/lang/php53/files/patch-sapi_apache2filter_config.m4
@@ -0,0 +1,11 @@
+--- sapi/apache2filter/config.m4.orig 2013-10-18 12:17:14.622544934 +0000
++++ sapi/apache2filter/config.m4 2013-10-18 12:22:13.032234760 +0000
+@@ -68,7 +68,7 @@
+ fi
+
+ APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
+- if test -z `$APXS -q SYSCONFDIR`; then
++ if true; then
+ INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
+ $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
+ -i -n php5"
diff --git a/lang/php53/files/patch-sapi_apache2handler_config.m4 b/lang/php53/files/patch-sapi_apache2handler_config.m4
new file mode 100644
index 000000000000..149c4ef0fc80
--- /dev/null
+++ b/lang/php53/files/patch-sapi_apache2handler_config.m4
@@ -0,0 +1,11 @@
+--- sapi/apache2handler/config.m4.orig 2013-10-18 12:22:26.576545216 +0000
++++ sapi/apache2handler/config.m4 2013-10-18 12:23:00.903131412 +0000
+@@ -67,7 +67,7 @@
+ fi
+
+ APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
+- if test -z `$APXS -q SYSCONFDIR`; then
++ if true; then
+ INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
+ $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
+ -i -n php5"
diff --git a/lang/php53/pkg-plist b/lang/php53/pkg-plist
index 26bbd01e52ce..ac4fcacd6aaa 100644
--- a/lang/php53/pkg-plist
+++ b/lang/php53/pkg-plist
@@ -233,6 +233,10 @@ lib/php/build/phpize.m4
lib/php/build/run-tests.php
lib/php/build/scan_makefile_in.awk
lib/php/build/shtool
+man/man1/php-config.1.gz
+man/man1/phpize.1.gz
+%%CLI%%man/man1/php.1.gz
+%%FPM%%man/man8/php-fpm.8.gz
%%APACHE%%%%APACHEMODDIR%%/%%AP_MODULE%%
%%APACHE%%@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %f
%%APACHE%%@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %f