aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-09-07 14:30:03 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-09-07 14:30:03 +0000
commit570f1b227ce7fdadb7c031679c3aa93fe5f7ee70 (patch)
treec02f89a59a7e138b929074a6ed263c97f8eeabdd /lang
parenteb6b6a7d155e64e16cd7a0a1323db82d2f504dd6 (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile.ext7
-rw-r--r--lang/php53/Makefile.ext7
2 files changed, 14 insertions, 0 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index f969b6883ae1..a6c8f54be6bd 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -61,6 +61,13 @@ USE_GNOME= libxml2
CONFIGURE_ARGS+=--enable-exif
.endif
+.if ${PHP_MODNAME} == "fileinfo"
+CONFIGURE_ARGS+=--enable-fileinfo \
+ --with-pcre-dir=${LOCALBASE}
+
+PHP_HEADER_DIRS= libmagic
+.endif
+
.if ${PHP_MODNAME} == "filter"
CONFIGURE_ARGS+=--enable-filter \
--with-pcre-dir=${LOCALBASE}
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index f969b6883ae1..a6c8f54be6bd 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -61,6 +61,13 @@ USE_GNOME= libxml2
CONFIGURE_ARGS+=--enable-exif
.endif
+.if ${PHP_MODNAME} == "fileinfo"
+CONFIGURE_ARGS+=--enable-fileinfo \
+ --with-pcre-dir=${LOCALBASE}
+
+PHP_HEADER_DIRS= libmagic
+.endif
+
.if ${PHP_MODNAME} == "filter"
CONFIGURE_ARGS+=--enable-filter \
--with-pcre-dir=${LOCALBASE}