aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2018-07-06 07:16:31 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2018-07-06 07:16:31 +0000
commit9a01bd29f0d14d8b51f9adce9bd3d41241d7505e (patch)
treea54ee5bac8cabbf2c18f52f5711957caa54a5e55 /lang
parent65b7324d7a2a2a8c728ecff2c5f10baae461cd04 (diff)
downloadports-9a01bd29f0d14d8b51f9adce9bd3d41241d7505e.tar.gz
ports-9a01bd29f0d14d8b51f9adce9bd3d41241d7505e.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/pypy3/distinfo6
-rw-r--r--lang/pypy3/files/patch-pypy_config_pypyoption.py11
-rw-r--r--lang/pypy3/files/patch-rpython_rlib_rvmprof_cintf.py11
-rw-r--r--lang/pypy3/pkg-descr4
-rw-r--r--lang/pypy3/pkg-plist3
5 files changed, 19 insertions, 16 deletions
diff --git a/lang/pypy3/distinfo b/lang/pypy3/distinfo
index 4ef07fdf7760..27cb6c84762d 100644
--- a/lang/pypy3/distinfo
+++ b/lang/pypy3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1515949994
-SHA256 (pypy3-v5.10.1-src.tar.bz2) = f5548e06e2fc0c24ec8b6e3c5b09f90081818f7caa3e436dc312592611724713
-SIZE (pypy3-v5.10.1-src.tar.bz2) = 29071765
+TIMESTAMP = 1530700264
+SHA256 (pypy3-v6.0.0-src.tar.bz2) = ed8005202b46d6fc6831df1d13a4613bc40084bfa42f275068edadf8954034a3
+SIZE (pypy3-v6.0.0-src.tar.bz2) = 22648140
diff --git a/lang/pypy3/files/patch-pypy_config_pypyoption.py b/lang/pypy3/files/patch-pypy_config_pypyoption.py
new file mode 100644
index 000000000000..0c60f2a1e5d1
--- /dev/null
+++ b/lang/pypy3/files/patch-pypy_config_pypyoption.py
@@ -0,0 +1,11 @@
+--- pypy/config/pypyoption.py.orig 2018-07-04 10:31:39 UTC
++++ pypy/config/pypyoption.py
+@@ -46,7 +46,7 @@ working_modules.update([
+ from rpython.jit.backend import detect_cpu
+ try:
+ if detect_cpu.autodetect().startswith('x86'):
+- if not sys.platform.startswith('openbsd'):
++ if not (sys.platform.startswith('openbsd') or sys.platform.startswith('freebsd')):
+ working_modules.add('_vmprof')
+ working_modules.add('faulthandler')
+ except detect_cpu.ProcessorAutodetectError:
diff --git a/lang/pypy3/files/patch-rpython_rlib_rvmprof_cintf.py b/lang/pypy3/files/patch-rpython_rlib_rvmprof_cintf.py
deleted file mode 100644
index c2b7a36d252e..000000000000
--- a/lang/pypy3/files/patch-rpython_rlib_rvmprof_cintf.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- rpython/rlib/rvmprof/cintf.py.orig 2017-12-22 10:09:25 UTC
-+++ rpython/rlib/rvmprof/cintf.py
-@@ -17,7 +17,7 @@ class VMProfPlatformUnsupported(Exceptio
-
- # vmprof works only on x86 for now
- IS_SUPPORTED = detect_cpu.autodetect().startswith('x86')
--if sys.platform == 'win32':
-+if sys.platform in ('freebsd10', 'win32'):
- IS_SUPPORTED = False
-
- ROOT = py.path.local(rpythonroot).join('rpython', 'rlib', 'rvmprof')
diff --git a/lang/pypy3/pkg-descr b/lang/pypy3/pkg-descr
index dfe7bbc57fa5..58efab51cc69 100644
--- a/lang/pypy3/pkg-descr
+++ b/lang/pypy3/pkg-descr
@@ -1,5 +1,5 @@
-PyPy3 (alpha) is a fast, compliant alternative implementation of the Python
-language (3.3.5). It has several advantages and distinct features:
+PyPy3 is a fast, compliant alternative implementation of the Python
+language (3.5.3). It has several advantages and distinct features:
- Speed: thanks to its Just-in-Time compiler, Python programs often run faster
on PyPy3.
diff --git a/lang/pypy3/pkg-plist b/lang/pypy3/pkg-plist
index f8ab6556d590..03a65e8441c0 100644
--- a/lang/pypy3/pkg-plist
+++ b/lang/pypy3/pkg-plist
@@ -15,6 +15,7 @@ bin/pypy3
%%PYPY_DIR%%/include/code.h
%%PYPY_DIR%%/include/compile.h
%%PYPY_DIR%%/include/complexobject.h
+%%PYPY_DIR%%/include/cpyext_datetime.h
%%PYPY_DIR%%/include/cpyext_descrobject.h
%%PYPY_DIR%%/include/cpyext_genobject.h
%%PYPY_DIR%%/include/cpyext_memoryobject.h
@@ -2090,6 +2091,7 @@ bin/pypy3
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_cffi_src/openssl/pem.py
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_cffi_src/openssl/pkcs12.py
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_cffi_src/openssl/pkcs7.py
+%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_cffi_src/openssl/pypy_win32_extra.py
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_cffi_src/openssl/rand.py
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_cffi_src/openssl/rsa.py
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_cffi_src/openssl/src/osrandom_engine.c
@@ -2106,6 +2108,7 @@ bin/pypy3
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_stdssl/error.py
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_stdssl/errorcodes.py
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_stdssl/utility.py
+%%PYPY_DIR%%/lib_pypy/_cffi_ssl/_stdssl/win32_extra.py
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/osx-roots.diff
%%PYPY_DIR%%/lib_pypy/_cffi_ssl/tools/make_ssl_data.py
%%PYPY_DIR%%/lib_pypy/_codecs_cn.py