aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 06:51:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 06:51:04 +0000
commit9f48528e6e53a3f6a788a0bfcf5f3d434d79921a (patch)
treef134d7bf940f5f50482b60e36c255e9f239360d6 /lang
parentf25de658a01310d78cbb67209274b82dcbf0878e (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/clang/Makefile9
-rw-r--r--lang/clang31/Makefile9
-rw-r--r--lang/erlang/Makefile11
-rw-r--r--lang/gcc/Makefile4
-rw-r--r--lang/gcc47/Makefile4
-rw-r--r--lang/p5-Test-XPath/Makefile3
-rw-r--r--lang/qscheme/Makefile10
7 files changed, 18 insertions, 32 deletions
diff --git a/lang/clang/Makefile b/lang/clang/Makefile
index 42bf4569036e..f1746f240d90 100644
--- a/lang/clang/Makefile
+++ b/lang/clang/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: clang
-# Date created: 24 Oct 2009
-# Whom: Brooks Davis
-#
+# Created by: Brooks Davis
# $FreeBSD$
-#
PORTNAME= clang
PORTVERSION= 3.2
@@ -36,9 +32,8 @@ BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake perl5
USE_LDCONFIG= yes
-USE_PERL5= yes
USE_PYTHON= yes
MAKE_ARGS= CLANG_TBLGEN=${WRKSRC}/${RELTYPE}/bin/clang-tblgen \
diff --git a/lang/clang31/Makefile b/lang/clang31/Makefile
index 2cdadb31ac68..a12217f9730f 100644
--- a/lang/clang31/Makefile
+++ b/lang/clang31/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: clang
-# Date created: 24 Oct 2009
-# Whom: Brooks Davis
-#
+# Created by: Brooks Davis
# $FreeBSD$
-#
PORTNAME= clang31
PORTVERSION= 3.1
@@ -38,10 +34,9 @@ BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
.endif
GNU_CONFIGURE= yes
+USES= gmake perl5
USE_GCC= 4.2+
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5= yes
USE_PYTHON= yes
MAKE_ARGS= CLANG_TBLGEN=${WRKSRC}/${RELTYPE}/bin/clang-tblgen \
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 5dff97e1d6ad..5112a0473592 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -51,6 +51,11 @@ OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
ERL_RELEASE= R${PORTVERSION:S/.//g:U:S/1$/-1/}
+USES= gmake perl5
+USE_CSTD= gnu89
+USE_RC_SUBR= epmd
+GNU_CONFIGURE= yes
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -124,12 +129,6 @@ WX_UNICODE= yes
CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
.endif
-USE_GMAKE= yes
-USE_CSTD= gnu89
-USE_PERL5= yes
-USE_RC_SUBR= epmd
-GNU_CONFIGURE= yes
-
.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+=--with-odbc
.if ${PORT_OPTIONS:MUNIXODBC}
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 6659120e34f0..7a704e9d2480 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -28,10 +28,10 @@ DISTVERSION= ${PORTVERSION}
GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
ONLY_FOR_ARCHS= amd64 i386 ia64 powerpc sparc64
-USES= bison gmake iconv
+USES= bison gmake iconv perl5
USE_BINUTILS= yes
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 8d5328bdfe27..3726df56e8a1 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -29,10 +29,10 @@ GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64
-USES= bison gmake iconv
+USES= bison gmake iconv perl5
USE_BINUTILS= yes
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
diff --git a/lang/p5-Test-XPath/Makefile b/lang/p5-Test-XPath/Makefile
index 9b41cb188d3a..01662043d6d8 100644
--- a/lang/p5-Test-XPath/Makefile
+++ b/lang/p5-Test-XPath/Makefile
@@ -15,7 +15,8 @@ LICENSE_COMB= dual
RUN_DEPENDS= p5-XML-LibXML>=1.70:${PORTSDIR}/textproc/p5-XML-LibXML
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Test::XPath.3
diff --git a/lang/qscheme/Makefile b/lang/qscheme/Makefile
index 5d4004ac37a2..619fdfaa4f25 100644
--- a/lang/qscheme/Makefile
+++ b/lang/qscheme/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qscheme
-# Date created: 6 Dec 2001
-# Whom: erik@smluc.org
-#
+# Created by: erik@smluc.org
# $FreeBSD$
-#
PORTNAME= qscheme
PORTVERSION= 0.5.1
@@ -19,9 +15,9 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall\
${LOCALBASE}/lib/libgmp.a:${PORTSDIR}/math/gmp
LIB_DEPENDS= getline:${PORTSDIR}/devel/libgetline
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
-USE_GMAKE= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
CONFIGURE_ARGS= --with-pcre-dir=${LOCALBASE}/lib \