aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
commitb59621d3ae883bef429a8fae6073bfa293a55222 (patch)
treeb415c7b2903cf47ada68c5557c3c6ac33a25fc41 /lang
parente93c09b8f3675471a176b72ae1e6f085f7a607ad (diff)
downloadports-b59621d3ae883bef429a8fae6073bfa293a55222.tar.gz
ports-b59621d3ae883bef429a8fae6073bfa293a55222.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/p5-Marpa-PP/Makefile22
-rw-r--r--lang/p5-Marpa-XS/Makefile2
-rw-r--r--lang/p5-Marpa/Makefile10
-rw-r--r--lang/p5-Parse-Perl/Makefile8
-rw-r--r--lang/p5-TryCatch/Makefile8
5 files changed, 42 insertions, 8 deletions
diff --git a/lang/p5-Marpa-PP/Makefile b/lang/p5-Marpa-PP/Makefile
index 45465a64c437..384b1826f3d6 100644
--- a/lang/p5-Marpa-PP/Makefile
+++ b/lang/p5-Marpa-PP/Makefile
@@ -18,12 +18,13 @@ COMMENT= Pure Perl version of Marpa
BUILD_DEPENDS= p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI \
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI \
+ p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
TEST_DEPENDS= p5-Test-Weaken>=3.004000:${PORTSDIR}/devel/p5-Test-Weaken
# PERL_CONFIGURE failed on Perl 5.12.4
-PERL_MODBUILD= yes
+PERL_MODBUILD= 5.10.0+
MAN3= Marpa::PP.3 \
Marpa::PP::Advanced::Bibliography.3 \
@@ -40,4 +41,19 @@ MAN3= Marpa::PP.3 \
Marpa::PP::Tracing.3 \
Marpa::PP::Vocabulary.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.21:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.21:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-Data-Dumper>=2.125:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Storable>=2.21:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= p5-Data-Dumper>=2.125:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Storable>=2.21:${PORTSDIR}/devel/p5-Storable
+TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/p5-Marpa-XS/Makefile b/lang/p5-Marpa-XS/Makefile
index 2f9fd77259a8..46c8ba0e786b 100644
--- a/lang/p5-Marpa-XS/Makefile
+++ b/lang/p5-Marpa-XS/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= p5-ExtUtils-PkgConfig>=0:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
TEST_DEPENDS= p5-Test-Weaken>=3.004000:${PORTSDIR}/devel/p5-Test-Weaken
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.10.0+
MAN3= Marpa::XS.3 \
Marpa::XS::Advanced::Bibliography.3 \
diff --git a/lang/p5-Marpa/Makefile b/lang/p5-Marpa/Makefile
index 1e48ad8ee403..baba0626ce2d 100644
--- a/lang/p5-Marpa/Makefile
+++ b/lang/p5-Marpa/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= p5-HTML-Parser>=3.64:${PORTSDIR}/www/p5-HTML-Parser \
RUN_DEPENDS= p5-HTML-Parser>=3.64:${PORTSDIR}/www/p5-HTML-Parser \
p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.10.0+
MAN3= Marpa::Advanced::Algorithm.3 \
Marpa::Advanced::Bibliography.3 \
@@ -38,4 +38,10 @@ MAN3= Marpa::Advanced::Algorithm.3 \
Marpa::Support.3 \
Marpa::Tracing.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501200
+TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/p5-Parse-Perl/Makefile b/lang/p5-Parse-Perl/Makefile
index a78e45ca6316..fd01fcc77d7b 100644
--- a/lang/p5-Parse-Perl/Makefile
+++ b/lang/p5-Parse-Perl/Makefile
@@ -27,4 +27,10 @@ MAN3= Parse::Perl.3 \
Parse::Perl::CopHintsHash.3 \
Parse::Perl::Environment.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/p5-TryCatch/Makefile b/lang/p5-TryCatch/Makefile
index dcd362364089..6ede8e89ac3f 100644
--- a/lang/p5-TryCatch/Makefile
+++ b/lang/p5-TryCatch/Makefile
@@ -46,4 +46,10 @@ BUILD_DEPENDS+= p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check
p5-B-Hooks-OP-PPAddr>=0.03:${PORTSDIR}/devel/p5-B-Hooks-OP-PPAddr
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>