aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-06 17:08:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-06 17:08:04 +0000
commitd5e5082e47bff3fff637948a78979d6a85795581 (patch)
treeca65df657f8181d835a6b8affdabe244323f89ce /lang
parent9b5f0edf2756e5fa6663b6a77c6f48c57548a416 (diff)
downloadports-d5e5082e47bff3fff637948a78979d6a85795581.tar.gz
ports-d5e5082e47bff3fff637948a78979d6a85795581.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile5
-rw-r--r--lang/ml-pnet/Makefile23
-rw-r--r--lang/ml-pnet/distinfo1
-rw-r--r--lang/ml-pnet/pkg-descr4
-rw-r--r--lang/ml-pnet/pkg-plist18
-rw-r--r--lang/pnet-base/Makefile49
-rw-r--r--lang/pnet-base/distinfo1
-rw-r--r--lang/pnet-base/pkg-descr5
-rw-r--r--lang/pnet-base/pkg-plist87
-rw-r--r--lang/pnet/Makefile29
-rw-r--r--lang/pnet/Makefile.pnet21
-rw-r--r--lang/pnet/pkg-descr7
-rw-r--r--lang/pnet/pkg-plist1
-rw-r--r--lang/pnetc/Makefile23
-rw-r--r--lang/pnetc/distinfo1
-rw-r--r--lang/pnetc/pkg-descr5
-rw-r--r--lang/pnetc/pkg-plist59
-rw-r--r--lang/pnetlib/Makefile29
-rw-r--r--lang/pnetlib/distinfo1
-rw-r--r--lang/pnetlib/pkg-descr4
-rw-r--r--lang/pnetlib/pkg-plist46
21 files changed, 419 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index d85f451eead0..6e638d39d39a 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -120,6 +120,7 @@
SUBDIR += mdk
SUBDIR += mit-scheme
SUBDIR += mixal
+ SUBDIR += ml-pnet
SUBDIR += mmix
SUBDIR += mono
SUBDIR += moscow_ml
@@ -175,6 +176,10 @@
SUBDIR += pm3-m3tk
SUBDIR += pm3-net
SUBDIR += pm3-netobj
+ SUBDIR += pnet
+ SUBDIR += pnet-base
+ SUBDIR += pnetc
+ SUBDIR += pnetlib
SUBDIR += ptoc
SUBDIR += py-compiler
SUBDIR += py-mx-base
diff --git a/lang/ml-pnet/Makefile b/lang/ml-pnet/Makefile
new file mode 100644
index 000000000000..07e5b2eb16a6
--- /dev/null
+++ b/lang/ml-pnet/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: treecc
+# Date created: Wed Jul 11 00:45:15 EDT 2001
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ml-pnet
+PORTVERSION= ${PNET_VERSION}
+CATEGORIES= lang
+MASTER_SITES= ${PNET_MASTER_SITES}
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Mono's upper-level libraries
+
+LIB_DEPENDS= XsharpSupport.0:${PORTSDIR}/lang/pnetlib
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+STRIP= # Nothing to be stripped.
+
+.include "${.CURDIR}/../pnet/Makefile.pnet"
+.include <bsd.port.mk>
diff --git a/lang/ml-pnet/distinfo b/lang/ml-pnet/distinfo
new file mode 100644
index 000000000000..9660376900e9
--- /dev/null
+++ b/lang/ml-pnet/distinfo
@@ -0,0 +1 @@
+MD5 (ml-pnet-0.6.0.tar.gz) = 496cee3b5b1816bf7dfe6d2be0660ce4
diff --git a/lang/ml-pnet/pkg-descr b/lang/ml-pnet/pkg-descr
new file mode 100644
index 000000000000..e535cc764acb
--- /dev/null
+++ b/lang/ml-pnet/pkg-descr
@@ -0,0 +1,4 @@
+Some of the Mono upper-level libraries in a form that can be easily compiled
+and used with pnet's CLI implementation. The source code is Mono's.
+
+WWW: http://www.southern-storm.com.au/portable_net.html
diff --git a/lang/ml-pnet/pkg-plist b/lang/ml-pnet/pkg-plist
new file mode 100644
index 000000000000..68a73824a268
--- /dev/null
+++ b/lang/ml-pnet/pkg-plist
@@ -0,0 +1,18 @@
+bin/sqlsharp-pnet
+bin/sqlsharp-pnet.exe
+lib/cscc/lib/Custommarshalers.dll
+lib/cscc/lib/Mono.Data.DB2Client.dll
+lib/cscc/lib/Mono.Data.MySql.dll
+lib/cscc/lib/Mono.Data.PostgreSqlClient.dll
+lib/cscc/lib/Mono.Data.Tds.dll
+lib/cscc/lib/Mono.Directory.LDAP.dll
+lib/cscc/lib/Mono.GetOptions.dll
+lib/cscc/lib/Mono.Posix.dll
+lib/cscc/lib/Npgsql.dll
+lib/cscc/lib/PEAPI.dll
+lib/cscc/lib/System.Data.OracleClient.dll
+lib/cscc/lib/System.Data.dll
+lib/cscc/lib/System.Management.dll
+lib/cscc/lib/System.Messaging.dll
+lib/cscc/lib/System.Runtime.Serialization.Formatters.Soap.dll
+lib/cscc/lib/System.ServiceProcess.dll
diff --git a/lang/pnet-base/Makefile b/lang/pnet-base/Makefile
new file mode 100644
index 000000000000..b65dcbcd6bcd
--- /dev/null
+++ b/lang/pnet-base/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: treecc
+# Date created: Wed Jul 11 00:45:15 EDT 2001
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pnet
+PORTVERSION= ${PNET_VERSION}
+CATEGORIES= lang
+MASTER_SITES= ${PNET_MASTER_SITES}
+PKGNAMESUFFIX= base
+
+MAINTAINER= ahze@ahze.net
+COMMENT= C\# compiler and runtime engine
+
+BUILD_DEPENDS= treecc:${PORTSDIR}/lang/treecc
+LIB_DEPENDS= ffi.2:${PORTSDIR}/devel/libffi
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_ARGS+= --enable-threads=posix
+
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+CONFIGURE_ARGS+= --disable-optimizations
+.endif
+
+INFO= pnettools
+MAN1= clrwrap.1 csant.1 cscc.1 csdoc.1 csdoc2hier.1 csdoc2html.1 \
+ csdoc2texi.1 cssrc2html.1 ilalink.1 ilasm.1 ildasm.1 ildd.1 \
+ ilfind.1 ilheader.1 ilnative.1 ilranlib.1 ilrun.1 ilsize.1 \
+ ilstrip.1 ilverify.1 resgen.1
+
+.include <bsd.port.pre.mk>
+
+post-everything::
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "Define optimized CFLAGS with"
+ @${ECHO_MSG} "WITH_OPTIMIZED_CFLAGS=yes"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|`$$CC -print-multi-os-directory 2>/dev/null`|elf|' \
+ ${WRKSRC}/libffi/configure ${WRKSRC}/libffi/configure.in
+
+.include "${.CURDIR}/../pnet/Makefile.pnet"
+.include <bsd.port.post.mk>
diff --git a/lang/pnet-base/distinfo b/lang/pnet-base/distinfo
new file mode 100644
index 000000000000..8af9e5e08969
--- /dev/null
+++ b/lang/pnet-base/distinfo
@@ -0,0 +1 @@
+MD5 (pnet-0.6.0.tar.gz) = 17785c4d9a748583bf675796e48019d5
diff --git a/lang/pnet-base/pkg-descr b/lang/pnet-base/pkg-descr
new file mode 100644
index 000000000000..aa7edad457bb
--- /dev/null
+++ b/lang/pnet-base/pkg-descr
@@ -0,0 +1,5 @@
+DotGNU Portable.NET contains a runtime engine, C# compiler, and a host of
+useful development tools, all written in C. This package is generally
+referred to as "pnet".
+
+WWW: http://www.southern-storm.com.au/portable_net.html
diff --git a/lang/pnet-base/pkg-plist b/lang/pnet-base/pkg-plist
new file mode 100644
index 000000000000..ad98f2ac44ce
--- /dev/null
+++ b/lang/pnet-base/pkg-plist
@@ -0,0 +1,87 @@
+bin/al
+bin/cli-unknown-ar
+bin/cli-unknown-gcc
+bin/cli-unknown-ranlib
+bin/cli-unknown-size
+bin/cli-unknown-strip
+bin/clrwrap
+bin/csant
+bin/cscc
+bin/csdoc
+bin/csdoc2hier
+bin/csdoc2html
+bin/csdoc2texi
+bin/cssrc2html
+bin/ilalink
+bin/ilasm
+bin/ildasm
+bin/ildd
+bin/ilfind
+bin/ilheader
+bin/ilnative
+bin/ilranlib
+bin/ilrun
+bin/ilsize
+bin/ilstrip
+bin/ilverify
+bin/resgen
+include/pnet/ffi.h
+include/pnet/ffi_mips.h
+include/pnet/fficonfig.h
+include/pnet/gc.h
+include/pnet/gc_local_alloc.h
+include/pnet/gc_typed.h
+include/pnet/il_align.h
+include/pnet/il_bignum.h
+include/pnet/il_coder.h
+include/pnet/il_config.h
+include/pnet/il_crypt.h
+include/pnet/il_debug.h
+include/pnet/il_decimal.h
+include/pnet/il_dumpasm.h
+include/pnet/il_engine.h
+include/pnet/il_errno.h
+include/pnet/il_gc.h
+include/pnet/il_image.h
+include/pnet/il_jopcodes.h
+include/pnet/il_linker.h
+include/pnet/il_meta.h
+include/pnet/il_opcodes.h
+include/pnet/il_profile.h
+include/pnet/il_program.h
+include/pnet/il_regex.h
+include/pnet/il_serialize.h
+include/pnet/il_sysio.h
+include/pnet/il_system.h
+include/pnet/il_thread.h
+include/pnet/il_types.h
+include/pnet/il_utils.h
+include/pnet/il_values.h
+include/pnet/il_writer.h
+include/pnet/il_xml.h
+include/pnet/leak_detector.h
+lib/cscc/plugins/cscc-b
+lib/cscc/plugins/cscc-bf
+lib/cscc/plugins/cscc-c-s
+lib/cscc/plugins/cscc-cs
+lib/cscc/plugins/cscc-csharp
+lib/cscc/plugins/cscc-java
+lib/cscc/plugins/cscc-vb
+lib/libILAsm.a
+lib/libILCodeGen.a
+lib/libILDumpAsm.a
+lib/libILEngine.a
+lib/libILImage.a
+lib/libILLink.a
+lib/libILSupport.a
+lib/pnet/elf/libffi.a
+lib/pnet/elf/libffi.la
+lib/pnet/libgc.a
+lib/pnet/libgc.la
+lib/pnet/libgc.so
+lib/pnet/libgc.so.1
+@dirrm include/pnet
+@dirrm lib/cscc/plugins
+@dirrm lib/cscc
+@dirrm lib/pnet/elf
+@dirrm lib/pnet
diff --git a/lang/pnet/Makefile b/lang/pnet/Makefile
new file mode 100644
index 000000000000..da0c93a088e1
--- /dev/null
+++ b/lang/pnet/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gnome2
+# Date created: 21 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pnet
+PORTVERSION= ${PNET_VERSION}
+CATEGORIES= lang
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= ahze@ahze.net
+COMMENT= The "meta-port" for DotGNU Portable.NET
+
+BUILD_DEPENDS= treecc:${PORTSDIR}/lang/treecc
+RUN_DEPENDS= cscc:${PORTSDIR}/lang/pnet-base \
+ csunit:${PORTSDIR}/lang/pnetlib \
+ sqlsharp-pnet:${PORTSDIR}/lang/ml-pnet \
+ ${LOCALBASE}/lib/cscc/lib/libc64.dll:${PORTSDIR}/lang/pnetc
+
+NO_BUILD= yes
+
+do-install: # empty
+
+.include "../pnet/Makefile.pnet"
+.include <bsd.port.mk>
diff --git a/lang/pnet/Makefile.pnet b/lang/pnet/Makefile.pnet
new file mode 100644
index 000000000000..2fa76cdc3028
--- /dev/null
+++ b/lang/pnet/Makefile.pnet
@@ -0,0 +1,21 @@
+PNET_VERSION= 0.6.0
+PNET_REVISION= 0
+PNET_PORTVER= ${PNET_VERSION}.${PNET_REVISION}
+PNET_PORTREV= 0
+PNET_PORTEPOCH= 0
+
+PNET_MASTER_SITES= http://www.southern-storm.com.au/download/
+
+ILSTRIP_CMD= ${LOCALBASE}/bin/ilstrip
+
+.if defined(WITH_OPTIMIZED_CSFLAGS)
+CSFLAGS=-02
+.endif
+
+pre-everything:: post-everything
+.if !defined(WITH_OPTIMIZED_CSFLAGS)
+ @${ECHO_MSG} "Define optimized CSLAGS with"
+ @${ECHO_MSG} "WITH_OPTIMIZED_CSFLAGS=yes"
+.endif
+
+post-everything::
diff --git a/lang/pnet/pkg-descr b/lang/pnet/pkg-descr
new file mode 100644
index 000000000000..c2eb7f2e7be8
--- /dev/null
+++ b/lang/pnet/pkg-descr
@@ -0,0 +1,7 @@
+Meta-port package for pnet.
+
+DotGNU Portable.NET contains a runtime engine, C# compiler, and a host of
+useful development tools, all written in C. This package is generally
+referred to as "pnet".
+
+WWW: http://www.southern-storm.com.au/portable_net.html
diff --git a/lang/pnet/pkg-plist b/lang/pnet/pkg-plist
new file mode 100644
index 000000000000..549a621fec0c
--- /dev/null
+++ b/lang/pnet/pkg-plist
@@ -0,0 +1 @@
+@comment this plist intentionally left empty
diff --git a/lang/pnetc/Makefile b/lang/pnetc/Makefile
new file mode 100644
index 000000000000..995cc71c1961
--- /dev/null
+++ b/lang/pnetc/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: treecc
+# Date created: Wed Jul 11 00:45:15 EDT 2001
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pnetC
+PORTVERSION= ${PNET_VERSION}
+CATEGORIES= lang
+MASTER_SITES= ${PNET_MASTER_SITES}
+
+MAINTAINER= ahze@ahze.net
+COMMENT= ANSI-compatible C library for pnet's cscc compiler
+
+LIB_DEPENDS= XsharpSupport.0:${PORTSDIR}/lang/pnetlib
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+STRIP= # Nothing to be stripped.
+
+.include "${.CURDIR}/../pnet/Makefile.pnet"
+.include <bsd.port.mk>
diff --git a/lang/pnetc/distinfo b/lang/pnetc/distinfo
new file mode 100644
index 000000000000..845a0840c8ad
--- /dev/null
+++ b/lang/pnetc/distinfo
@@ -0,0 +1 @@
+MD5 (pnetC-0.6.0.tar.gz) = e076377cdd64b499ebe8a5356c2129fc
diff --git a/lang/pnetc/pkg-descr b/lang/pnetc/pkg-descr
new file mode 100644
index 000000000000..22c932b74a82
--- /dev/null
+++ b/lang/pnetc/pkg-descr
@@ -0,0 +1,5 @@
+This is the "pnetC" project. The goal of the project is to create
+an ANSI-compatible C library, that can be compiled down to IL using
+Portable.NET's "cscc" compiler.
+
+WWW: http://www.southern-storm.com.au/portable_net.html
diff --git a/lang/pnetc/pkg-plist b/lang/pnetc/pkg-plist
new file mode 100644
index 000000000000..400118109b4f
--- /dev/null
+++ b/lang/pnetc/pkg-plist
@@ -0,0 +1,59 @@
+lib/cscc/lib/libc64.dll
+lib/cscc/lib/libm64.dll
+share/cscc/include/alloca.h
+share/cscc/include/assert.h
+share/cscc/include/bits/libc-lock.h
+share/cscc/include/bits/local_lim.h
+share/cscc/include/bits/mman.h
+share/cscc/include/bits/posix1_lim.h
+share/cscc/include/bits/posix2_lim.h
+share/cscc/include/bits/stat.h
+share/cscc/include/bits/stdio_lim.h
+share/cscc/include/bits/types.h
+share/cscc/include/bits/waitflags.h
+share/cscc/include/bits/waitstatus.h
+share/cscc/include/bits/wchar.h
+share/cscc/include/bits/wordsize.h
+share/cscc/include/bits/xopen_lim.h
+share/cscc/include/ctype.h
+share/cscc/include/dirent.h
+share/cscc/include/errno.h
+share/cscc/include/fcntl.h
+share/cscc/include/features.h
+share/cscc/include/gmp-mparam.h
+share/cscc/include/gmp.h
+share/cscc/include/gnu/stubs.h
+share/cscc/include/ieee754.h
+share/cscc/include/inttypes.h
+share/cscc/include/limits.h
+share/cscc/include/malloc.h
+share/cscc/include/math.h
+share/cscc/include/pthread.h
+share/cscc/include/pwd.h
+share/cscc/include/setjmp.h
+share/cscc/include/stdarg.h
+share/cscc/include/stdbool.h
+share/cscc/include/stddef.h
+share/cscc/include/stdint.h
+share/cscc/include/stdio.h
+share/cscc/include/stdio_ext.h
+share/cscc/include/stdlib.h
+share/cscc/include/string.h
+share/cscc/include/strings.h
+share/cscc/include/sys/cdefs.h
+share/cscc/include/sys/errno.h
+share/cscc/include/sys/mman.h
+share/cscc/include/sys/stat.h
+share/cscc/include/sys/sysmacros.h
+share/cscc/include/sys/types.h
+share/cscc/include/time.h
+share/cscc/include/unistd.h
+share/cscc/include/varargs.h
+share/cscc/include/wchar.h
+share/cscc/include/wctype.h
+share/cscc/include/xlocale.h
+@dirrm share/cscc/include/bits
+@dirrm share/cscc/include/gnu
+@dirrm share/cscc/include/sys
+@dirrm share/cscc/include
+@dirrm share/cscc
diff --git a/lang/pnetlib/Makefile b/lang/pnetlib/Makefile
new file mode 100644
index 000000000000..b61426d728c8
--- /dev/null
+++ b/lang/pnetlib/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: treecc
+# Date created: Wed Jul 11 00:45:15 EDT 2001
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pnetlib
+PORTVERSION= ${PNET_VERSION}.1
+CATEGORIES= lang
+MASTER_SITES= ${PNET_MASTER_SITES}
+
+MAINTAINER= ahze@ahze.net
+COMMENT= C\# system library for pnet
+
+BUILD_DEPENDS= cscc:${PORTSDIR}/lang/pnet-base \
+ treecc:${PORTSDIR}/lang/treecc
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+STRIP= # Nothing to be stripped.
+
+.include <bsd.port.pre.mk>
+post-install:
+ ${STRIP_CMD} ${PREFIX}/lib/cscc/lib/libXsharpSupport.so.0
+ ${STRIP_CMD} ${PREFIX}/lib/cscc/lib/libXsharpSupport.a
+
+.include "${.CURDIR}/../pnet/Makefile.pnet"
+.include <bsd.port.post.mk>
diff --git a/lang/pnetlib/distinfo b/lang/pnetlib/distinfo
new file mode 100644
index 000000000000..e4a9b3ce6dd7
--- /dev/null
+++ b/lang/pnetlib/distinfo
@@ -0,0 +1 @@
+MD5 (pnetlib-0.6.0.1.tar.gz) = 7ace204daba6a511af955a8b5b97cb2d
diff --git a/lang/pnetlib/pkg-descr b/lang/pnetlib/pkg-descr
new file mode 100644
index 000000000000..42add1cd065d
--- /dev/null
+++ b/lang/pnetlib/pkg-descr
@@ -0,0 +1,4 @@
+C# class libraries, including "mscorlib.dll", "System.dll", "System.Xml.dll",
+"System.Drawing.dll", "System.Windows.Forms.dll", etc.
+
+WWW: http://www.southern-storm.com.au/portable_net.html
diff --git a/lang/pnetlib/pkg-plist b/lang/pnetlib/pkg-plist
new file mode 100644
index 000000000000..5d2f67490596
--- /dev/null
+++ b/lang/pnetlib/pkg-plist
@@ -0,0 +1,46 @@
+bin/csunit
+bin/csunit.exe
+bin/ilinstall
+bin/ilinstall.exe
+bin/jsrun
+bin/jsrun.exe
+lib/cscc/lib/Accessibility.dll
+lib/cscc/lib/DotGNU.Images.dll
+lib/cscc/lib/DotGNU.SSL.dll
+lib/cscc/lib/I18N.CJK.dll
+lib/cscc/lib/I18N.MidEast.dll
+lib/cscc/lib/I18N.Other.dll
+lib/cscc/lib/I18N.Rare.dll
+lib/cscc/lib/I18N.West.dll
+lib/cscc/lib/I18N.dll
+lib/cscc/lib/ICSharpCode.SharpZipLib.dll
+lib/cscc/lib/ISymWrapper.dll
+lib/cscc/lib/Microsoft.JScript.dll
+lib/cscc/lib/Microsoft.VisualBasic.dll
+lib/cscc/lib/Microsoft.VisualC.dll
+lib/cscc/lib/Microsoft.Vsa.dll
+lib/cscc/lib/OpenSystem.C.dll
+lib/cscc/lib/System.Configuration.Install.dll
+lib/cscc/lib/System.Drawing.Postscript.dll
+lib/cscc/lib/System.Drawing.Win32.dll
+lib/cscc/lib/System.Drawing.Xsharp.dll
+lib/cscc/lib/System.Drawing.dll
+lib/cscc/lib/System.EnterpriseServices.dll
+lib/cscc/lib/System.Net.IrDA.dll
+lib/cscc/lib/System.Windows.Forms.dll
+lib/cscc/lib/System.Xml.dll
+lib/cscc/lib/System.dll
+lib/cscc/lib/Xsharp.dll
+lib/cscc/lib/cscompmgd.dll
+lib/cscc/lib/cstest.dll
+lib/cscc/lib/de/I18N.resources.dll
+lib/cscc/lib/de/System.Xml.resources.dll
+lib/cscc/lib/de/System.resources.dll
+lib/cscc/lib/de/mscorlib.resources.dll
+lib/cscc/lib/libXsharpSupport.a
+lib/cscc/lib/libXsharpSupport.so
+lib/cscc/lib/libXsharpSupport.so.0
+lib/cscc/lib/mscorlib.dll
+lib/cscc/lib/pnetlib.here
+@dirrm lib/cscc/lib/de
+@dirrm lib/cscc/lib