aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-07-31 08:44:56 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-07-31 08:44:56 +0000
commit982b80dfafb406139a5e53b318c7d9e53157502c (patch)
tree78c8b5b2ca878117937061a048008252136bb967 /lang
parent985792904b257636075154197aa65397dd7ed657 (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php71/Makefile.ext6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/php71/Makefile.ext b/lang/php71/Makefile.ext
index dc60a841413f..7480fe77d4e1 100644
--- a/lang/php71/Makefile.ext
+++ b/lang/php71/Makefile.ext
@@ -96,12 +96,15 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpng.so:graphics/png
USES+= jpeg
-CONFIGURE_ARGS+=--with-gd \
+CONFIGURE_ARGS+=--with-gd=${LOCALBASE} \
--with-freetype-dir=${LOCALBASE} \
--with-jpeg-dir=${LOCALBASE} \
--with-png-dir=${LOCALBASE} \
--with-zlib-dir=/usr
+EXTRACT_AFTER_ARGS=--no-same-owner --no-same-permissions --exclude libgd \
+ php-${PORTVERSION}/ext/gd
+
OPTIONS_DEFINE=TRUETYPE JIS WEBP X11
OPTIONS_DEFAULT=TRUETYPE X11
@@ -110,7 +113,6 @@ JIS_DESC= Enable JIS-mapped Japanese font support
WEBP_DESC= Enable WebP image format support
X11_DESC= Enable XPM support
-PHP_HEADER_DIRS=libgd
.endif
.if ${PHP_MODNAME} == "gettext"