aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-04-28 09:08:58 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-04-28 09:08:58 +0000
commit1eb9d015abef11541c805aaad9b850e1b1f92e26 (patch)
tree87a6715f46150f30507c3812c9b6c0c48c92aa52 /lang
parent34ddc65d98f0c94b966c62a649eeb16d71a9882c (diff)
downloadports-1eb9d015abef11541c805aaad9b850e1b1f92e26.tar.gz
ports-1eb9d015abef11541c805aaad9b850e1b1f92e26.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/tcl86/files/patch-unix-Makefile.in48
-rw-r--r--lang/tcl86/pkg-plist1
2 files changed, 33 insertions, 16 deletions
diff --git a/lang/tcl86/files/patch-unix-Makefile.in b/lang/tcl86/files/patch-unix-Makefile.in
index d4c0a6edd080..f2083b53a6f5 100644
--- a/lang/tcl86/files/patch-unix-Makefile.in
+++ b/lang/tcl86/files/patch-unix-Makefile.in
@@ -1,5 +1,5 @@
--- Makefile.in.orig 2013-09-19 22:17:13.000000000 +0200
-+++ Makefile.in 2013-09-20 09:14:56.000000000 +0200
++++ Makefile.in 2014-04-28 10:32:43.000000000 +0200
@@ -54,6 +54,8 @@
# Directory in which to install the include file tcl.h:
@@ -93,7 +93,7 @@
do \
if [ ! -d "$$i" ] ; then \
echo "Making directory $$i"; \
-@@ -822,7 +834,13 @@
+@@ -822,7 +834,22 @@
else true; \
fi; \
done;
@@ -102,13 +102,34 @@
+ @for i in $(TOP_DIR)/library/encoding/*.enc ; do \
+ $(INSTALL_DATA) $$i "$(SCRIPT_INSTALL_DIR)"/encoding; \
+ done;
++ @echo "Installing library files to $(SCRIPT_INSTALL_DIR)/";
++ @for i in $(TOP_DIR)/library/*.tcl $(TOP_DIR)/library/tclIndex \
++ $(UNIX_DIR)/tclAppInit.c @LDAIX_SRC@ @DTRACE_SRC@; \
++ do \
++ $(INSTALL_DATA) $$i "$(SCRIPT_INSTALL_DIR)"; \
++ done;
++ @echo "Customizing tcl module path"; \
++ echo "::tcl::tm::path add {$(TCL_LIBRARY)}" >> \
++ "$(SCRIPT_INSTALL_DIR)"/tm.tcl;
+
+install-modules: libraries
+ @for i in opt0.4 http1.0 platform; \
do \
if [ ! -d "$(SCRIPT_INSTALL_DIR)"/$$i ] ; then \
echo "Making directory $(SCRIPT_INSTALL_DIR)/$$i"; \
-@@ -842,31 +860,29 @@
+@@ -830,43 +857,26 @@
+ else true; \
+ fi; \
+ done;
+- @echo "Installing library files to $(SCRIPT_INSTALL_DIR)/";
+- @for i in $(TOP_DIR)/library/*.tcl $(TOP_DIR)/library/tclIndex \
+- $(UNIX_DIR)/tclAppInit.c @LDAIX_SRC@ @DTRACE_SRC@; \
+- do \
+- $(INSTALL_DATA) $$i "$(SCRIPT_INSTALL_DIR)"; \
+- done;
+ @echo "Installing package http1.0 files to $(SCRIPT_INSTALL_DIR)/http1.0/";
+ @for i in $(TOP_DIR)/library/http1.0/*.tcl ; \
+ do \
$(INSTALL_DATA) $$i "$(SCRIPT_INSTALL_DIR)"/http1.0; \
done;
@echo "Installing package http 2.8.7 as a Tcl Module";
@@ -124,31 +145,28 @@
+ @$(INSTALL_DATA) $(TOP_DIR)/library/msgcat/msgcat.tcl "$(SCRIPT_INSTALL_DIR)"/msgcat-1.5.2.tm;
@echo "Installing package tcltest 2.3.6 as a Tcl Module";
- @$(INSTALL_DATA) $(TOP_DIR)/library/tcltest/tcltest.tcl "$(SCRIPT_INSTALL_DIR)"/../tcl8/8.5/tcltest-2.3.6.tm;
+-
+ @$(INSTALL_DATA) $(TOP_DIR)/library/tcltest/tcltest.tcl "$(SCRIPT_INSTALL_DIR)"/tcltest-2.3.6.tm;
-
@echo "Installing package platform 1.0.12 as a Tcl Module";
- @$(INSTALL_DATA) $(TOP_DIR)/library/platform/platform.tcl "$(SCRIPT_INSTALL_DIR)"/../tcl8/8.4/platform-1.0.12.tm;
+ @$(INSTALL_DATA) $(TOP_DIR)/library/platform/platform.tcl "$(SCRIPT_INSTALL_DIR)"/platform-1.0.12.tm;
@echo "Installing package platform::shell 1.1.4 as a Tcl Module";
- @$(INSTALL_DATA) $(TOP_DIR)/library/platform/shell.tcl "$(SCRIPT_INSTALL_DIR)"/../tcl8/8.4/platform/shell-1.1.4.tm;
-+ @$(INSTALL_DATA) $(TOP_DIR)/library/platform/shell.tcl "$(SCRIPT_INSTALL_DIR)"/platform/shell-1.1.4.tm;
-
- @echo "Installing encoding files to $(SCRIPT_INSTALL_DIR)/encoding/";
- @for i in $(TOP_DIR)/library/encoding/*.enc ; do \
- $(INSTALL_DATA) $$i "$(SCRIPT_INSTALL_DIR)"/encoding; \
- done;
+-
+- @echo "Installing encoding files to $(SCRIPT_INSTALL_DIR)/encoding/";
+- @for i in $(TOP_DIR)/library/encoding/*.enc ; do \
+- $(INSTALL_DATA) $$i "$(SCRIPT_INSTALL_DIR)"/encoding; \
+- done;
- @if [ -n "$(TCL_MODULE_PATH)" -a -f $(TOP_DIR)/library/tm.tcl ]; then \
- echo "Customizing tcl module path"; \
- echo "if {![interp issafe]} { ::tcl::tm::roots {$(TCL_MODULE_PATH)} }" >> \
- "$(SCRIPT_INSTALL_DIR)"/tm.tcl; \
- fi
-+ @echo "Customizing tcl module path"; \
-+ echo "::tcl::tm::path add {$(TCL_LIBRARY)}" >> \
-+ "$(SCRIPT_INSTALL_DIR)"/tm.tcl; \
++ @$(INSTALL_DATA) $(TOP_DIR)/library/platform/shell.tcl "$(SCRIPT_INSTALL_DIR)"/platform/shell-1.1.4.tm;
install-tzdata:
@for i in tzdata; \
-@@ -941,7 +957,7 @@
+@@ -941,7 +951,7 @@
done
install-headers:
@@ -157,7 +175,7 @@
do \
if [ ! -d "$$i" ] ; then \
echo "Making directory $$i"; \
-@@ -950,14 +966,21 @@
+@@ -950,14 +960,21 @@
fi; \
done;
@echo "Installing header files to $(INCLUDE_INSTALL_DIR)/";
diff --git a/lang/tcl86/pkg-plist b/lang/tcl86/pkg-plist
index 714dd47dbb5c..1c8f630af0ca 100644
--- a/lang/tcl86/pkg-plist
+++ b/lang/tcl86/pkg-plist
@@ -1693,4 +1693,3 @@ libdata/pkgconfig/tcl.pc
@dirrm include/tcl%%TCL_VER%%/unix
@dirrm include/tcl%%TCL_VER%%/generic
@dirrm include/tcl%%TCL_VER%%
-