aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2011-06-06 11:19:40 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2011-06-06 11:19:40 +0000
commit31cd95de3b3c11fbc328697c847def048f44fd88 (patch)
treebc5e3b3a117a0fb9f689e1e7ef5c7616525e12d9 /lang
parent98ceab81126a75fb622e6a04e0bb50aca5b3ae54 (diff)
downloadports-31cd95de3b3c11fbc328697c847def048f44fd88.tar.gz
ports-31cd95de3b3c11fbc328697c847def048f44fd88.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc45/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 81e3c1affb32..9a4b1f5eb8f0 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -61,6 +61,7 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--disable-nls \
+ --enable-languages=c,c++,fortran \
--enable-lto=no \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
@@ -101,7 +102,8 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
EXTRA_PATCHES+= ${FILESDIR}/java-patch-hier
# FIXME: we are currently getting weird build failures with libjava on
# some 4.x and 5.x systems, which the following works around. PR 81788.
-CONFIGURE_ARGS+=--disable-rpath --enable-libgcj
+CONFIGURE_ARGS+=--disable-rpath \
+ --enable-languages=c,c++,fortran,java
MAN1+= aot-compile${SUFFIX}.1 \
gappletviewer${SUFFIX}.1 \
gc-analyze${SUFFIX}.1 \