aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-06-01 12:35:40 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-06-01 12:35:40 +0000
commit73d987023637b5e150eb7f1c6eaa4fca3b7472d3 (patch)
tree8d9b654746867ca9f702f910b4d656d96ea21275 /lang
parent0a88efc19b56e6291ef844bfc71ce93ddc92a111 (diff)
downloadports-73d987023637b5e150eb7f1c6eaa4fca3b7472d3.tar.gz
ports-73d987023637b5e150eb7f1c6eaa4fca3b7472d3.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/lua-mode.el/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/lang/lua-mode.el/Makefile b/lang/lua-mode.el/Makefile
index bd65d6e3ed97..a7b5221090ed 100644
--- a/lang/lua-mode.el/Makefile
+++ b/lang/lua-mode.el/Makefile
@@ -20,16 +20,13 @@ EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
PLIST_FILES= share/emacs/site-lisp/lua-mode.el lib/xemacs/site-lisp/lua-mode.el
-PLIST_DIRS= lib/xemacs/site-lisp lib/xemacs
+PLIST_DIRSTRY= lib/xemacs/site-lisp lib/xemacs
-NO_STAGE= yes
do-install:
- ${MKDIR} ${EMACSLISPDIR}
- ${MKDIR} ${XEMACSLISPDIR}
- ${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${EMACSLISPDIR}/lua-mode.el
- ${LN} -sf ${EMACSLISPDIR}/lua-mode.el ${XEMACSLISPDIR}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${EMACSLISPDIR}
+ @${MKDIR} ${STAGEDIR}${XEMACSLISPDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} \
+ ${STAGEDIR}${EMACSLISPDIR}/lua-mode.el
+ ${LN} -sf ${EMACSLISPDIR}/lua-mode.el ${STAGEDIR}${XEMACSLISPDIR}
.include <bsd.port.mk>