aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2020-06-30 06:05:07 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2020-06-30 06:05:07 +0000
commitcf7aa5ea2c27fb12781140c22d6bddc17f05ed9d (patch)
tree0051500159f381ab795169ed381ef2cce14d90d8 /lang
parent6282c726edce35305806f8806f0d33d807be7216 (diff)
downloadports-cf7aa5ea2c27fb12781140c22d6bddc17f05ed9d.tar.gz
ports-cf7aa5ea2c27fb12781140c22d6bddc17f05ed9d.zip
Update to the 20200628 snapshot of GCC 11.0.0.
The issue temporarily work around by reverting upstream changes via files/patch-PR95805 has been resolved, so remove that hack (which is in conflict now anyways).
Notes
Notes: svn path=/head/; revision=540857
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc11-devel/Makefile2
-rw-r--r--lang/gcc11-devel/distinfo6
-rw-r--r--lang/gcc11-devel/files/patch-PR9580547
3 files changed, 4 insertions, 51 deletions
diff --git a/lang/gcc11-devel/Makefile b/lang/gcc11-devel/Makefile
index 621437eb13b8..07c9e1cf5d6e 100644
--- a/lang/gcc11-devel/Makefile
+++ b/lang/gcc11-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 11.0.0.s20200621
+PORTVERSION= 11.0.0.s20200628
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc11-devel/distinfo b/lang/gcc11-devel/distinfo
index 54ca28320b52..b557cc229297 100644
--- a/lang/gcc11-devel/distinfo
+++ b/lang/gcc11-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592784068
-SHA256 (gcc-11-20200621.tar.xz) = ac7566828cba717b23e0a954ac72dff9fa39cddbaa9beb03a3dedf72bccec75c
-SIZE (gcc-11-20200621.tar.xz) = 71629184
+TIMESTAMP = 1593412533
+SHA256 (gcc-11-20200628.tar.xz) = d4fef9327b480b852e0828d604c86b8d3fbd3b96986f713e39606fd556399351
+SIZE (gcc-11-20200628.tar.xz) = 71655664
diff --git a/lang/gcc11-devel/files/patch-PR95805 b/lang/gcc11-devel/files/patch-PR95805
deleted file mode 100644
index b75149fe1b89..000000000000
--- a/lang/gcc11-devel/files/patch-PR95805
+++ /dev/null
@@ -1,47 +0,0 @@
-This should be properly fixed upstream by the next snapshot.
-
-Revert commit 4e49b994de060d4a6c9318d0ed52ef038153426e
-Author: Richard Sandiford <richard.sandiford@arm.com>
-Date: Wed Jun 17 17:45:29 2020 +0100
-
- recog: Tweak insn_gen_fn::operator() definition
-
- Fixes a “left operand of comma has no effect” warning that some were
- seeing. Also fixes a spurious ellipsis that Jonathan Wakely pointed
- out.
-
- 2020-06-17 Richard Sandiford <richard.sandiford@arm.com>
-
- gcc/
- * coretypes.h (first_type): New alias template.
- * recog.h (insn_gen_fn::operator()): Use it instead of a decltype.
- Remove spurious “...” and split the function type out into a typedef.
-
---- gcc/coretypes.h 2020-06-21 22:32:12.000000000 +0000
-+++ gcc/coretypes.h 2020-06-23 18:56:41.074951000 +0000
-@@ -359,10 +359,6 @@
- const ValueType value; /* the value of the name */
- };
-
--/* Alias of the first type, ignoring the second. */
--template<typename T1, typename T2>
--using first_type = T1;
--
- /* Iterator pair used for a collection iteration with range-based loops. */
-
- template<typename T>
---- gcc/recog.h
-+++ gcc/recog.h
-@@ -295,10 +295,9 @@ struct insn_gen_fn
- typedef void (*stored_funcptr) (void);
-
- template<typename ...Ts>
-- rtx_insn *operator() (Ts... args) const
-+ rtx_insn *operator() (Ts... args...) const
- {
-- typedef rtx_insn *(*funcptr) (first_type<rtx, Ts>...);
-- return ((funcptr) func) (args...);
-+ return ((rtx_insn *(*) (decltype(args, NULL_RTX)...)) func) (args...);
- }
-
- // This is for compatibility of code that invokes functions like