aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-09-18 08:33:15 +0000
committerChris Rees <crees@FreeBSD.org>2011-09-18 08:33:15 +0000
commitd03cd9afc5c493cefcf8dc87de3689b53d79a54d (patch)
tree1eb7a0391e3b616f786f85392504dc00fc02c250 /lang
parentcc516d16adb1ca25b7ddc0221b98af33e3062f52 (diff)
downloadports-d03cd9afc5c493cefcf8dc87de3689b53d79a54d.tar.gz
ports-d03cd9afc5c493cefcf8dc87de3689b53d79a54d.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python24/Makefile11
-rw-r--r--lang/python25/Makefile11
-rw-r--r--lang/python26/Makefile9
-rw-r--r--lang/python27/Makefile9
-rw-r--r--lang/python31/Makefile11
-rw-r--r--lang/python32/Makefile11
6 files changed, 56 insertions, 6 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 628d1fde5451..a9754b9a700b 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -99,8 +99,10 @@ PLIST_SUB+= 32BIT_ONLY=""
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-.if !exists(/usr/bin/ypcat) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
+WITHOUT_NIS?= detected
.else
PLIST_SUB+= NO_NIS=""
.endif
@@ -134,6 +136,13 @@ pre-patch:
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
+post-patch:
+.if defined(WITHOUT_NIS)
+ ${REINPLACE_CMD} -e \
+ 's/disabled_module_list =[^]]*/&, "nis"/' \
+ ${PATCH_WRKSRC}/setup.py
+.endif
+
post-configure:
@# prepare a subdir for shared build
.for subdir in Modules Parser Python Objects
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index b8b56a57a933..e67b7e3df38d 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -98,8 +98,10 @@ PLIST_SUB+= 32BIT_ONLY=""
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-.if !exists(/usr/bin/ypcat) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
+WITHOUT_NIS?= detected
.else
PLIST_SUB+= NO_NIS=""
.endif
@@ -146,6 +148,13 @@ pre-patch:
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
+post-patch:
+.if defined(WITHOUT_NIS)
+ ${REINPLACE_CMD} -e \
+ 's/disabled_module_list =[^]]*/&, "nis"/' \
+ ${PATCH_WRKSRC}/setup.py
+.endif
+
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 8f1e32eb9c96..8f742fcc5e9b 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -131,8 +131,10 @@ PLIST_SUB+= 32BIT_ONLY=""
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-.if !exists(/usr/bin/ypcat) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
+WITHOUT_NIS?= detected
.else
PLIST_SUB+= NO_NIS=""
.endif
@@ -188,6 +190,11 @@ post-patch:
@cd ${WRKSRC} && ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-setup.py
.endif
.endif
+.if defined(WITHOUT_NIS)
+ ${REINPLACE_CMD} -e \
+ 's/disabled_module_list =[^]]*/&, "nis"/' \
+ ${PATCH_WRKSRC}/setup.py
+.endif
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index d8ee01c78ed3..9e95b226855d 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -136,8 +136,10 @@ MAKE_ENV+= UNAME_m="powerpc64"
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-.if !exists(/usr/bin/ypcat) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
+WITHOUT_NIS?= detected
.else
PLIST_SUB+= NO_NIS=""
.endif
@@ -193,6 +195,11 @@ post-patch:
@cd ${WRKSRC} && ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-setup.py
.endif
.endif
+.if defined(WITHOUT_NIS)
+ ${REINPLACE_CMD} -e \
+ 's/disabled_module_list =[^]]*/&, "nis"/' \
+ ${PATCH_WRKSRC}/setup.py
+.endif
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 0650170d3525..9389dfa372fb 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -96,8 +96,10 @@ CONFIGURE_ARGS+= --without-pymalloc
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-.if !exists(/usr/bin/ypcat) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
+WITHOUT_NIS?= detected
.else
PLIST_SUB+= NO_NIS=""
.endif
@@ -143,6 +145,13 @@ pre-patch:
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
+post-patch:
+.if defined(WITHOUT_NIS)
+ ${REINPLACE_CMD} -e \
+ 's/disabled_module_list =[^]]*/&, "nis"/' \
+ ${PATCH_WRKSRC}/setup.py
+.endif
+
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index fa283d2a72ff..5fc533074b86 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -100,8 +100,10 @@ PYABIVER:= m${PYABIVER}
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-.if !exists(/usr/bin/ypcat) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
+WITHOUT_NIS?= detected
.else
PLIST_SUB+= NO_NIS=""
.endif
@@ -147,6 +149,13 @@ pre-patch:
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
+post-patch:
+.if defined(WITHOUT_NIS)
+ ${REINPLACE_CMD} -e \
+ 's/disabled_module_list =[^]]*/&, "nis"/' \
+ ${PATCH_WRKSRC}/setup.py
+.endif
+
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib