aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-10-04 05:17:10 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-10-04 05:17:10 +0000
commitec722082a10e4eb1a17be30daea2eb64ce359964 (patch)
tree95e6891a0e9ea37f0684456b127f209b139885ac /lang
parent183a927e9d09976421c9be531c16162c94c01c7c (diff)
downloadports-ec722082a10e4eb1a17be30daea2eb64ce359964.tar.gz
ports-ec722082a10e4eb1a17be30daea2eb64ce359964.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python-doc-html/distinfo5
-rw-r--r--lang/python/Makefile3
-rw-r--r--lang/python/distinfo1
-rw-r--r--lang/python/files/patch-configure27
-rw-r--r--lang/python/files/patch-pyconfig.h.in11
-rw-r--r--lang/python23/Makefile3
-rw-r--r--lang/python23/distinfo1
-rw-r--r--lang/python23/files/patch-configure27
-rw-r--r--lang/python23/files/patch-pyconfig.h.in11
-rw-r--r--lang/python24/Makefile3
-rw-r--r--lang/python24/distinfo1
-rw-r--r--lang/python24/files/patch-configure27
-rw-r--r--lang/python24/files/patch-pyconfig.h.in11
13 files changed, 38 insertions, 93 deletions
diff --git a/lang/python-doc-html/distinfo b/lang/python-doc-html/distinfo
index 1664c388f00c..28f086bed28c 100644
--- a/lang/python-doc-html/distinfo
+++ b/lang/python-doc-html/distinfo
@@ -54,3 +54,8 @@ MD5 (python/pdf-a4-2.3.1.tar.bz2) = 675721c2588db2752137b12172ecb90d
MD5 (python/pdf-letter-2.3.1.tar.bz2) = f3aac660e95d0af61df8f4789f21755f
MD5 (python/postscript-a4-2.3.1.tar.bz2) = f0931b1e866838721dd062ba1ef7bdab
MD5 (python/postscript-letter-2.3.1.tar.bz2) = 26aad65ac284bb5d2769399a50bda51c
+MD5 (python/html-2.3.2.tar.bz2) = 099df1801c947e4a821605a6ae01c6b2
+MD5 (python/pdf-a4-2.3.2.tar.bz2) = eae1a8eb7f13534ebf068808ac99b0e9
+MD5 (python/pdf-letter-2.3.2.tar.bz2) = 2677385da2db8c3fd05de937a9e148d3
+MD5 (python/postscript-a4-2.3.2.tar.bz2) = fc1752ce42810b87870688327bedecc7
+MD5 (python/postscript-letter-2.3.2.tar.bz2) = 5cca4937bf2b3b662d2c815ebc72a9d5
diff --git a/lang/python/Makefile b/lang/python/Makefile
index c0a54297eeed..f4afc2575e05 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3.1
-PORTREVISION= 2
+PORTVERSION= 2.3.2
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
diff --git a/lang/python/distinfo b/lang/python/distinfo
index 17d0a7cc7c66..a4a8c4eaa046 100644
--- a/lang/python/distinfo
+++ b/lang/python/distinfo
@@ -12,4 +12,5 @@ MD5 (python/Python-2.2.2.tgz) = 1c1067396e5aa0299978486eb5bd1a5c
MD5 (python/Python-2.2.3.tgz) = 169f89f318e252dac0c54dd1b165d229
MD5 (python/Python-2.3.tgz) = 595620a4769073a812e353597585c4e8
MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
+MD5 (python/Python-2.3.2.tgz) = f54d7a529d444994b4b33429bbb45479
MD5 (python/Python-2.4a0-20030801.tgz) = 7bb219e81cd565ed1c360108d9e8ba16
diff --git a/lang/python/files/patch-configure b/lang/python/files/patch-configure
index 271eb9522fbd..6ee47894e12f 100644
--- a/lang/python/files/patch-configure
+++ b/lang/python/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Sun Sep 21 00:29:40 2003
-+++ configure Mon Sep 29 20:01:11 2003
+--- configure.orig Sat Oct 4 13:27:50 2003
++++ configure Sat Oct 4 13:29:05 2003
@@ -1321,7 +1321,7 @@
VERSION=2.3
@@ -9,25 +9,16 @@
# The later defininition of _XOPEN_SOURCE disables certain features
# on Linux, so we need _GNU_SOURCE to re-enable them (makedev, tm_zone).
-@@ -3596,6 +3596,12 @@
+@@ -3594,6 +3594,12 @@
+ LDLIBRARY='libpython$(VERSION).so'
+ BLDLIBRARY='-L. -lpython$(VERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
- INSTSONAME="$LDLIBRARY".$SOVERSION
- ;;
++ INSTSONAME="$LDLIBRARY".$SOVERSION
++ ;;
+ FreeBSD*)
+ LDLIBRARY='libpython$(VERSION).so'
+ BLDLIBRARY='-L. -lpython$(VERSION)'
+ RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
-+ INSTSONAME="$LDLIBRARY".$SOVERSION
-+ ;;
+ INSTSONAME="$LDLIBRARY".$SOVERSION
+ ;;
hp*|HP*)
- LDLIBRARY='libpython$(VERSION).sl'
- BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
-@@ -13384,7 +13390,7 @@
- (exit $ac_status); }; }; then
-
- cat >>confdefs.h <<\_ACEOF
--#define HAVE_SYNC 1
-+#define HAVE_FSYNC 1
- _ACEOF
-
- echo "$as_me:$LINENO: result: yes" >&5
diff --git a/lang/python/files/patch-pyconfig.h.in b/lang/python/files/patch-pyconfig.h.in
deleted file mode 100644
index 289f4dcafcad..000000000000
--- a/lang/python/files/patch-pyconfig.h.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- pyconfig.h.in.orig Fri Sep 26 13:09:17 2003
-+++ pyconfig.h.in Fri Sep 26 13:09:25 2003
-@@ -486,7 +486,7 @@
- #undef HAVE_SYMLINK
-
- /* Define if you have the 'fsync' function. */
--#undef HAVE_SYNC
-+#undef HAVE_FSYNC
-
- /* Define to 1 if you have the `sysconf' function. */
- #undef HAVE_SYSCONF
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index c0a54297eeed..f4afc2575e05 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3.1
-PORTREVISION= 2
+PORTVERSION= 2.3.2
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
diff --git a/lang/python23/distinfo b/lang/python23/distinfo
index 17d0a7cc7c66..a4a8c4eaa046 100644
--- a/lang/python23/distinfo
+++ b/lang/python23/distinfo
@@ -12,4 +12,5 @@ MD5 (python/Python-2.2.2.tgz) = 1c1067396e5aa0299978486eb5bd1a5c
MD5 (python/Python-2.2.3.tgz) = 169f89f318e252dac0c54dd1b165d229
MD5 (python/Python-2.3.tgz) = 595620a4769073a812e353597585c4e8
MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
+MD5 (python/Python-2.3.2.tgz) = f54d7a529d444994b4b33429bbb45479
MD5 (python/Python-2.4a0-20030801.tgz) = 7bb219e81cd565ed1c360108d9e8ba16
diff --git a/lang/python23/files/patch-configure b/lang/python23/files/patch-configure
index 271eb9522fbd..6ee47894e12f 100644
--- a/lang/python23/files/patch-configure
+++ b/lang/python23/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Sun Sep 21 00:29:40 2003
-+++ configure Mon Sep 29 20:01:11 2003
+--- configure.orig Sat Oct 4 13:27:50 2003
++++ configure Sat Oct 4 13:29:05 2003
@@ -1321,7 +1321,7 @@
VERSION=2.3
@@ -9,25 +9,16 @@
# The later defininition of _XOPEN_SOURCE disables certain features
# on Linux, so we need _GNU_SOURCE to re-enable them (makedev, tm_zone).
-@@ -3596,6 +3596,12 @@
+@@ -3594,6 +3594,12 @@
+ LDLIBRARY='libpython$(VERSION).so'
+ BLDLIBRARY='-L. -lpython$(VERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
- INSTSONAME="$LDLIBRARY".$SOVERSION
- ;;
++ INSTSONAME="$LDLIBRARY".$SOVERSION
++ ;;
+ FreeBSD*)
+ LDLIBRARY='libpython$(VERSION).so'
+ BLDLIBRARY='-L. -lpython$(VERSION)'
+ RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
-+ INSTSONAME="$LDLIBRARY".$SOVERSION
-+ ;;
+ INSTSONAME="$LDLIBRARY".$SOVERSION
+ ;;
hp*|HP*)
- LDLIBRARY='libpython$(VERSION).sl'
- BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
-@@ -13384,7 +13390,7 @@
- (exit $ac_status); }; }; then
-
- cat >>confdefs.h <<\_ACEOF
--#define HAVE_SYNC 1
-+#define HAVE_FSYNC 1
- _ACEOF
-
- echo "$as_me:$LINENO: result: yes" >&5
diff --git a/lang/python23/files/patch-pyconfig.h.in b/lang/python23/files/patch-pyconfig.h.in
deleted file mode 100644
index 289f4dcafcad..000000000000
--- a/lang/python23/files/patch-pyconfig.h.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- pyconfig.h.in.orig Fri Sep 26 13:09:17 2003
-+++ pyconfig.h.in Fri Sep 26 13:09:25 2003
-@@ -486,7 +486,7 @@
- #undef HAVE_SYMLINK
-
- /* Define if you have the 'fsync' function. */
--#undef HAVE_SYNC
-+#undef HAVE_FSYNC
-
- /* Define to 1 if you have the `sysconf' function. */
- #undef HAVE_SYSCONF
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index c0a54297eeed..f4afc2575e05 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3.1
-PORTREVISION= 2
+PORTVERSION= 2.3.2
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
diff --git a/lang/python24/distinfo b/lang/python24/distinfo
index 17d0a7cc7c66..a4a8c4eaa046 100644
--- a/lang/python24/distinfo
+++ b/lang/python24/distinfo
@@ -12,4 +12,5 @@ MD5 (python/Python-2.2.2.tgz) = 1c1067396e5aa0299978486eb5bd1a5c
MD5 (python/Python-2.2.3.tgz) = 169f89f318e252dac0c54dd1b165d229
MD5 (python/Python-2.3.tgz) = 595620a4769073a812e353597585c4e8
MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
+MD5 (python/Python-2.3.2.tgz) = f54d7a529d444994b4b33429bbb45479
MD5 (python/Python-2.4a0-20030801.tgz) = 7bb219e81cd565ed1c360108d9e8ba16
diff --git a/lang/python24/files/patch-configure b/lang/python24/files/patch-configure
index 271eb9522fbd..6ee47894e12f 100644
--- a/lang/python24/files/patch-configure
+++ b/lang/python24/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Sun Sep 21 00:29:40 2003
-+++ configure Mon Sep 29 20:01:11 2003
+--- configure.orig Sat Oct 4 13:27:50 2003
++++ configure Sat Oct 4 13:29:05 2003
@@ -1321,7 +1321,7 @@
VERSION=2.3
@@ -9,25 +9,16 @@
# The later defininition of _XOPEN_SOURCE disables certain features
# on Linux, so we need _GNU_SOURCE to re-enable them (makedev, tm_zone).
-@@ -3596,6 +3596,12 @@
+@@ -3594,6 +3594,12 @@
+ LDLIBRARY='libpython$(VERSION).so'
+ BLDLIBRARY='-L. -lpython$(VERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
- INSTSONAME="$LDLIBRARY".$SOVERSION
- ;;
++ INSTSONAME="$LDLIBRARY".$SOVERSION
++ ;;
+ FreeBSD*)
+ LDLIBRARY='libpython$(VERSION).so'
+ BLDLIBRARY='-L. -lpython$(VERSION)'
+ RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
-+ INSTSONAME="$LDLIBRARY".$SOVERSION
-+ ;;
+ INSTSONAME="$LDLIBRARY".$SOVERSION
+ ;;
hp*|HP*)
- LDLIBRARY='libpython$(VERSION).sl'
- BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
-@@ -13384,7 +13390,7 @@
- (exit $ac_status); }; }; then
-
- cat >>confdefs.h <<\_ACEOF
--#define HAVE_SYNC 1
-+#define HAVE_FSYNC 1
- _ACEOF
-
- echo "$as_me:$LINENO: result: yes" >&5
diff --git a/lang/python24/files/patch-pyconfig.h.in b/lang/python24/files/patch-pyconfig.h.in
deleted file mode 100644
index 289f4dcafcad..000000000000
--- a/lang/python24/files/patch-pyconfig.h.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- pyconfig.h.in.orig Fri Sep 26 13:09:17 2003
-+++ pyconfig.h.in Fri Sep 26 13:09:25 2003
-@@ -486,7 +486,7 @@
- #undef HAVE_SYMLINK
-
- /* Define if you have the 'fsync' function. */
--#undef HAVE_SYNC
-+#undef HAVE_FSYNC
-
- /* Define to 1 if you have the `sysconf' function. */
- #undef HAVE_SYSCONF