aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-11-22 08:35:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-11-22 08:35:23 +0000
commitf63311415c95894de3b0842b03b078607e614729 (patch)
treeeb97eb620d88dced085081fff8ee2d0e3ebd9fe4 /lang
parente202be6a263e1c88c91f146c0a0648113e4a9cec (diff)
downloadports-f63311415c95894de3b0842b03b078607e614729.tar.gz
ports-f63311415c95894de3b0842b03b078607e614729.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/q/Makefile4
-rw-r--r--lang/q/files/patch-modules-octave_octave.c19
-rw-r--r--lang/q/files/patch-src_qmparse.y10
3 files changed, 29 insertions, 4 deletions
diff --git a/lang/q/Makefile b/lang/q/Makefile
index 5505397fa8a2..c5af638ea287 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -80,10 +80,6 @@ INFO= qdoc
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if ${ARCH} == "amd64"
BROKEN= Does not build on amd64 (shared libraries must be compiled with -fPIC)
.endif
diff --git a/lang/q/files/patch-modules-octave_octave.c b/lang/q/files/patch-modules-octave_octave.c
new file mode 100644
index 000000000000..891db66f7685
--- /dev/null
+++ b/lang/q/files/patch-modules-octave_octave.c
@@ -0,0 +1,19 @@
+--- modules/octave/octave.c.orig 2007-11-14 03:04:18.000000000 +0100
++++ modules/octave/octave.c 2007-11-14 03:06:27.000000000 +0100
+@@ -126,6 +126,8 @@
+ static const char *octaverc = ".octaverc";
+ static const char *octaverc_bak = ".octaverc.$$$";
+
++static int send_octave(char *);
++
+ /* handle SIGINT and SIGTERM */
+
+ #if RETSIGTYPE == void
+@@ -272,7 +274,6 @@
+ FILE *fp, *fp2;
+ char buf[bufsz];
+ int bak = 0;
+- static int send_octave(char *cmd);
+ static int init = 0;
+ if (!octp) {
+ /* get the command from the OCTAVE variable if defined */
diff --git a/lang/q/files/patch-src_qmparse.y b/lang/q/files/patch-src_qmparse.y
new file mode 100644
index 000000000000..a07f756d502e
--- /dev/null
+++ b/lang/q/files/patch-src_qmparse.y
@@ -0,0 +1,10 @@
+--- src/qmparse.y.orig 2007-11-14 03:07:31.000000000 +0100
++++ src/qmparse.y 2007-11-14 03:09:06.000000000 +0100
+@@ -239,7 +239,6 @@
+
+ | _PROMPT_ arg_list
+ {
+- static savepos();
+ char **argv = $2.v;
+ int argc = $2.c, i;
+ if (argc == 0) {