aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-06-20 02:09:12 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-06-20 02:09:12 +0000
commitfdbefa0bcc11e8ce3b98b58a7003760167cec896 (patch)
treeb09353fee0405ece59df25ea335c7df3c54cc5a2 /lang
parentd7ebba1c06e5728081090f503c204d120bbf5d3b (diff)
downloadports-fdbefa0bcc11e8ce3b98b58a7003760167cec896.tar.gz
ports-fdbefa0bcc11e8ce3b98b58a7003760167cec896.zip
Fix conditional. "defined(${MLSIZE})" is only true if MLSIZE's value
happens to be a defined variable name. Reported by: tobik Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=539692
Diffstat (limited to 'lang')
-rw-r--r--lang/smlnj/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/smlnj/Makefile b/lang/smlnj/Makefile
index 82603a394798..7779a16ee1ff 100644
--- a/lang/smlnj/Makefile
+++ b/lang/smlnj/Makefile
@@ -79,7 +79,7 @@ MLSRCS+= ${MLROOT}/${srcdir}
MLTARGETS= heap2asm
MLEXE= asdlgen heap2exec ml-antlr ml-build ml-burg ml-lex \
ml-makedepend ml-ulex ml-yacc sml
-.if defined(${MLSIZE}) && ${MLSIZE} == 32
+.if defined(MLSIZE) && ${MLSIZE} == 32
MLEXE+= ml-nlffigen
.endif
.if ${PORT_OPTIONS:MEVERYTHING}