aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2006-09-20 06:25:49 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2006-09-20 06:25:49 +0000
commit03e9478acc6f951aade8dbab2e0e7560f49d2643 (patch)
tree34f1437c182455fe9692119458c0c4e1b27c49da /lang
parent60ae946d9375b3cfe62bba38ddd35fff5015ea95 (diff)
downloadports-03e9478acc6f951aade8dbab2e0e7560f49d2643.tar.gz
ports-03e9478acc6f951aade8dbab2e0e7560f49d2643.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/drscheme/Makefile9
-rw-r--r--lang/drscheme/files/patch-collects-profj-to-scheme.ss20
-rw-r--r--lang/drscheme/pkg-plist2
3 files changed, 28 insertions, 3 deletions
diff --git a/lang/drscheme/Makefile b/lang/drscheme/Makefile
index 9c1b12d60327..b10d5b02d4c3 100644
--- a/lang/drscheme/Makefile
+++ b/lang/drscheme/Makefile
@@ -7,6 +7,7 @@
PORTNAME= drscheme
PORTVERSION= 351
+PORTREVISION= 1
CATEGORIES= lang scheme
MASTER_SITES= http://download.plt-scheme.org/bundles/${PORTVERSION}/plt/ \
http://www.cs.utah.edu/plt/download/${PORTVERSION}/plt/ \
@@ -22,11 +23,12 @@ EXTRACT_ONLY= plt-${PORTVERSION}-src-unix.tgz
MAINTAINER= jkoshy@FreeBSD.org
COMMENT= An interactive, integrated, graphical Scheme programming environment
-BROKEN= Does not compile
+LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared --x-includes=${X11BASE}/include \
- --x-libraries=${X11BASE}/lib --enable-lt=${LIBTOOL}
+ --x-libraries=${X11BASE}/lib --enable-lt=${LIBTOOL} --disable-libpng \
+ --disable-libjpeg
WRKSRC= ${WRKDIR}/plt/src
USE_LDCONFIG= yes
@@ -59,4 +61,7 @@ PLIST_SUB+= MMM=""
PLIST_SUB+= MMM="@comment "
.endif
+post-patch:
+ ${RM} ${WRKSRC}/../collects/profj/to-scheme.ss.orig
+
.include <bsd.port.post.mk>
diff --git a/lang/drscheme/files/patch-collects-profj-to-scheme.ss b/lang/drscheme/files/patch-collects-profj-to-scheme.ss
new file mode 100644
index 000000000000..78032d895fd7
--- /dev/null
+++ b/lang/drscheme/files/patch-collects-profj-to-scheme.ss
@@ -0,0 +1,20 @@
+--- ../collects/profj/to-scheme.ss 2006/08/02 03:53:43 3922
++++ ../trunk/collects/profj/to-scheme.ss 2006/09/19 21:01:05 4389
+@@ -341,13 +341,14 @@
+ (member (id-string (name-id extend))
+ (map id-string (map def-name ordered-defs)))))
+
+- ;make-composite-name: def -> string
++ ;make-composite-name: string -> string
+ (define (make-composite-name d)
+- (build-identifier (string-append (id-string (header-id (def-header d))) "-composite")))
++ (build-identifier (string-append d "-composite")))
+
+ ;translate-defs: (list def) type-records -> (values (list syntax) (list reqs))
+ (define (translate-defs defs type-recs)
+- (module-name (make-composite-name (car defs)))
++ (let ((sorted-d-list (sort (map (compose id-string def-name) defs) string<?)))
++ (module-name (make-composite-name (car sorted-d-list))))
+ (module-require (if (to-file)
+ (let ((location (build-path (begin (send type-recs set-location! (def-file (car defs)))
+ (send type-recs get-compilation-location) "compiled")
diff --git a/lang/drscheme/pkg-plist b/lang/drscheme/pkg-plist
index 9fe73e0b9620..00a5a3aaf93d 100644
--- a/lang/drscheme/pkg-plist
+++ b/lang/drscheme/pkg-plist
@@ -1797,6 +1797,7 @@ lib/plt/collects/htdch/graphics/compiled/Command.jinfo
lib/plt/collects/htdch/graphics/compiled/Command.zo
lib/plt/collects/htdch/graphics/compiled/CommandSequence.jinfo
lib/plt/collects/htdch/graphics/compiled/CommandSequence.zo
+lib/plt/collects/htdch/graphics/compiled/CommandSequence-composite.zo
lib/plt/collects/htdch/graphics/compiled/DrawImage.jinfo
lib/plt/collects/htdch/graphics/compiled/DrawImage.zo
lib/plt/collects/htdch/graphics/compiled/DrawLine.jinfo
@@ -1825,7 +1826,6 @@ lib/plt/collects/htdch/graphics/compiled/Red.jinfo
lib/plt/collects/htdch/graphics/compiled/Red.zo
lib/plt/collects/htdch/graphics/compiled/View.jinfo
lib/plt/collects/htdch/graphics/compiled/View.zo
-lib/plt/collects/htdch/graphics/compiled/View-composite.zo
lib/plt/collects/htdch/graphics/compiled/White.jinfo
lib/plt/collects/htdch/graphics/compiled/White.zo
lib/plt/collects/htdch/graphics/compiled/World.jinfo