aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2011-10-28 10:42:24 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2011-10-28 10:42:24 +0000
commit5bc148fb49f344096c1b58fc5cdea109d4171688 (patch)
treeb26aba1dddb29650efab7491684c395baaeaccbc /lang
parent250c73a74b44026f858451128b6b5514e522249d (diff)
downloadports-5bc148fb49f344096c1b58fc5cdea109d4171688.tar.gz
ports-5bc148fb49f344096c1b58fc5cdea109d4171688.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python24/Makefile4
-rw-r--r--lang/python24/files/patch-freebsd72
-rw-r--r--lang/python24/pkg-plist3
-rw-r--r--lang/python25/Makefile5
-rw-r--r--lang/python25/files/patch-freebsd82
-rw-r--r--lang/python25/pkg-plist3
-rw-r--r--lang/python26/Makefile6
-rw-r--r--lang/python26/files/extra-patch-setup.py4
-rw-r--r--lang/python26/files/patch-Lib-test-test_fcntl.py2
-rw-r--r--lang/python26/files/patch-Lib-test-test_socket.py2
-rw-r--r--lang/python26/files/patch-Lib_test_test_threading.py2
-rw-r--r--lang/python26/files/patch-setup.py4
-rw-r--r--lang/python26/pkg-plist3
-rw-r--r--lang/python31/Makefile6
-rw-r--r--lang/python31/files/patch-Lib-test-test_fcntl.py2
-rw-r--r--lang/python31/files/patch-Lib-test_regrtest.py7
-rw-r--r--lang/python31/files/patch-setup.py4
-rw-r--r--lang/python31/pkg-plist3
-rw-r--r--lang/python32/Makefile6
-rw-r--r--lang/python32/files/patch-Lib-test-test_fcntl.py2
-rw-r--r--lang/python32/files/patch-Lib-test_regrtest.py7
-rw-r--r--lang/python32/files/patch-setup.py4
-rw-r--r--lang/python32/pkg-plist6
23 files changed, 63 insertions, 26 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index dec843e3ddac..7a22c2436dd0 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -31,7 +31,7 @@ PYTHON_VERSION= python2.4
PYTHON_NO_DEPENDS= yes
PLATFORMS= plat-freebsd4 plat-freebsd5 plat-freebsd6 plat-freebsd7 \
- plat-freebsd8 plat-freebsd9
+ plat-freebsd8 plat-freebsd9 plat-freebsd10
SHARED_WRKSRC= ${WRKSRC}/build.shared
PLIST= ${WRKDIR}/pkg-plist
PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
@@ -163,6 +163,8 @@ post-build:
pre-su-install:
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd9
+ ${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
+ ${PATCH_WRKSRC}/Lib/plat-freebsd10
.for platform in ${PLATFORMS}
${MKDIR} ${PYTHONPREFIX_LIBDIR}/${platform}
.for file in IN.py regen
diff --git a/lang/python24/files/patch-freebsd7 b/lang/python24/files/patch-freebsd7
index a3e7569529f7..794815576f17 100644
--- a/lang/python24/files/patch-freebsd7
+++ b/lang/python24/files/patch-freebsd7
@@ -11,7 +11,7 @@ diff -u -r1.218 setup.py
- if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6'):
+ if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
-+ 'freebsd7', 'freebsd8', 'freebsd9'):
++ 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
if platform == 'sunos5':
diff --git a/lang/python24/pkg-plist b/lang/python24/pkg-plist
index 8b1222328f1e..88fe79a97e0d 100644
--- a/lang/python24/pkg-plist
+++ b/lang/python24/pkg-plist
@@ -673,6 +673,8 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/plat-freebsd8/regen
%%PYTHON_LIBDIR%%/plat-freebsd9/IN.py
%%PYTHON_LIBDIR%%/plat-freebsd9/regen
+%%PYTHON_LIBDIR%%/plat-freebsd10/IN.py
+%%PYTHON_LIBDIR%%/plat-freebsd10/regen
%%PYTHON_LIBDIR%%/platform.py
%%PYTHON_LIBDIR%%/popen2.py
%%PYTHON_LIBDIR%%/poplib.py
@@ -1688,6 +1690,7 @@ lib/lib%%PYTHON_VERSION%%.so.1
@dirrm %%PYTHON_LIBDIR%%/test/decimaltestdata
@dirrm %%PYTHON_LIBDIR%%/test
@dirrm %%PYTHON_LIBDIR%%/site-packages
+@dirrm %%PYTHON_LIBDIR%%/plat-freebsd10
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd9
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd8
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd7
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 0a0560ced7a7..4ce5fea4cf00 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -40,7 +40,8 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
DATADIR= ${PREFIX}/share/${PYTHON_VERSION}
PLATFORMS= plat-freebsd4 plat-freebsd5 plat-freebsd6 \
- plat-freebsd7 plat-freebsd8 plat-freebsd9
+ plat-freebsd7 plat-freebsd8 plat-freebsd9 \
+ plat-freebsd10
BIN_SCRIPTS= idle pydoc python python-shared smtpd.py python-config \
python-shared-config
@@ -167,6 +168,8 @@ pre-build:
pre-su-install:
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd9
+ ${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
+ ${PATCH_WRKSRC}/Lib/plat-freebsd10
.for platform in ${PLATFORMS}
${MKDIR} ${PYTHONPREFIX_LIBDIR}/${platform}
.for file in IN.py regen
diff --git a/lang/python25/files/patch-freebsd8 b/lang/python25/files/patch-freebsd8
index ad4f1eff7c67..53e302ea43e1 100644
--- a/lang/python25/files/patch-freebsd8
+++ b/lang/python25/files/patch-freebsd8
@@ -932,7 +932,7 @@ Index: Lib/plat-freebsd8/IN.py
if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7'):
-+ 'freebsd7', 'freebsd8', 'freebsd9'):
++ 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
if platform == 'sunos5':
diff --git a/lang/python25/pkg-plist b/lang/python25/pkg-plist
index b8494174919b..084c717612ed 100644
--- a/lang/python25/pkg-plist
+++ b/lang/python25/pkg-plist
@@ -755,6 +755,8 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/plat-freebsd8/regen
%%PYTHON_LIBDIR%%/plat-freebsd9/IN.py
%%PYTHON_LIBDIR%%/plat-freebsd9/regen
+%%PYTHON_LIBDIR%%/plat-freebsd10/IN.py
+%%PYTHON_LIBDIR%%/plat-freebsd10/regen
%%PYTHON_LIBDIR%%/platform.py
%%PYTHON_LIBDIR%%/popen2.py
%%PYTHON_LIBDIR%%/poplib.py
@@ -1988,6 +1990,7 @@ lib/lib%%PYTHON_VERSION%%.so.1
@dirrm %%PYTHON_LIBDIR%%/sqlite3/test
@dirrm %%PYTHON_LIBDIR%%/sqlite3
@dirrm %%PYTHON_LIBDIR%%/site-packages
+@dirrm %%PYTHON_LIBDIR%%/plat-freebsd10
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd9
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd8
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd7
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 38be184fff72..915a94478d75 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -23,6 +23,7 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
USE_LDCONFIG= yes
+WITH_FBSD10_FIX= yes
MAKE_JOBS_SAFE= yes
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
@@ -39,7 +40,8 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
DATADIR= ${PREFIX}/share/${PYTHON_VERSION}
-PLATFORMS= plat-freebsd6 plat-freebsd7 plat-freebsd8 plat-freebsd9
+PLATFORMS= plat-freebsd6 plat-freebsd7 plat-freebsd8 plat-freebsd9 \
+ plat-freebsd10
BIN_SCRIPTS= 2to3 idle pydoc smtpd.py
BIN_FILES= python python-shared python-config python-shared-config \
@@ -144,6 +146,8 @@ CONFIGURE_ARGS+= --with-fpectl
pre-patch:
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd9
+ ${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
+ ${PATCH_WRKSRC}/Lib/plat-freebsd10
${MKDIR} ${WRKSRC} ${SHARED_WRKSRC}/Modules
${LN} ${PATCH_WRKSRC}/Lib/smtpd.py ${PATCH_WRKSRC}/Tools/scripts/
.for script in ${BIN_SCRIPTS}
diff --git a/lang/python26/files/extra-patch-setup.py b/lang/python26/files/extra-patch-setup.py
index 77dc467db500..1122acac8054 100644
--- a/lang/python26/files/extra-patch-setup.py
+++ b/lang/python26/files/extra-patch-setup.py
@@ -4,7 +4,7 @@
)
libraries = []
-- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
+- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
@@ -16,7 +16,7 @@
+ )
+ libraries = []
+
-+ elif platform in ('freebsd7', 'freebsd8', 'freebsd9'):
++ elif platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
+ macros = dict( # FreeBSD 7+
+ HAVE_SEM_OPEN=1,
+ HAVE_SEM_TIMEDWAIT=1,
diff --git a/lang/python26/files/patch-Lib-test-test_fcntl.py b/lang/python26/files/patch-Lib-test-test_fcntl.py
index ebd2ec81265f..f8773e0aaf1c 100644
--- a/lang/python26/files/patch-Lib-test-test_fcntl.py
+++ b/lang/python26/files/patch-Lib-test-test_fcntl.py
@@ -5,7 +5,7 @@
'Darwin1.2', 'darwin',
'freebsd2', 'freebsd3', 'freebsd4', 'freebsd5',
- 'freebsd6', 'freebsd7', 'freebsd8',
-+ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9',
++ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'
'bsdos2', 'bsdos3', 'bsdos4',
'openbsd', 'openbsd2', 'openbsd3', 'openbsd4'):
if struct.calcsize('l') == 8:
diff --git a/lang/python26/files/patch-Lib-test-test_socket.py b/lang/python26/files/patch-Lib-test-test_socket.py
index 8c1ada8b2da6..7ccd3fe31bea 100644
--- a/lang/python26/files/patch-Lib-test-test_socket.py
+++ b/lang/python26/files/patch-Lib-test-test_socket.py
@@ -5,7 +5,7 @@
# protocol, at least for modern Linuxes.
if sys.platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8', 'darwin'):
-+ 'freebsd7', 'freebsd8', 'freebsd9', 'darwin'):
++ 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10', 'darwin'):
# avoid the 'echo' service on this platform, as there is an
# assumption breaking non-standard port/protocol entry
services = ('daytime', 'qotd', 'domain')
diff --git a/lang/python26/files/patch-Lib_test_test_threading.py b/lang/python26/files/patch-Lib_test_test_threading.py
index c7dec6dd9b87..82d1658b3e26 100644
--- a/lang/python26/files/patch-Lib_test_test_threading.py
+++ b/lang/python26/files/patch-Lib_test_test_threading.py
@@ -5,7 +5,7 @@
# Skip platforms with known problems forking from a worker thread.
# See http://bugs.python.org/issue3863.
- if sys.platform in ('freebsd4', 'freebsd5', 'freebsd6', 'os2emx'):
-+ if sys.platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'os2emx'):
++ if sys.platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10', 'os2emx'):
print >>sys.stderr, ('Skipping test_3_join_in_forked_from_thread'
' due to known OS bugs on'), sys.platform
return
diff --git a/lang/python26/files/patch-setup.py b/lang/python26/files/patch-setup.py
index 829817af3af7..271cda1f30be 100644
--- a/lang/python26/files/patch-setup.py
+++ b/lang/python26/files/patch-setup.py
@@ -73,7 +73,7 @@
libraries = []
- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
-+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
++ elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
macros = dict( # FreeBSD
@@ -82,7 +82,7 @@
if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8'):
-+ 'freebsd7', 'freebsd8', 'freebsd9'):
++ 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
else:
missing.append('ossaudiodev')
diff --git a/lang/python26/pkg-plist b/lang/python26/pkg-plist
index 7f3720bf6a10..1010fb68d6c1 100644
--- a/lang/python26/pkg-plist
+++ b/lang/python26/pkg-plist
@@ -919,6 +919,8 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/plat-freebsd8/regen
%%PYTHON_LIBDIR%%/plat-freebsd9/IN.py
%%PYTHON_LIBDIR%%/plat-freebsd9/regen
+%%PYTHON_LIBDIR%%/plat-freebsd10/IN.py
+%%PYTHON_LIBDIR%%/plat-freebsd10/regen
%%PYTHON_LIBDIR%%/platform.py
%%PYTHON_LIBDIR%%/plistlib.py
%%PYTHON_LIBDIR%%/popen2.py
@@ -2220,6 +2222,7 @@ lib/libpython2.6.a
@dirrm %%PYTHON_LIBDIR%%/sqlite3/test
@dirrm %%PYTHON_LIBDIR%%/sqlite3
@dirrm %%PYTHON_LIBDIR%%/site-packages
+@dirrm %%PYTHON_LIBDIR%%/plat-freebsd10
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd9
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd8
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd7
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 3b262749ac10..ccd3a9aa10fb 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
+WITH_FBSD10_FIX= yes
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
@@ -40,7 +41,8 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
DATADIR= ${PREFIX}/share/${PYTHON_VERSION}
PLATFORMS= plat-freebsd4 plat-freebsd5 plat-freebsd6 \
- plat-freebsd7 plat-freebsd8 plat-freebsd9
+ plat-freebsd7 plat-freebsd8 plat-freebsd9 \
+ plat-freebsd10
BIN_SCRIPTS= 2to3 idle3 pydoc3
BIN_FILES= python python-shared python-config python-shared-config \
@@ -109,6 +111,8 @@ CONFIGURE_ARGS+= --with-fpectl
pre-patch:
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd9
+ ${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
+ ${PATCH_WRKSRC}/Lib/plat-freebsd10
${MKDIR} ${WRKSRC} ${SHARED_WRKSRC}/Modules
.for script in ${BIN_SCRIPTS}
${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \
diff --git a/lang/python31/files/patch-Lib-test-test_fcntl.py b/lang/python31/files/patch-Lib-test-test_fcntl.py
index 62104a2da20e..606a6e9a9612 100644
--- a/lang/python31/files/patch-Lib-test-test_fcntl.py
+++ b/lang/python31/files/patch-Lib-test-test_fcntl.py
@@ -5,7 +5,7 @@
'Darwin1.2', 'darwin',
'freebsd2', 'freebsd3', 'freebsd4', 'freebsd5',
- 'freebsd6', 'freebsd7', 'freebsd8',
-+ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9',
++ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10',
'bsdos2', 'bsdos3', 'bsdos4',
'openbsd', 'openbsd2', 'openbsd3', 'openbsd4'):
if struct.calcsize('l') == 8:
diff --git a/lang/python31/files/patch-Lib-test_regrtest.py b/lang/python31/files/patch-Lib-test_regrtest.py
index d10cb99056e6..99754f75043e 100644
--- a/lang/python31/files/patch-Lib-test_regrtest.py
+++ b/lang/python31/files/patch-Lib-test_regrtest.py
@@ -1,10 +1,11 @@
---- Lib/test/regrtest.py.orgi 2009-11-26 13:29:08.000000000 +0100
-+++ Lib/test/regrtest.py 2009-11-26 13:29:37.000000000 +0100
-@@ -1146,6 +1146,7 @@
+--- Lib/test/regrtest.py.orig 2011-06-11 17:48:50.000000000 +0200
++++ Lib/test/regrtest.py 2011-10-28 11:17:37.000000000 +0200
+@@ -1203,6 +1203,8 @@
_expectations['freebsd6'] = _expectations['freebsd4']
_expectations['freebsd7'] = _expectations['freebsd4']
_expectations['freebsd8'] = _expectations['freebsd4']
+_expectations['freebsd9'] = _expectations['freebsd4']
++_expectations['freebsd10'] = _expectations['freebsd4']
class _ExpectedSkips:
def __init__(self):
diff --git a/lang/python31/files/patch-setup.py b/lang/python31/files/patch-setup.py
index ee5430f79091..70983b7f89b1 100644
--- a/lang/python31/files/patch-setup.py
+++ b/lang/python31/files/patch-setup.py
@@ -64,7 +64,7 @@
libraries = []
- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
-+ elif platform in ('freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
++ elif platform in ('freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
macros = dict()
@@ -74,7 +74,7 @@
# Platform-specific libraries
- if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8'):
-+ if platform in ('linux2', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
++ if platform in ('linux2', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
else:
missing.append('ossaudiodev')
diff --git a/lang/python31/pkg-plist b/lang/python31/pkg-plist
index a40334f4dab5..52d8d909749f 100644
--- a/lang/python31/pkg-plist
+++ b/lang/python31/pkg-plist
@@ -899,6 +899,8 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/plat-freebsd8/regen
%%PYTHON_LIBDIR%%/plat-freebsd9/IN.py
%%PYTHON_LIBDIR%%/plat-freebsd9/regen
+%%PYTHON_LIBDIR%%/plat-freebsd10/IN.py
+%%PYTHON_LIBDIR%%/plat-freebsd10/regen
%%PYTHON_LIBDIR%%/platform.py
%%PYTHON_LIBDIR%%/plistlib.py
%%PYTHON_LIBDIR%%/poplib.py
@@ -2215,6 +2217,7 @@ libdata/pkgconfig/python-3.1.pc
@dirrm %%PYTHON_LIBDIR%%/sqlite3
@dirrm %%PYTHON_LIBDIR%%/site-packages
@dirrm %%PYTHON_LIBDIR%%/pydoc_data
+@dirrm %%PYTHON_LIBDIR%%/plat-freebsd10
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd9
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd8
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd7
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 8d2ebe779c75..a845d3a6861c 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
+WITH_FBSD10_FIX= yes
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
@@ -41,7 +42,8 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
DATADIR= ${PREFIX}/share/${PYTHON_VERSION}
PLATFORMS= plat-freebsd4 plat-freebsd5 plat-freebsd6 \
- plat-freebsd7 plat-freebsd8 plat-freebsd9
+ plat-freebsd7 plat-freebsd8 plat-freebsd9 \
+ plat-freebsd10
BIN_SCRIPTS= 2to3 idle3 pydoc3
BIN_FILES= python python-shared python-config python-shared-config \
@@ -113,6 +115,8 @@ CONFIGURE_ARGS+= --with-fpectl
pre-patch:
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd9
+ ${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
+ ${PATCH_WRKSRC}/Lib/plat-freebsd10
${MKDIR} ${WRKSRC} ${SHARED_WRKSRC}/Modules
.for script in ${BIN_SCRIPTS}
${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \
diff --git a/lang/python32/files/patch-Lib-test-test_fcntl.py b/lang/python32/files/patch-Lib-test-test_fcntl.py
index 62104a2da20e..bc3987953d67 100644
--- a/lang/python32/files/patch-Lib-test-test_fcntl.py
+++ b/lang/python32/files/patch-Lib-test-test_fcntl.py
@@ -5,7 +5,7 @@
'Darwin1.2', 'darwin',
'freebsd2', 'freebsd3', 'freebsd4', 'freebsd5',
- 'freebsd6', 'freebsd7', 'freebsd8',
-+ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9',
++ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'
'bsdos2', 'bsdos3', 'bsdos4',
'openbsd', 'openbsd2', 'openbsd3', 'openbsd4'):
if struct.calcsize('l') == 8:
diff --git a/lang/python32/files/patch-Lib-test_regrtest.py b/lang/python32/files/patch-Lib-test_regrtest.py
index d10cb99056e6..f3337036cefc 100644
--- a/lang/python32/files/patch-Lib-test_regrtest.py
+++ b/lang/python32/files/patch-Lib-test_regrtest.py
@@ -1,10 +1,11 @@
---- Lib/test/regrtest.py.orgi 2009-11-26 13:29:08.000000000 +0100
-+++ Lib/test/regrtest.py 2009-11-26 13:29:37.000000000 +0100
-@@ -1146,6 +1146,7 @@
+--- Lib/test/regrtest.py.orig 2011-09-03 18:16:43.000000000 +0200
++++ Lib/test/regrtest.py 2011-10-28 11:26:04.000000000 +0200
+@@ -1522,6 +1522,8 @@
_expectations['freebsd6'] = _expectations['freebsd4']
_expectations['freebsd7'] = _expectations['freebsd4']
_expectations['freebsd8'] = _expectations['freebsd4']
+_expectations['freebsd9'] = _expectations['freebsd4']
++_expectations['freebsd10'] = _expectations['freebsd4']
class _ExpectedSkips:
def __init__(self):
diff --git a/lang/python32/files/patch-setup.py b/lang/python32/files/patch-setup.py
index 78ebd9ab74b7..e79da3d11fb6 100644
--- a/lang/python32/files/patch-setup.py
+++ b/lang/python32/files/patch-setup.py
@@ -55,7 +55,7 @@
libraries = []
- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
-+ elif platform in ('freebsd7', 'freebsd8', 'freebsd9'):
++ elif platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
macros = dict()
@@ -65,7 +65,7 @@
# Platform-specific libraries
- if (platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8')
-+ if (platform in ('freebsd7', 'freebsd8', 'freebsd9')
++ if (platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10')
or platform.startswith("gnukfreebsd")):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
else:
diff --git a/lang/python32/pkg-plist b/lang/python32/pkg-plist
index 7dc2737630c3..abc07b2d9f86 100644
--- a/lang/python32/pkg-plist
+++ b/lang/python32/pkg-plist
@@ -2285,6 +2285,10 @@ libdata/pkgconfig/python-3.2.pc
%%PYTHON_LIBDIR%%/plat-freebsd9/__pycache__/IN.cpython-32.pyc
%%PYTHON_LIBDIR%%/plat-freebsd9/__pycache__/IN.cpython-32.pyo
%%PYTHON_LIBDIR%%/plat-freebsd9/regen
+%%PYTHON_LIBDIR%%/plat-freebsd10/IN.py
+%%PYTHON_LIBDIR%%/plat-freebsd10/__pycache__/IN.cpython-32.pyc
+%%PYTHON_LIBDIR%%/plat-freebsd10/__pycache__/IN.cpython-32.pyo
+%%PYTHON_LIBDIR%%/plat-freebsd10/regen
%%PYTHON_LIBDIR%%/platform.py
%%PYTHON_LIBDIR%%/plistlib.py
%%PYTHON_LIBDIR%%/poplib.py
@@ -4320,6 +4324,8 @@ libdata/pkgconfig/python-3.2.pc
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd8
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd9/__pycache__
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd9
+@dirrm %%PYTHON_LIBDIR%%/plat-freebsd10/__pycache__
+@dirrm %%PYTHON_LIBDIR%%/plat-freebsd10
@dirrm %%PYTHON_LIBDIR%%/pydoc_data/__pycache__
@dirrm %%PYTHON_LIBDIR%%/pydoc_data
@dirrm %%PYTHON_LIBDIR%%/site-packages