aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-05-03 10:45:08 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-05-03 10:45:08 +0000
commit89bfc042101f96276b4ddd4feab855ad7b53c04e (patch)
tree2c17c6ea7433b1d23ad7d409efe70cce22943e78 /lang
parente6ff23fafcac3488a784b4f1e9337a0153cd7e26 (diff)
downloadports-89bfc042101f96276b4ddd4feab855ad7b53c04e.tar.gz
ports-89bfc042101f96276b4ddd4feab855ad7b53c04e.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/perl5.10/Makefile2
-rw-r--r--lang/perl5.12/Makefile2
-rw-r--r--lang/perl5.14/Makefile2
-rw-r--r--lang/perl5.16/Makefile2
-rw-r--r--lang/perl5.6/Makefile2
-rw-r--r--lang/perl5.8/Makefile2
-rw-r--r--lang/perl5/Makefile2
7 files changed, 9 insertions, 5 deletions
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index f349ce63a9e9..61671171fd00 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -96,7 +96,7 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-LATEST_LINK= perl5.8
+LATEST_LINK= perl
.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index f349ce63a9e9..61671171fd00 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -96,7 +96,7 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-LATEST_LINK= perl5.8
+LATEST_LINK= perl
.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index f349ce63a9e9..61671171fd00 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -96,7 +96,7 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-LATEST_LINK= perl5.8
+LATEST_LINK= perl
.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index f349ce63a9e9..61671171fd00 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -96,7 +96,7 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-LATEST_LINK= perl5.8
+LATEST_LINK= perl
.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
diff --git a/lang/perl5.6/Makefile b/lang/perl5.6/Makefile
index 041198d03854..92fd89f817b1 100644
--- a/lang/perl5.6/Makefile
+++ b/lang/perl5.6/Makefile
@@ -84,6 +84,8 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
.error You have `USE_PERL5' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
+NO_LATEST_LINK= yes
+
.if ${OSVERSION} < 500036
PKGMESSAGE= ${PKGDIR}/pkg-message-sysperl
.else
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index f349ce63a9e9..61671171fd00 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -96,7 +96,7 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-LATEST_LINK= perl5.8
+LATEST_LINK= perl
.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
diff --git a/lang/perl5/Makefile b/lang/perl5/Makefile
index 041198d03854..92fd89f817b1 100644
--- a/lang/perl5/Makefile
+++ b/lang/perl5/Makefile
@@ -84,6 +84,8 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
.error You have `USE_PERL5' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
+NO_LATEST_LINK= yes
+
.if ${OSVERSION} < 500036
PKGMESSAGE= ${PKGDIR}/pkg-message-sysperl
.else