aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2017-04-30 20:37:56 +0000
committerLarry Rosenman <ler@FreeBSD.org>2017-04-30 20:37:56 +0000
commitaacf24a5a90a3e770d05ec7fc45666138fdc6817 (patch)
tree01f5082433b649ef5a7c6e46d7aa01ec361cdb24 /lang
parenteb1d37a08ce49f34c424cb4ec226311db39c9b9e (diff)
downloadports-aacf24a5a90a3e770d05ec7fc45666138fdc6817.tar.gz
ports-aacf24a5a90a3e770d05ec7fc45666138fdc6817.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/picoc/Makefile13
-rw-r--r--lang/picoc/distinfo5
-rw-r--r--lang/picoc/files/patch-cstdlib__stdio.c14
-rw-r--r--lang/picoc/files/patch-cstdlib__unistd.c34
-rw-r--r--lang/picoc/pkg-descr9
5 files changed, 35 insertions, 40 deletions
diff --git a/lang/picoc/Makefile b/lang/picoc/Makefile
index 706838dc9c62..a435fc3a3994 100644
--- a/lang/picoc/Makefile
+++ b/lang/picoc/Makefile
@@ -3,22 +3,21 @@
PORTNAME= picoc
PORTVERSION= 2.1
CATEGORIES= lang devel
-MASTER_SITES= GOOGLE_CODE
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= portmaster@bsdforge.com
COMMENT= Very small C interpreter for scripting
LICENSE= BSD3CLAUSE
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
+USE_GITHUB= yes
+GH_ACCOUNT= zsaleeba
+GH_TAGNAME= 4555e84
-USES= gmake readline tar:bzip2
+USES= gmake readline
PLIST_FILES= bin/picoc
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${GH_TAGNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/picoc ${STAGEDIR}${PREFIX}/bin/picoc
diff --git a/lang/picoc/distinfo b/lang/picoc/distinfo
index 5426acc7dd43..bf53ef1690a1 100644
--- a/lang/picoc/distinfo
+++ b/lang/picoc/distinfo
@@ -1,2 +1,3 @@
-SHA256 (picoc-2.1.tar.bz2) = bfed355fab810b337ccfa9e3215679d0b9886c00d9cb5e691f7e7363fd388b7e
-SIZE (picoc-2.1.tar.bz2) = 69991
+TIMESTAMP = 1490214999
+SHA256 (zsaleeba-picoc-2.1-4555e84_GH0.tar.gz) = 4b830e5b532134016d1c17353c538a9ce38c51ef9a9c9a1832f4372e821e962d
+SIZE (zsaleeba-picoc-2.1-4555e84_GH0.tar.gz) = 615846
diff --git a/lang/picoc/files/patch-cstdlib__stdio.c b/lang/picoc/files/patch-cstdlib__stdio.c
index 69197e88ccf3..f11d1278e976 100644
--- a/lang/picoc/files/patch-cstdlib__stdio.c
+++ b/lang/picoc/files/patch-cstdlib__stdio.c
@@ -1,11 +1,11 @@
---- ./cstdlib/stdio.c.orig 2011-02-21 06:22:13.000000000 +0100
-+++ ./cstdlib/stdio.c 2011-03-11 08:08:19.710970864 +0100
-@@ -414,7 +414,7 @@
-
+--- cstdlib/stdio.c.orig 2017-03-22 14:37:13.263703000 -0700
++++ cstdlib/stdio.c 2017-03-22 14:41:07.228360000 -0700
+@@ -428,7 +428,7 @@
void StdioFileno(struct ParseState *Parser, struct Value *ReturnValue, struct Value **Param, int NumArgs)
{
+ #ifndef WIN32
- ReturnValue->Val->Integer = fileno(Param[0]->Val->Pointer);
+ ReturnValue->Val->Integer = fileno((FILE *)Param[0]->Val->Pointer);
- }
-
- void StdioFflush(struct ParseState *Parser, struct Value *ReturnValue, struct Value **Param, int NumArgs)
+ #else
+ ReturnValue->Val->Integer = _fileno(Param[0]->Val->Pointer);
+ #endif
diff --git a/lang/picoc/files/patch-cstdlib__unistd.c b/lang/picoc/files/patch-cstdlib__unistd.c
index 0813c1cb36b5..72bbbf765236 100644
--- a/lang/picoc/files/patch-cstdlib__unistd.c
+++ b/lang/picoc/files/patch-cstdlib__unistd.c
@@ -1,19 +1,23 @@
---- ./cstdlib/unistd.c.orig 2011-02-21 06:22:13.000000000 +0100
-+++ ./cstdlib/unistd.c 2011-03-11 08:09:48.884688383 +0100
-@@ -80,10 +80,10 @@
+--- cstdlib/unistd.c.orig 2017-03-22 14:01:43.750834000 -0700
++++ cstdlib/unistd.c 2017-03-22 14:08:17.778456000 -0700
+@@ -81,16 +81,6 @@
ReturnValue->Val->Integer = fchdir(Param[0]->Val->Integer);
}
-void UnistdFdatasync(struct ParseState *Parser, struct Value *ReturnValue, struct Value **Param, int NumArgs)
-+/*void UnistdFdatasync(struct ParseState *Parser, struct Value *ReturnValue, struct Value **Param, int NumArgs)
- {
- ReturnValue->Val->Integer = fdatasync(Param[0]->Val->Integer);
+-{
+-#ifndef F_FULLSYNC
+- ReturnValue->Val->Integer = fdatasync(Param[0]->Val->Integer);
+-#else
+- /* Mac OS X equivalent */
+- ReturnValue->Val->Integer = fcntl(Param[0]->Val->Integer, F_FULLFSYNC);
+-#endif
-}
-+}*/
-
+-
void UnistdFork(struct ParseState *Parser, struct Value *ReturnValue, struct Value **Param, int NumArgs)
{
-@@ -278,7 +278,7 @@
+ ReturnValue->Val->Integer = fork();
+@@ -284,7 +274,7 @@
void UnistdSetpgrp(struct ParseState *Parser, struct Value *ReturnValue, struct Value **Param, int NumArgs)
{
@@ -22,21 +26,11 @@
}
void UnistdSetregid(struct ParseState *Parser, struct Value *ReturnValue, struct Value **Param, int NumArgs)
-@@ -416,7 +416,7 @@
+@@ -422,7 +412,6 @@
{ Unistd_Exit, "void _exit(int);" },
{ UnistdFchown, "int fchown(int, uid_t, gid_t);" },
{ UnistdFchdir, "int fchdir(int);" },
- { UnistdFdatasync, "int fdatasync(int);" },
-+/* { UnistdFdatasync, "int fdatasync(int);" },*/
{ UnistdFork, "pid_t fork(void);" },
{ UnistdFpathconf, "long fpathconf(int, int);" },
{ UnistdFsync, "int fsync(int);" },
-@@ -458,7 +458,7 @@
- { UnistdSbrk, "void *sbrk(intptr_t);" },
- { UnistdSetgid, "int setgid(gid_t);" },
- { UnistdSetpgid, "int setpgid(pid_t, pid_t);" },
-- { UnistdSetpgrp, "pid_t setpgrp(void);" },
-+ { UnistdSetpgrp, "pid_t setpgrp(pid_t, pid_t);" },
- { UnistdSetregid, "int setregid(gid_t, gid_t);" },
- { UnistdSetreuid, "int setreuid(uid_t, uid_t);" },
- { UnistdSetsid, "pid_t setsid(void);" },
diff --git a/lang/picoc/pkg-descr b/lang/picoc/pkg-descr
index a795fd187cfa..ba304d531703 100644
--- a/lang/picoc/pkg-descr
+++ b/lang/picoc/pkg-descr
@@ -1,5 +1,6 @@
-PicoC is a very small C interpreter for scripting. It was originally written for
-scripting a UAV's on-board flight system and it's also very suitable for other
-robotic, embedded and non-embedded applications too.
+PicoC is a very small C interpreter for scripting. It was
+originally written for scripting a UAV's on-board flight
+system and it's also very suitable for other robotic,
+embedded and non-embedded applications too.
-WWW: http://code.google.com/p/picoc/
+WWW: https://github.com/zsaleeba/picoc