aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2014-11-22 20:40:08 +0000
committerChris Rees <crees@FreeBSD.org>2014-11-22 20:40:08 +0000
commit4cb60faedd280bf4b0b07bd947bd9087e09d4357 (patch)
tree68afea909ff5f83c22ece4ec8e2ae5959483778d /lang
parent5b6c7671efda9fa65107199c83addafb2a6f9dca (diff)
downloadports-4cb60faedd280bf4b0b07bd947bd9087e09d4357.tar.gz
ports-4cb60faedd280bf4b0b07bd947bd9087e09d4357.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/harbour/Makefile2
-rw-r--r--lang/mit-scheme/Makefile2
-rw-r--r--lang/newlisp-devel/Makefile2
-rw-r--r--lang/newlisp/Makefile2
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php53/Makefile.ext4
-rw-r--r--lang/php55/Makefile.ext4
-rw-r--r--lang/php56/Makefile.ext4
-rw-r--r--lang/pike78/Makefile2
-rw-r--r--lang/urweb/Makefile3
10 files changed, 15 insertions, 14 deletions
diff --git a/lang/harbour/Makefile b/lang/harbour/Makefile
index f10d687bcf12..60794c840ee4 100644
--- a/lang/harbour/Makefile
+++ b/lang/harbour/Makefile
@@ -119,7 +119,7 @@ MAKE_ENV+= HB_WITH_MYSQL=no
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
+USES+= pgsql
MAKE_ENV+= HB_WITH_PGSQL=nolocal
.else
MAKE_ENV+= HB_WITH_PGSQL=no
diff --git a/lang/mit-scheme/Makefile b/lang/mit-scheme/Makefile
index 3ed12a286744..1a3c13bfa886 100644
--- a/lang/mit-scheme/Makefile
+++ b/lang/mit-scheme/Makefile
@@ -70,7 +70,7 @@ CONFIGURE_ARGS+=--without-openssl
.if ${PORT_OPTIONS:MPGSQL}
PLIST_SUB+= POSTGRESQL=""
CONFIGURE_ARGS+=--with-libpq=${LOCALBASE}
-USE_PGSQL= yes
+USES+= pgsql
.else
PLIST_SUB+= POSTGRESQL="@comment "
CONFIGURE_ARGS+=--without-libpq
diff --git a/lang/newlisp-devel/Makefile b/lang/newlisp-devel/Makefile
index 1c5ef9f54040..037dbb40b382 100644
--- a/lang/newlisp-devel/Makefile
+++ b/lang/newlisp-devel/Makefile
@@ -71,7 +71,7 @@ PLIST_SUB+= MYSQL="@comment "
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
+USES+= pgsql
MODULES+= postgres
PLIST_SUB+= PGSQL=""
.else
diff --git a/lang/newlisp/Makefile b/lang/newlisp/Makefile
index d89141022be5..b3e38d25d96a 100644
--- a/lang/newlisp/Makefile
+++ b/lang/newlisp/Makefile
@@ -69,7 +69,7 @@ PLIST_SUB+= MYSQL="@comment "
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
+USES+= pgsql
MODULES+= postgres
PLIST_SUB+= PGSQL=""
.else
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index dd15b6851644..558f964035b3 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -265,7 +265,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_pgsql"
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--with-pdo-pgsql=${LOCALBASE}
@@ -282,7 +282,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pgsql"
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 721fa72e9817..c16ef0c53abe 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -255,7 +255,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_pgsql"
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--with-pdo-pgsql=${LOCALBASE}
@@ -272,7 +272,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pgsql"
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index c330c85aae91..4ab7342617d2 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -269,7 +269,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_pgsql"
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--with-pdo-pgsql=${LOCALBASE}
@@ -286,7 +286,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pgsql"
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index d293fa272e8b..bf4a20532ca6 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -269,7 +269,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_pgsql"
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--with-pdo-pgsql=${LOCALBASE}
@@ -286,7 +286,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pgsql"
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
diff --git a/lang/pike78/Makefile b/lang/pike78/Makefile
index 46cd8f4046b5..0ed7797e69f6 100644
--- a/lang/pike78/Makefile
+++ b/lang/pike78/Makefile
@@ -32,7 +32,7 @@ FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
FREETYPE_CONFIGURE_WITH=freetype
MYSQL_USE= mysql=yes
MYSQL_CONFIGURE_WITH= mysql
-PGSQL_USE= pgsql=yes
+PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
CFLAGS+= -ffast-math -fomit-frame-pointer
diff --git a/lang/urweb/Makefile b/lang/urweb/Makefile
index b3952d38e008..212942129d2c 100644
--- a/lang/urweb/Makefile
+++ b/lang/urweb/Makefile
@@ -42,7 +42,8 @@ CONFIGURE_ARGS+= with_emacs=no
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= server
+USES+= pgsql
+WANT_PGSQL= server
.else
CONFIGURE_ENV+= PGHEADER="no"
.endif