aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-02-05 08:46:44 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-02-05 08:46:44 +0000
commit632c877ba7a7dbf5457335936beefc40986d6467 (patch)
tree64c1f32af3e0aa9a1dc986314478300a0b162d68 /lang
parent7f59a530b0192e8c3fc707491be37ecac392a48d (diff)
downloadports-632c877ba7a7dbf5457335936beefc40986d6467.tar.gz
ports-632c877ba7a7dbf5457335936beefc40986d6467.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/seed7/Makefile10
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/files/patch-prg_chk_all.sd792
3 files changed, 8 insertions, 98 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 92f0c78bd04f..9c0e5bc973df 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20130120
+DISTVERSION= 05_20130203
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -15,6 +15,7 @@ LICENSE= LGPL21
USE_GMAKE= yes
USE_XORG= x11
+MAN1= s7.1 s7c.1
ONLY_FOR_ARCHS= i386 amd64 sparc64
@@ -74,10 +75,11 @@ do-install:
${INSTALL} -d ${EXAMPLESDIR}
cd ${WRKSRC}/../prg && ${COPYTREE_SHARE} '*.dna *.sd7 *.dat *.s7i' ${EXAMPLESDIR}
.endif
+# insall man pages
+ ${INSTALL_DATA} ${WRKSRC}/../doc/s7.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/../doc/s7c.1 ${MANPREFIX}/man/man1
regression-test: build
- @echo ""
- @echo "Testing the ${PORTNAME} installation"
- @(cd ${WRKSRC}/../prg && ${WRKSRC}/../bin/s7 -l ${WRKSRC}/../lib chk_all build)
+ cd ${WRKSRC} && ${GMAKE} test
.include <bsd.port.post.mk>
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 6190ad20b14d..02f3dc7d2980 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20130120.tgz) = ddf142b0f79e0ff2cd6d25472bf39f2389bf42f01686d2e6d25c9f6f267c8142
-SIZE (seed7_05_20130120.tgz) = 1821907
+SHA256 (seed7_05_20130203.tgz) = 7b0fb2fce99dd2b9de0cde1c02a722a45e159a2edc390eba8dd072c4f772a8f0
+SIZE (seed7_05_20130203.tgz) = 1829321
diff --git a/lang/seed7/files/patch-prg_chk_all.sd7 b/lang/seed7/files/patch-prg_chk_all.sd7
deleted file mode 100644
index 1686e441a676..000000000000
--- a/lang/seed7/files/patch-prg_chk_all.sd7
+++ /dev/null
@@ -1,92 +0,0 @@
---- ../prg/chk_all.sd7.orig 2013-01-21 17:05:47.000000000 +0100
-+++ ../prg/chk_all.sd7 2013-01-21 17:04:54.000000000 +0100
-@@ -30,6 +30,11 @@
- const string: OBJECT_FILE_EXTENSION is configValue("OBJECT_FILE_EXTENSION");
- const string: EXECUTABLE_FILE_EXTENSION is configValue("EXECUTABLE_FILE_EXTENSION");
-
-+var string: interpretProgram is "./s7 -q ";
-+var string: interpretCompiler is "./s7 s7c ";
-+var string: executeCompiler is "./s7c ";
-+var string: s7compiler is "./s7c" & EXECUTABLE_FILE_EXTENSION;
-+
- const string: chkint_output is "\n\
- \Integer literals with exponent work correct.\n\
- \Based integer literals work correct.\n\
-@@ -234,7 +239,7 @@
- begin
- write(progName);
- flush(OUT);
-- interpretedOutput := cmdOutput("./s7 -q " & progName);
-+ interpretedOutput := cmdOutput(interpretProgram & progName);
- if interpretedOutput <> referenceOutput then
- writeln;
- writeln(" *** The interpreted " <& progName <& " does not work okay:");
-@@ -244,7 +249,7 @@
- if fileType(progName & EXECUTABLE_FILE_EXTENSION) <> FILE_ABSENT then
- removeFile(progName & EXECUTABLE_FILE_EXTENSION);
- end if;
-- compilerOutput := cmdOutput("./s7 s7c " & progName);
-+ compilerOutput := cmdOutput(interpretCompiler & progName);
- if fileType(progName & EXECUTABLE_FILE_EXTENSION) = FILE_REGULAR then
- compiledOutput := cmdOutput("./" & progName);
- if compiledOutput <> referenceOutput then
-@@ -284,7 +289,7 @@
- end if;
- okay := FALSE;
- end if;
-- if fileType("s7c" & EXECUTABLE_FILE_EXTENSION) = FILE_REGULAR then
-+ if fileType(s7compiler) = FILE_REGULAR then
- if fileType("tmp_" & progName & ".c") = FILE_REGULAR then
- if fileType("tmp1_" & progName & ".c") = FILE_REGULAR then
- removeFile("tmp1_" & progName & ".c");
-@@ -294,7 +299,7 @@
- if fileType(progName & EXECUTABLE_FILE_EXTENSION) <> FILE_ABSENT then
- removeFile(progName & EXECUTABLE_FILE_EXTENSION);
- end if;
-- compilerOutput := cmdOutput("./s7c " & progName);
-+ compilerOutput := cmdOutput(executeCompiler & progName);
- if fileType(progName & EXECUTABLE_FILE_EXTENSION) = FILE_REGULAR then
- if fileType("tmp1_" & progName & ".c") = FILE_REGULAR then
- if not equalFiles("tmp_" & progName & ".c", "tmp1_" & progName & ".c") then
-@@ -327,17 +332,31 @@
-
- const proc: main is func
- begin
-- if fileType("s7c" & EXECUTABLE_FILE_EXTENSION) = FILE_REGULAR then
-- removeFile("s7c" & EXECUTABLE_FILE_EXTENSION);
-- end if;
-- write("compiling the compiler");
-- flush(OUT);
-- ignore(cmdOutput("./s7 s7c s7c"));
-- if not fileType("s7c" & EXECUTABLE_FILE_EXTENSION) = FILE_REGULAR then
-- writeln;
-- writeln(" *** Failed to compile the compiler");
-+ if length(argv(PROGRAM)) = 1 and argv(PROGRAM)[1] = "build" then
-+ interpretProgram := "../bin/s7 -l ../lib -q ";
-+ interpretCompiler := "../bin/s7 -l ../lib s7c -l ../lib -b ../bin ";
-+ executeCompiler := "../bin/s7c -l ../lib -b ../bin ";
-+ s7compiler := "../bin/s7c" & EXECUTABLE_FILE_EXTENSION;
-+ write("checking for presence of " <& s7compiler);
-+ if not fileType(s7compiler) = FILE_REGULAR then
-+ writeln;
-+ writeln(" *** No Seed7 compiler executable found");
-+ else
-+ writeln(" - okay");
-+ end if;
- else
-- writeln(" - okay");
-+ if fileType(s7compiler) = FILE_REGULAR then
-+ removeFile(s7compiler);
-+ end if;
-+ write("compiling the compiler");
-+ flush(OUT);
-+ ignore(cmdOutput(interpretCompiler & "s7c"));
-+ if not fileType(s7compiler) = FILE_REGULAR then
-+ writeln;
-+ writeln(" *** Failed to compile the compiler");
-+ else
-+ writeln(" - okay");
-+ end if;
- end if;
- check("chkint", chkint_output);
- check("chkflt", chkflt_output);