aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-12-03 13:19:31 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-12-03 13:19:31 +0000
commita762ff98aebe5614b872c43a1b253feff19d9093 (patch)
treeaf24ddc15ae973e063253f37e4690809ab44c562 /lang
parent3c8a130f53956696f38bef4e38eb04a79e934504 (diff)
downloadports-a762ff98aebe5614b872c43a1b253feff19d9093.tar.gz
ports-a762ff98aebe5614b872c43a1b253feff19d9093.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile3
-rw-r--r--lang/php5/Makefile3
-rw-r--r--lang/php53/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 1e28534c5ad8..bfb40cfe900b 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -163,7 +163,8 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
- @${REINPLACE_CMD} "s|<crypt.h>|<unistd.h>|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} "s|<crypt.h>|<unistd.h>|g;s|HAVE_CRYPT_H|HAVE_UNISTD_H|g" \
+ ${WRKSRC}/configure
.if ${PHP_SAPI} == "full"
pre-configure:
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index c53f32b7a13b..2ebec85f8072 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -168,7 +168,8 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
- @${REINPLACE_CMD} "s|<crypt.h>|<unistd.h>|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} "s|<crypt.h>|<unistd.h>|g;s|HAVE_CRYPT_H|HAVE_UNISTD_H|g" \
+ ${WRKSRC}/configure
.if ${PHP_SAPI} == "full"
pre-configure:
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index c53f32b7a13b..2ebec85f8072 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -168,7 +168,8 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
- @${REINPLACE_CMD} "s|<crypt.h>|<unistd.h>|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} "s|<crypt.h>|<unistd.h>|g;s|HAVE_CRYPT_H|HAVE_UNISTD_H|g" \
+ ${WRKSRC}/configure
.if ${PHP_SAPI} == "full"
pre-configure: