aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-12-08 08:59:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-12-08 08:59:28 +0000
commit680174eb06d972473daf929f9db647c92c999039 (patch)
treedb86d2f0388c19612850dc15842cb25dcb12db3b /lang
parent2395e2f49c8480cc991c6e6d6f6315c291be51ef (diff)
downloadports-680174eb06d972473daf929f9db647c92c999039.tar.gz
ports-680174eb06d972473daf929f9db647c92c999039.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile.ext11
-rw-r--r--lang/php5/Makefile.ext15
-rw-r--r--lang/php53/Makefile.ext15
3 files changed, 7 insertions, 34 deletions
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index 02c1a6ded751..623534cc38e0 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -293,10 +293,9 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
+LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
-
-OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
.endif
.if ${PHP_MODNAME} == "sockets"
@@ -466,14 +465,6 @@ post-patch:
@${REINPLACE_CMD} "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/pfpro.c
.endif
-.if ${PHP_MODNAME} == "snmp"
-. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-. else
-LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-. endif
-.endif
-
.if ${PHP_MODNAME} == "zlib"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 05dbbe16da11..caab1b6c1e03 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -378,10 +378,9 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
-USE_OPENSSL= yes
-
-OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
+LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
+USE_OPENSSL= yes
.endif
.if ${PHP_MODNAME} == "soap"
@@ -601,14 +600,6 @@ LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
.endif
.endif
-.if ${PHP_MODNAME} == "snmp"
-. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-. else
-LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-. endif
-.endif
-
.if ${PHP_MODNAME} == "sqlite"
. if defined(WITH_UTF8)
CONFIGURE_ARGS+=--enable-sqlite-utf8
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 05dbbe16da11..caab1b6c1e03 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -378,10 +378,9 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
-USE_OPENSSL= yes
-
-OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
+LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
+USE_OPENSSL= yes
.endif
.if ${PHP_MODNAME} == "soap"
@@ -601,14 +600,6 @@ LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
.endif
.endif
-.if ${PHP_MODNAME} == "snmp"
-. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
-LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
-. else
-LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-. endif
-.endif
-
.if ${PHP_MODNAME} == "sqlite"
. if defined(WITH_UTF8)
CONFIGURE_ARGS+=--enable-sqlite-utf8