aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-18 17:49:31 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-18 17:49:31 +0000
commitfe54d2a7c76c819f48572aaac53161c6073e4bc2 (patch)
treecd3a2332516a8e0f6a9b518a6f6eb3a97af4baa7 /lang
parentb64acc87813cd14f5610cecd37bb98e52497b3fa (diff)
downloadports-fe54d2a7c76c819f48572aaac53161c6073e4bc2.tar.gz
ports-fe54d2a7c76c819f48572aaac53161c6073e4bc2.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile4
-rw-r--r--lang/erlang14/Makefile4
-rw-r--r--lang/ghc/Makefile4
-rw-r--r--lang/ghc5/Makefile4
-rw-r--r--lang/gprolog/Makefile8
5 files changed, 23 insertions, 1 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index d1247bfbab36..b0e4adbf1787 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -46,6 +46,10 @@ CONFIGURE_ARGS+= --enable-threads --enable-hipe
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if !exists(${JAVABINDIR}/java)
WITHOUT_JAVA= yes
.endif
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index d1247bfbab36..b0e4adbf1787 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -46,6 +46,10 @@ CONFIGURE_ARGS+= --enable-threads --enable-hipe
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if !exists(${JAVABINDIR}/java)
WITHOUT_JAVA= yes
.endif
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 462cd1859d27..bf3154cb2ba5 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -19,6 +19,10 @@ BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
USE_BZIP2= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
DISTFILES= ${SRC_DIST}
.if ${OSVERSION} < 500000
diff --git a/lang/ghc5/Makefile b/lang/ghc5/Makefile
index b8352f7ed5f1..4dfccaa8b908 100644
--- a/lang/ghc5/Makefile
+++ b/lang/ghc5/Makefile
@@ -20,6 +20,10 @@ BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
USE_BZIP2= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
DISTFILES= ${SRC_DIST}
.if ${OSVERSION} < 500000
diff --git a/lang/gprolog/Makefile b/lang/gprolog/Makefile
index d981bafe994b..d7220ff58945 100644
--- a/lang/gprolog/Makefile
+++ b/lang/gprolog/Makefile
@@ -27,8 +27,14 @@ CONFIGURE_ARGS= --with-c-flags="${CFLAGS}"
PLIST_SUB+= GPROLOG_VER=${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|<malloc\.h>|<stdlib.h>|g' ${WRKSRC}/EnginePl/machine.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>