aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-05 13:18:26 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-05 13:18:26 +0000
commit03ff71952dd0d66dd6073e4f803cbc25fc6230eb (patch)
tree02717a43beaa3c8b8ee1a4998a8c040dfac61fa2 /lang
parent26ff21a4257f3bdddd387d2971015b21156594e5 (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python24/Makefile5
-rw-r--r--lang/python25/Makefile6
-rw-r--r--lang/python26/Makefile6
-rw-r--r--lang/python27/Makefile6
-rw-r--r--lang/python31/Makefile6
-rw-r--r--lang/python32/Makefile6
6 files changed, 11 insertions, 24 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 7a22c2436dd0..05e293015dba 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python24
PORTVERSION= 2.4.5
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -57,9 +57,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-# workaround for a bug in base curses.h.
-CFLAGS+= -D__wchar_t=wchar_t
-
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 4ce5fea4cf00..6cf4d9f83670 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -3,10 +3,11 @@
# Whom: Hye-Shik Chang <perky@FreeBSD.org>
#
# $FreeBSD$
+#
PORTNAME= python25
PORTVERSION= 2.5.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -63,9 +64,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-# workaround for a bug in base curses.h.
-CFLAGS+= -D__wchar_t=wchar_t
-
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 915a94478d75..ae8aee22b92e 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -3,10 +3,11 @@
# Whom: Hye-Shik Chang <perky@FreeBSD.org>
#
# $FreeBSD$
+#
PORTNAME= python26
PORTVERSION= 2.6.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -80,9 +81,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-# workaround for a bug in base curses.h.
-CFLAGS+= -D__wchar_t=wchar_t
-
.if !defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS=""
.if defined(WITH_PTH)
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index fc0bc78e91ee..28ba9bd0c3a4 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -3,10 +3,11 @@
# Whom: Hye-Shik Chang <perky@FreeBSD.org>
#
# $FreeBSD$
+#
PORTNAME= python27
PORTVERSION= 2.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -80,9 +81,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-# workaround for a bug in base curses.h.
-CFLAGS+= -D__wchar_t=wchar_t
-
.if !defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS=""
.if defined(WITH_PTH)
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index ccd3a9aa10fb..2ebcea9b19c4 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -3,10 +3,11 @@
# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
#
# $FreeBSD$
+#
PORTNAME= python31
PORTVERSION= 3.1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -65,9 +66,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-# workaround for a bug in base curses.h.
-CFLAGS+= -D__wchar_t=wchar_t
-
.if !defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index a845d3a6861c..f7650d9e1f1a 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -3,10 +3,11 @@
# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
#
# $FreeBSD$
+#
PORTNAME= python32
PORTVERSION= 3.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -66,9 +67,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-# workaround for a bug in base curses.h.
-CFLAGS+= -D__wchar_t=wchar_t
-
.if !defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads