aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
commit34fa6c853efa04ca648d3d4187d4aec40a00fc0d (patch)
tree3445b3e9b6e7650fd127ec078394a0d7a8e79076 /lang
parentae2c26ad44dba87dd1377d70dfb1906132114c7b (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gambas/Makefile4
-rw-r--r--lang/php4/Makefile.ext3
-rw-r--r--lang/php5/Makefile.ext3
-rw-r--r--lang/php53/Makefile.ext3
-rw-r--r--lang/pike72/Makefile4
-rw-r--r--lang/pike76/Makefile2
6 files changed, 8 insertions, 11 deletions
diff --git a/lang/gambas/Makefile b/lang/gambas/Makefile
index ac7bd8cbe527..6a9858ab4e70 100644
--- a/lang/gambas/Makefile
+++ b/lang/gambas/Makefile
@@ -69,11 +69,11 @@ NEW${lib:U}!= ${LDCONFIG} -r | ${GREP} ${lib} | ${GREP} -v 'compat/pkg' \
| ${AWK} -F 'lib\/' '{print $$2}'
.endfor
-.if exists(${LOCALBASE}/include/postgresql/server/postgres.h)
+.if exists(${LOCALBASE}/bin/pg_config)
WITH_PGSQL= yes
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgresql-includes=${LOCALBASE}/include/postgresql/server \
--with-postgresql-libraries=${LOCALBASE}/lib
PLIST_SUB+= PGSQL=""
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index 6de92282d459..499105d57d48 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -256,8 +256,7 @@ PHP_HEADER_DIRS=pcrelib
.endif
.if ${PHP_MODNAME} == "pgsql"
-POSTGRESQL_PORT?= databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= YES
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 27b1ee61528a..20e4241ddf2d 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -248,8 +248,7 @@ PHP_HEADER_DIRS=pcrelib
.endif
.if ${PHP_MODNAME} == "pgsql"
-POSTGRESQL_PORT?= databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= YES
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 27b1ee61528a..20e4241ddf2d 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -248,8 +248,7 @@ PHP_HEADER_DIRS=pcrelib
.endif
.if ${PHP_MODNAME} == "pgsql"
-POSTGRESQL_PORT?= databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= YES
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index 0e101f698b01..459efc7f967d 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -75,7 +75,7 @@ WITH_FREETYPE= yes
WITH_MYSQL= yes
.endif
-.if exists(${LOCALBASE}/lib/libpq.so.2)
+.if exists(${LOCALBASE}/lib/libpq.so)
WITH_POSTGRES= yes
.endif
@@ -130,7 +130,7 @@ CONFIGURE_ARGS+= --without-mysql
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql=${PREFIX}
.else
CONFIGURE_ARGS+= --without-pgsql
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
index 417c2701f613..63da13e0015b 100644
--- a/lang/pike76/Makefile
+++ b/lang/pike76/Makefile
@@ -154,7 +154,7 @@ CONFIGURE_ARGS+= --without-mysql
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql=${PREFIX}
.else
CONFIGURE_ARGS+= --without-pgsql