aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-09-11 14:57:58 +0000
committerRene Ladan <rene@FreeBSD.org>2021-09-30 21:23:30 +0000
commit620968a43a5f9bb3fa98ab20f257a4c0d864caa7 (patch)
tree09bef799707f4b6e715b912429bd3b73c1addf4c /lang
parentb9a93c0bf4778b9ec327c1be6f819eb1ff90ec19 (diff)
downloadports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.tar.gz
ports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.zip
cleanup: drop support for EOL FreeBSD 11.X
Search criteria used: - 11.4 - OSREL* - OSVER* - *_FreeBSD_11 Input from: - adridg: devel/qca-legacy - jbeich: _WITH_DPRINTF, _WITH_GETLINE, GNU bfd workarounds - sunpoet: security/p5-*OpenSSL* Reviewed by: doceng, kde, multimedia, perl, python, ruby, rust Differential Revision: https://reviews.freebsd.org/D32008 Test Plan: make index
Diffstat (limited to 'lang')
-rw-r--r--lang/ccl/Makefile7
-rw-r--r--lang/clover/Makefile1
-rw-r--r--lang/crystal/Makefile1
-rw-r--r--lang/gcc6-aux/Makefile12
-rw-r--r--lang/ghc/Makefile8
-rw-r--r--lang/gnustep-base/Makefile1
-rw-r--r--lang/go/Makefile8
-rw-r--r--lang/hermes/Makefile6
-rw-r--r--lang/ldc/Makefile2
-rw-r--r--lang/luajit-openresty/Makefile8
-rw-r--r--lang/perl5-devel/Makefile7
-rw-r--r--lang/perl5.30/Makefile7
-rw-r--r--lang/perl5.32/Makefile7
-rw-r--r--lang/perl5.34/Makefile7
-rw-r--r--lang/python310/Makefile4
-rw-r--r--lang/rust-bootstrap/Makefile2
-rw-r--r--lang/rust/Makefile13
-rw-r--r--lang/zig-devel/Makefile1
-rw-r--r--lang/zig/Makefile1
19 files changed, 17 insertions, 86 deletions
diff --git a/lang/ccl/Makefile b/lang/ccl/Makefile
index f801f2635594..62438d38f95d 100644
--- a/lang/ccl/Makefile
+++ b/lang/ccl/Makefile
@@ -26,11 +26,6 @@ USE_ASDF= yes
.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1200000
-IGNORE= does not build on FreeBSD < 12.0
-.endif
BUILD_DEPENDS+= as:devel/binutils
LISP_ARCH= x8664
@@ -64,4 +59,4 @@ do-install:
done
${INSTALL_SCRIPT} ${WRKDIR}/ccl.sh ${STAGEDIR}${PREFIX}/bin/ccl
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index c56294ee5f15..148a8904350f 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -13,7 +13,6 @@ RUN_DEPENDS= libclc>=0.3.0:devel/libclc \
ONLY_FOR_ARCHS= i386 amd64 powerpc64le powerpc64
ONLY_FOR_ARCHS_REASON= Clover needs a GPU supported by the Radeon KMS driver
-BROKEN_FreeBSD_11= undefined reference to `vl_video_buffer_plane_order'
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
diff --git a/lang/crystal/Makefile b/lang/crystal/Makefile
index e82ef1821380..47c32dbee0e2 100644
--- a/lang/crystal/Makefile
+++ b/lang/crystal/Makefile
@@ -11,7 +11,6 @@ COMMENT= Language with Ruby-like syntax and static type checking
LICENSE= APACHE20
-IGNORE_FreeBSD_11= prebuilt bootstrap only built for FreeBSD >=12 (ino64)
ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= requires prebuilt bootstrap compiler
diff --git a/lang/gcc6-aux/Makefile b/lang/gcc6-aux/Makefile
index 074401270aa6..f532a3d9de28 100644
--- a/lang/gcc6-aux/Makefile
+++ b/lang/gcc6-aux/Makefile
@@ -50,17 +50,7 @@ BOOTSTRAP_DESC= Create bootstrap compiler (overrides other options)
.if ${OPSYS} == FreeBSD
ONLY_FOR_ARCHS= aarch64 amd64 i386
MODERN_BINUTILS= yes
-. if ${ARCH} == aarch64 && ${OSVERSION} > 1200075 #ino64
-BOOTSTRAP_COMPILER= ada-bootstrap.aarch64.freebsd.120.tar.bz2
-. elif ${ARCH} == aarch64
-BOOTSTRAP_COMPILER= ada-bootstrap.aarch64.freebsd.111.tar.bz2
-. elif ${ARCH} == amd64 && ${OSVERSION} > 1200030 #ino64
-BOOTSTRAP_COMPILER= ada-bootstrap.${GARCH}.freebsd.120.tar.bz2
-. elif ${ARCH} == i386 && ${OSVERSION} > 1200030 #ino64
-BOOTSTRAP_COMPILER= ada-bootstrap.${GARCH}.freebsd.120.tar.bz2
-. else
-BOOTSTRAP_COMPILER= ada-bootstrap.${GARCH}.freebsd.100B.tar.bz2
-. endif
+BOOTSTRAP_COMPILER= ada-bootstrap.${ARCH}.freebsd.120.tar.bz2
.endif
.if ${OPSYS} == DragonFly
ONLY_FOR_ARCHS= x86_64
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 2b70b2cb8b55..37b610987ff7 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -132,10 +132,7 @@ _EXECUTABLES+= ${GHC_LIBDIR}/bin/ghc-iserv-dyn
.if empty(PORT_OPTIONS:MBOOT)
BOOTSTRAPS_SUFFIX?= ${BOOTSTRAPS_SUFFIX_${ARCH}}
BOOTSTRAPS_SUFFIX_powerpc64?= -${PPC_ABI:tl}
-. if ${OSVERSION} < 1200000 && (${ARCH} == amd64 || ${ARCH} == i386)
-ELEVEN_SUFX= 11
-. endif
-DISTFILES+= ghc-${BOOT_GHC_VERSION}-boot-${ARCH}-freebsd${BOOTSTRAPS_SUFFIX}${ELEVEN_SUFX}${EXTRACT_SUFX}:boot
+DISTFILES+= ghc-${BOOT_GHC_VERSION}-boot-${ARCH}-freebsd${BOOTSTRAPS_SUFFIX}${EXTRACT_SUFX}:boot
.endif # MBOOT
.if ${ARCH} == aarch64 || ${ARCH:Marmv*}
@@ -162,9 +159,6 @@ CONFIGURE_ENV_BOOTSTRAP=LLC=llc${BOOT_LLVM_VERSION} \
.endif
.if ${ARCH} == aarch64 || ${ARCH:Marmv*} || ${ARCH} == powerpc64
-. if ${OSVERSION} < 1202000
-IGNORE= lang/ghc requires at least FreeBSD 12.2-RELEASE
-. endif
. ifdef QEMU_EMULATING
IGNORE= qemu-user-static isn't able to build lang/ghc, but it builds fine on a real hardware
. endif
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index cce41c595c40..1984313a8ee6 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -12,7 +12,6 @@ COMMENT= GNUstep Foundation library
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
-BROKEN_FreeBSD_11_powerpc64= fails to link: ld.lld: error: /usr/src/lib/csu/common/crtend.c:55: relocation R_PPC64_ADDR16_DS out of range: -32776 is not in [-32768, 32767]
BROKEN_FreeBSD_12_powerpc64= fails to link: ld.lld: error: /usr/src/lib/csu/common/crtend.c:55: relocation R_PPC64_ADDR16_DS out of range: -32776 is not in [-32768, 32767]
LIB_DEPENDS+= libffi.so:devel/libffi
diff --git a/lang/go/Makefile b/lang/go/Makefile
index edc64432f732..4c9fe513d8e2 100644
--- a/lang/go/Makefile
+++ b/lang/go/Makefile
@@ -65,12 +65,6 @@ GOARCH_i386= 386
GOARM_armv6= 6
GOARM_armv7= 7
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == aarch64 && ${OSVERSION} < 1200000
-IGNORE= aarch64 support requires FreeBSD 12.0 or newer
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|^if ulimit -T|false \&\& &|' ${WRKSRC}/src/run.bash
@@ -126,4 +120,4 @@ makesum:
${RM} ${DISTINFO_FILE}.tmp
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/hermes/Makefile b/lang/hermes/Makefile
index 1fece6cc427e..abd108302abe 100644
--- a/lang/hermes/Makefile
+++ b/lang/hermes/Makefile
@@ -25,12 +25,6 @@ CMAKE_OFF= HERMES_ENABLE_TEST_SUITE
BINARY_ALIAS= python=${PYTHON_CMD} python3=${PYTHON_CMD}
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1201518
-BROKEN= needs pthread_getname_np from OSVERSION 1201518 or above
-.endif
-
do-test: # some tests are known to fail: https://github.com/facebook/hermes/issues/347
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DHERMES_ENABLE_TEST_SUITE:BOOL=ON ${CMAKE_SOURCE_PATH} && \
diff --git a/lang/ldc/Makefile b/lang/ldc/Makefile
index 93e3cfb246a7..6d3e714005f0 100644
--- a/lang/ldc/Makefile
+++ b/lang/ldc/Makefile
@@ -44,7 +44,7 @@ LDCVER= ${PORTVERSION}
CFLAGS+= -fPIC
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1200029
+.if ${OPSYS} == FreeBSD
EXTRA_PATCHES= ${PATCHDIR}/fbsd12-*
.endif
diff --git a/lang/luajit-openresty/Makefile b/lang/luajit-openresty/Makefile
index b4f2ee89b709..bfe12fecc865 100644
--- a/lang/luajit-openresty/Makefile
+++ b/lang/luajit-openresty/Makefile
@@ -39,15 +39,9 @@ PLIST_SUB+= VERSION=${LUAJIT_VERSION} SOVERSION=${LUAJIT_SOVERSION}
USE_GCC=yes
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000
-MAKE_ARGS+= XCFLAGS=-DLJ_TARGET_HAS_GETENTROPY=0
-.endif
-
post-install:
${LN} -sf ${PORTNAME}-${LUAJIT_VERSION} \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_MAN} ${WRKSRC}/etc/luajit.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/perl5-devel/Makefile b/lang/perl5-devel/Makefile
index 8bae24ef6134..9bda07c8dcf2 100644
--- a/lang/perl5-devel/Makefile
+++ b/lang/perl5-devel/Makefile
@@ -46,7 +46,8 @@ TEST_ENV= ${MAKE_ENV} \
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
-CONFIGURE_ARGS= -Darchlib=${PREFIX}/${_ARCH_LIB} \
+CONFIGURE_ARGS= -Accflags='-DUSE_THREAD_SAFE_LOCALE' \
+ -Darchlib=${PREFIX}/${_ARCH_LIB} \
-Dcc="${CC}" \
-Dcf_by=${MAINTAINER:C,@.*,,} \
-Dcf_email=${MAINTAINER} \
@@ -197,10 +198,6 @@ _PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
.include <bsd.port.options.mk>
.sinclude "${_PERL5_DEFAULT_FILE}"
-.if ${OSVERSION} >= 1200004
-CONFIGURE_ARGS+= -Accflags='-DUSE_THREAD_SAFE_LOCALE'
-.endif
-
# if this port is default due PERL5_DEFAULT
# change PKGNAME to reflect this
.if ${PERL_VER} == ${PERL5_DEFAULT} || ${PERL5_DEFAULT} == devel # XXX Remove devel case
diff --git a/lang/perl5.30/Makefile b/lang/perl5.30/Makefile
index 84e6486a774d..703a24240901 100644
--- a/lang/perl5.30/Makefile
+++ b/lang/perl5.30/Makefile
@@ -43,7 +43,8 @@ CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
-Ui_malloc -Ui_iconv -Uinstallusrbinperl -Dusenm=n \
-Dcc="${CC}" -Duseshrplib -Dinc_version_list=none \
-Dcf_by=${MAINTAINER:C,@.*,,} -Dcf_email=${MAINTAINER} \
- -Dcf_time="`${STAT} -t \"%a %b %d %T %Z %Y\" -f %Sm ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX}`"
+ -Dcf_time="`${STAT} -t \"%a %b %d %T %Z %Y\" -f %Sm ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX}`" \
+ -Accflags='-DUSE_THREAD_SAFE_LOCALE'
# Keep the following two in sync.
# lddlflags is used for all .so linking
# shrpldflags is used for libperl.so, so remove all the extra bits inherited from lddlflags.
@@ -166,10 +167,6 @@ _PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
.include <bsd.port.options.mk>
.sinclude "${_PERL5_DEFAULT_FILE}"
-.if ${OSVERSION} >= 1200004
-CONFIGURE_ARGS+= -Accflags='-DUSE_THREAD_SAFE_LOCALE'
-.endif
-
# if this port is default due PERL5_DEFAULT
# change PKGNAME to reflect this
.if ${PERL_VER} == ${PERL5_DEFAULT}
diff --git a/lang/perl5.32/Makefile b/lang/perl5.32/Makefile
index ffb0d239590c..7cf5fb55fa68 100644
--- a/lang/perl5.32/Makefile
+++ b/lang/perl5.32/Makefile
@@ -52,7 +52,8 @@ CONFIGURE_ARGS= -Darchlib=${PREFIX}/${_ARCH_LIB} \
-sde \
-Ui_iconv \
-Ui_malloc \
- -Uinstallusrbinperl
+ -Uinstallusrbinperl \
+ -Accflags='-DUSE_THREAD_SAFE_LOCALE'
# Keep the following two in sync.
# lddlflags is used for all .so linking
# shrpldflags is used for libperl.so, so remove all the extra bits inherited from lddlflags.
@@ -172,10 +173,6 @@ _PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
.include <bsd.port.options.mk>
.sinclude "${_PERL5_DEFAULT_FILE}"
-.if ${OSVERSION} >= 1200004
-CONFIGURE_ARGS+= -Accflags='-DUSE_THREAD_SAFE_LOCALE'
-.endif
-
# if this port is default due PERL5_DEFAULT
# change PKGNAME to reflect this
.if ${PERL_VER} == ${PERL5_DEFAULT}
diff --git a/lang/perl5.34/Makefile b/lang/perl5.34/Makefile
index ed38db918ce0..044eabcd635b 100644
--- a/lang/perl5.34/Makefile
+++ b/lang/perl5.34/Makefile
@@ -52,7 +52,8 @@ CONFIGURE_ARGS= -Darchlib=${PREFIX}/${_ARCH_LIB} \
-sde \
-Ui_iconv \
-Ui_malloc \
- -Uinstallusrbinperl
+ -Uinstallusrbinperl \
+ -Accflags='-DUSE_THREAD_SAFE_LOCALE'
# Keep the following two in sync.
# lddlflags is used for all .so linking
# shrpldflags is used for libperl.so, so remove all the extra bits inherited from lddlflags.
@@ -172,10 +173,6 @@ _PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
.include <bsd.port.options.mk>
.sinclude "${_PERL5_DEFAULT_FILE}"
-.if ${OSVERSION} >= 1200004
-CONFIGURE_ARGS+= -Accflags='-DUSE_THREAD_SAFE_LOCALE'
-.endif
-
# if this port is default due PERL5_DEFAULT
# change PKGNAME to reflect this
.if ${PERL_VER} == ${PERL5_DEFAULT}
diff --git a/lang/python310/Makefile b/lang/python310/Makefile
index 64aba656d340..508b194c02aa 100644
--- a/lang/python310/Makefile
+++ b/lang/python310/Makefile
@@ -112,8 +112,8 @@ PLIST_SUB+= NO_NIS=""
.endif
# Python 3.10 requires OpenSSL >= 1.1.1 (PEP 644), so with
-# older OpenSSL or libressl, some modules are not built
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000 && !${SSL_DEFAULT:Mopenssl*} || ${SSL_DEFAULT:Mlibressl*}
+# libressl, some modules are not built
+.if ${SSL_DEFAULT:Mlibressl*}
PLIST_SUB+= SUPPORTED_OPENSSL="@comment "
.else
PLIST_SUB+= SUPPORTED_OPENSSL=""
diff --git a/lang/rust-bootstrap/Makefile b/lang/rust-bootstrap/Makefile
index 6a8d9d1ed894..a014052ec0c3 100644
--- a/lang/rust-bootstrap/Makefile
+++ b/lang/rust-bootstrap/Makefile
@@ -67,8 +67,6 @@ _RUST_LLVM_TARGET_powerpc= PowerPC
.if ${OPSYS} != FreeBSD
IGNORE= is only for FreeBSD
-.elif ${OSVERSION} < 1200502
-IGNORE= will not build on 12.0 due to old toolchain; 11.x untested
.endif
.if ${FLAVOR} == powerpc64le && ${OSVERSION} < 1300116
IGNORE= will not build on 12.x due to old system
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index c6815b26b515..0db40e6a5e3f 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -24,8 +24,6 @@ LICENSE_COMB= dual
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE-APACHE
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
-IGNORE_FreeBSD_11_powerpc64= is missing a bootstrap for FreeBSD 11.x powerpc64
-IGNORE_FreeBSD_11_powerpc= is missing a bootstrap for FreeBSD 11.x powerpc
IGNORE_FreeBSD_12_powerpc= is missing a bootstrap for FreeBSD 12.x powerpc
ONLY_FOR_ARCHS?= aarch64 amd64 armv6 armv7 i386 powerpc64 powerpc64le \
powerpc
@@ -111,11 +109,6 @@ USE_GCC= yes
STRIP_CMD= ${LOCALBASE}/bin/strip # unsupported e_type with base strip
.endif
-# remove when 11.4 is EOL
-.if ${ARCH} == aarch64 && ${OSVERSION} < 1202000
-IGNORE= fails to run due to a bug in rtld, update to 12.2-RELEASE or newer
-.endif
-
.ifdef QEMU_EMULATING
IGNORE= fails to build with qemu-user-static
.endif
@@ -187,11 +180,7 @@ do-configure:
@${ECHO_CMD} 'ccache=false' >> ${WRKSRC}/config.toml
.endif
@${ECHO_CMD} 'ninja=true' >> ${WRKSRC}/config.toml
-.if ${ARCH} == armv6
-# fails to link with base ld.bfd: rustc_codegen_llvm.e2557spx-cgu.11:(.text._ZN89_$LT$rustc_target..abi..call..CastTarget$u20$as$u20$rustc_codegen_llvm..abi..LlvmType$GT$9llvm_type17h1296210ab461fc57E+0x54): relocation truncated to fit: R_ARM_CALL against symbol `__aeabi_uldivmod' defined in .text.__aeabi_uldivmod section in /tmp/rustcdnGbao/libcompiler_builtins-ee65b414e4115a8f.rlib(compiler_builtins-ee65b414e4115a8f.compiler_builtins.ay8p39ey-cgu.13.rcgu.o)
- @${PRINTF} '#!/bin/sh\nexec ${CC} -fuse-ld=lld "$$@"' > ${WRKDIR}/cc-wrapper
- @${CHMOD} +x ${WRKDIR}/cc-wrapper
-.elif ${ARCH} == powerpc
+.if ${ARCH} == powerpc
# Rust doesn't call the system compiler with the full version of the target.
# This makes powerpc miscompile due to the secure-plt ABI change.
# Additionally, force using ld.bfd to work around a linking problem in rustc_mir
diff --git a/lang/zig-devel/Makefile b/lang/zig-devel/Makefile
index 33059061e434..62a19947419a 100644
--- a/lang/zig-devel/Makefile
+++ b/lang/zig-devel/Makefile
@@ -11,7 +11,6 @@ COMMENT= Language designed for robustness, optimality, and maintainability
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_FreeBSD_11= expects getrandom(2) which is unavailable on FreeBSD < 12.0
ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= not yet supported
diff --git a/lang/zig/Makefile b/lang/zig/Makefile
index 1bd162fd1e10..9c0fcb34f400 100644
--- a/lang/zig/Makefile
+++ b/lang/zig/Makefile
@@ -9,7 +9,6 @@ COMMENT= Language designed for robustness, optimality, and maintainability
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_FreeBSD_11= expects getrandom(2) which is unavailable on FreeBSD < 12.0
ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= not yet supported