aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-11 16:52:44 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-11 16:52:44 +0000
commit8b499abea8195b447ba3b97c06e5e56aa0a0f673 (patch)
tree6b7c124429cf0876a0952f09cdfd71ba28931043 /lang
parent09cc0e0957fc7bea3f8ca69e2bbdafb51761f27a (diff)
downloadports-8b499abea8195b447ba3b97c06e5e56aa0a0f673.tar.gz
ports-8b499abea8195b447ba3b97c06e5e56aa0a0f673.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/linux-libperl5.8/Makefile50
-rw-r--r--lang/linux-libperl5.8/distinfo.i3863
-rw-r--r--lang/linux-libperl5.8/pkg-descr6
-rw-r--r--lang/linux-libperl5.8/pkg-plist.i3866
5 files changed, 66 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index e87735384bad..1f305928631d 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -125,6 +125,7 @@
SUBDIR += libutils
SUBDIR += linux-j
SUBDIR += linux-libgcc
+ SUBDIR += linux-libperl5.8
SUBDIR += logo
SUBDIR += lua
SUBDIR += lua-mode.el
diff --git a/lang/linux-libperl5.8/Makefile b/lang/linux-libperl5.8/Makefile
new file mode 100644
index 000000000000..42ad1fc879d8
--- /dev/null
+++ b/lang/linux-libperl5.8/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: linux libperl
+# Date created: Sun Dec 11 16:38:34 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# Based on: emulators/linux_base by marcel@FreeBSD.org and
+# devel/linux-sdl12 by freebsd-emulation@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libperl
+PORTVERSION= 5.8.5
+CATEGORIES= lang linux
+MASTER_SITES= ftp://195.220.108.108/linux/conectiva/snapshot/i386/RPMS.extra/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}${PORTVERSION:R}-${PORTVERSION}-67091cl.${MACHINE_ARCH}
+EXTRACT_SUFX= .rpm
+EXTRACT_ONLY=
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Library for embedding the perl interpreter (linux version)
+
+BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+
+USE_LINUX= yes
+USE_LINUX_PREFIX= yes
+LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
+
+ONLY_FOR_ARCHS= i386 amd64
+DIST_SUBDIR= rpm
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+
+DBPATH= /var/lib/rpm
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
+ --nodeps --replacepkgs
+RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+MACHINE_ARCH= i386
+.endif
+
+do-install:
+ @${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
+ @${LDCONFIG_LINUX}
+
+.include <bsd.port.post.mk>
diff --git a/lang/linux-libperl5.8/distinfo.i386 b/lang/linux-libperl5.8/distinfo.i386
new file mode 100644
index 000000000000..84e58be7c436
--- /dev/null
+++ b/lang/linux-libperl5.8/distinfo.i386
@@ -0,0 +1,3 @@
+MD5 (rpm/libperl5.8-5.8.5-67091cl.i386.rpm) = be258a9a7a48cde5e44d70ccb6d5b18f
+SHA256 (rpm/libperl5.8-5.8.5-67091cl.i386.rpm) = 0f3b89c7e963b217666e8384174eea7c848e225618ae4b06a50db6c2f6c41720
+SIZE (rpm/libperl5.8-5.8.5-67091cl.i386.rpm) = 1122934
diff --git a/lang/linux-libperl5.8/pkg-descr b/lang/linux-libperl5.8/pkg-descr
new file mode 100644
index 000000000000..e90d4f64e85a
--- /dev/null
+++ b/lang/linux-libperl5.8/pkg-descr
@@ -0,0 +1,6 @@
+Shared lib for embedding the perl interpreter into other apps. This
+is not needed by the Perl interpreter itself.
+
+WWW: http://perl.com/
+
+-- lioux@FreeBSD.org
diff --git a/lang/linux-libperl5.8/pkg-plist.i386 b/lang/linux-libperl5.8/pkg-plist.i386
new file mode 100644
index 000000000000..db6d43ecc386
--- /dev/null
+++ b/lang/linux-libperl5.8/pkg-plist.i386
@@ -0,0 +1,6 @@
+usr/lib/libperl.so.5.8
+usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so.5.8
+@dirrm usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE
+@dirrm usr/lib/perl5/5.8.5/i386-linux-thread-multi
+@dirrm usr/lib/perl5/5.8.5
+@dirrm usr/lib/perl5