aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-05-23 00:48:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-05-23 00:48:43 +0000
commitadfa34ad53d0adc2a1c8d9317a63effc101a1a29 (patch)
tree0e0bbdd4f346138f8f51d0b5844a56c8959c0250 /lang
parent0bf762a0daf20fdc1e1797be7c55231b64d0d8e2 (diff)
downloadports-adfa34ad53d0adc2a1c8d9317a63effc101a1a29.tar.gz
ports-adfa34ad53d0adc2a1c8d9317a63effc101a1a29.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/intel-compute-runtime/Makefile12
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-backtrace11
-rw-r--r--lang/intel-compute-runtime/files/patch-clock_gettime10
-rw-r--r--lang/intel-compute-runtime/files/patch-getPath38
-rw-r--r--lang/intel-compute-runtime/files/patch-no-blitter11
-rw-r--r--lang/intel-compute-runtime/files/patch-ocloc-no-dlsym34
7 files changed, 29 insertions, 93 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index dede7d1164cc..15b9aa36c6f3 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= compute-runtime
-DISTVERSION= 20.19.16754
+DISTVERSION= 20.20.16837
CATEGORIES= lang
PKGNAMEPREFIX= intel-
@@ -13,6 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Only Intel GPUs on x86 are supported
+BROKEN_i386= https://github.com/intel/compute-runtime/issues/316
LIB_DEPENDS= libigc.so:devel/intel-graphics-compiler \
libigdgmm.so:multimedia/gmmlib
@@ -23,9 +24,12 @@ USE_LDCONFIG= yes
GH_ACCOUNT= intel
CMAKE_ON= SKIP_UNIT_TESTS
CMAKE_ARGS= -DNEO_OCL_DRIVER_VERSION:STRING="${DISTVERSIONFULL}"
-PLIST_FILES= etc/OpenCL/vendors/intel.icd \
- bin/ocloc \
- lib/intel-opencl/libigdrcl.so
+PLIST_FILES= bin/ocloc \
+ etc/OpenCL/vendors/intel.icd \
+ include/ocloc_api.h \
+ lib/intel-opencl/libigdrcl.so \
+ lib/libocloc.so \
+ ${NULL}
OPTIONS_DEFINE= VAAPI
OPTIONS_DEFAULT=VAAPI
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index eb63d2c2bf3c..dd2a4bd17ded 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588775595
-SHA256 (intel-compute-runtime-20.19.16754_GH0.tar.gz) = efe934ec037b1a757e3b427ca110ca42aaa2ad21cd7e8cffc3f02f034eea828e
-SIZE (intel-compute-runtime-20.19.16754_GH0.tar.gz) = 3099362
+TIMESTAMP = 1589575000
+SHA256 (intel-compute-runtime-20.20.16837_GH0.tar.gz) = 975787ced1800ea52ece2ca40c23c4cac9267a358957c4a7f5255d22dc6a6d5f
+SIZE (intel-compute-runtime-20.20.16837_GH0.tar.gz) = 3121549
diff --git a/lang/intel-compute-runtime/files/patch-backtrace b/lang/intel-compute-runtime/files/patch-backtrace
index 0820f615f4d8..10a7a98e0207 100644
--- a/lang/intel-compute-runtime/files/patch-backtrace
+++ b/lang/intel-compute-runtime/files/patch-backtrace
@@ -23,15 +23,14 @@ ld: error: undefined symbol: backtrace_symbols
callstack = backtrace_symbols(addresses, backtraceSize);
for (int i = 0; i < backtraceSize; ++i) {
---- shared/offline_compiler/source/CMakeLists.txt.orig 2020-02-28 16:16:42 UTC
+--- shared/offline_compiler/source/CMakeLists.txt.orig 2020-05-15 20:36:40 UTC
+++ shared/offline_compiler/source/CMakeLists.txt
-@@ -161,6 +161,10 @@ endif()
+@@ -140,6 +140,9 @@ endif()
+
if(UNIX)
- target_link_libraries(ocloc_lib dl pthread)
- target_link_libraries(ocloc dl pthread)
+ target_link_libraries(${OCLOC_NAME}_lib dl pthread)
+ if(CMAKE_SYSTEM_NAME MATCHES "DragonFly|FreeBSD|NetBSD|OpenBSD")
-+ target_link_libraries(ocloc_lib execinfo)
-+ target_link_libraries(ocloc execinfo)
++ target_link_libraries(${OCLOC_NAME}_lib execinfo)
+ endif()
endif()
diff --git a/lang/intel-compute-runtime/files/patch-clock_gettime b/lang/intel-compute-runtime/files/patch-clock_gettime
index 34ada0f4b451..e1cf4dc32ff5 100644
--- a/lang/intel-compute-runtime/files/patch-clock_gettime
+++ b/lang/intel-compute-runtime/files/patch-clock_gettime
@@ -9,14 +9,18 @@ runtime/os_interface/linux/os_time_linux.cpp:138:24: error:
if (resolutionFunc(CLOCK_MONOTONIC_RAW, &ts)) {
^
---- shared/source/os_interface/linux/os_time_linux.cpp.orig 2020-02-28 16:16:42 UTC
+--- shared/source/os_interface/linux/os_time_linux.cpp.orig 2020-05-15 20:36:40 UTC
+++ shared/source/os_interface/linux/os_time_linux.cpp
-@@ -14,6 +14,10 @@
+@@ -14,6 +14,14 @@
#include <time.h>
+#ifndef CLOCK_MONOTONIC_RAW
-+#define CLOCK_MONOTONIC_RAW CLOCK_MONOTONIC
++# ifdef CLOCK_MONOTONIC_FAST
++# define CLOCK_MONOTONIC_RAW CLOCK_MONOTONIC_FAST
++# else
++# define CLOCK_MONOTONIC_RAW CLOCK_MONOTONIC
++# endif
+#endif
+
namespace NEO {
diff --git a/lang/intel-compute-runtime/files/patch-getPath b/lang/intel-compute-runtime/files/patch-getPath
deleted file mode 100644
index 3b648a653c65..000000000000
--- a/lang/intel-compute-runtime/files/patch-getPath
+++ /dev/null
@@ -1,38 +0,0 @@
-Implement getPath on BSDs
-
---- shared/offline_compiler/source/utilities/linux/get_path.cpp.orig 2020-02-28 16:16:42 UTC
-+++ shared/offline_compiler/source/utilities/linux/get_path.cpp
-@@ -10,11 +10,33 @@
- #include <sys/types.h>
- #include <unistd.h>
-
-+#if defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD__)
-+#include <sys/sysctl.h>
-+#endif
-+
- std::string getPath() {
-+#if defined(KERN_PROC_PATHNAME)
-+ char exepath[PATH_MAX + 1] = {0};
-+ size_t len = sizeof(exepath);
-+ int mib[] = {
-+ CTL_KERN,
-+#if defined(__NetBSD__)
-+ KERN_PROC_ARGS,
-+ -1,
-+ KERN_PROC_PATHNAME,
-+#else
-+ KERN_PROC,
-+ KERN_PROC_PATHNAME,
-+ -1,
-+#endif
-+ };
-+ if (sysctl(mib, sizeof(mib)/sizeof(mib[0]), exepath, &len, NULL, 0) != -1) {
-+#else // Linux
- char exepath[128] = {0};
- std::stringstream ss;
- ss << "/proc/" << getpid() << "/exe";
- if (readlink(ss.str().c_str(), exepath, 128) != -1) {
-+#endif
- std::string path = std::string(exepath);
- path = path.substr(0, path.find_last_of('/') + 1);
- return path;
diff --git a/lang/intel-compute-runtime/files/patch-no-blitter b/lang/intel-compute-runtime/files/patch-no-blitter
index ca34842f0132..bd4ac0f63a7e 100644
--- a/lang/intel-compute-runtime/files/patch-no-blitter
+++ b/lang/intel-compute-runtime/files/patch-no-blitter
@@ -23,14 +23,15 @@ frame #4: 0x000000000020df59 ze_peak`L0Context::init_xe(this=0x00007fffffffde70)
185 }
186 if (verbose)
---- level_zero/core/source/device/device_imp.h.orig 2020-04-17 18:43:38 UTC
+--- level_zero/core/source/device/device_imp.h.orig 2020-05-15 20:36:40 UTC
+++ level_zero/core/source/device/device_imp.h
-@@ -99,9 +99,7 @@ struct DeviceImp : public Device {
- auto hwInfo = neoDevice->getHardwareInfo();
- if (hwInfo.capabilityTable.blitterOperationsSupported) {
- *useBliter = NEO::DebugManager.flags.EnableCopyOnlyCommandListsAndCommandQueues.get();
+@@ -102,10 +102,7 @@ struct DeviceImp : public Device {
+ } else {
+ *useBliter = NEO::DebugManager.flags.EnableCopyOnlyCommandListsAndCommandQueues.get();
+ }
- return ZE_RESULT_SUCCESS;
}
+-
- return ZE_RESULT_ERROR_INVALID_ENUMERATION;
}
return ZE_RESULT_SUCCESS;
diff --git a/lang/intel-compute-runtime/files/patch-ocloc-no-dlsym b/lang/intel-compute-runtime/files/patch-ocloc-no-dlsym
deleted file mode 100644
index fabe89e9bbc1..000000000000
--- a/lang/intel-compute-runtime/files/patch-ocloc-no-dlsym
+++ /dev/null
@@ -1,34 +0,0 @@
-Regressed by https://github.com/intel/compute-runtime/commit/beab60f62634
-
-FAILED: bin/built_ins/x64/gen12lp/copy_buffer_rect_Gen12LPlp.spv bin/built_ins/x64/gen12lp/copy_buffer_rect_Gen12LPlp.bin bin/built_ins/x64/gen12lp/copy_buffer_rect_Gen12LPlp.cpp bin/built_ins/x64/gen12lp/copy_buffer_rect_Gen12LPlp.gen
-cd shared/source/built_ins/kernels && LD_LIBRARY_PATH=bin bin/ocloc -q -file copy_buffer_rect.builtin_kernel -device tgllp -64 -out_dir bin/built_ins/x64/gen12lp -cpp_file -options -cl-kernel-arg-info
-Error! Couldn't find OclocInvoke function.
-Error! Ocloc Library couldn't be loaded.
-
---- shared/offline_compiler/source/ocloc_wrapper.cpp.orig 2020-02-28 16:16:42 UTC
-+++ shared/offline_compiler/source/ocloc_wrapper.cpp
-@@ -5,6 +5,7 @@
- *
- */
-
-+#include "ocloc_api.h"
- #include "ocloc_wrapper.h"
-
- #include "shared/source/os_interface/os_library.h"
-@@ -43,14 +44,8 @@ struct OclocWrapper::Impl {
- OclocLibrary ocloc;
- std::string oclocLibName = "";
- ocloc.library.reset(NEO::OsLibrary::load(oclocLibName));
-- if (nullptr == (ocloc.invoke = reinterpret_cast<pOclocInvoke>(ocloc.library->getProcAddress("oclocInvoke")))) {
-- std::cout << "Error! Couldn't find OclocInvoke function.\n";
-- return;
-- }
-- if (nullptr == (ocloc.freeOutput = reinterpret_cast<pOclocFreeOutput>(ocloc.library->getProcAddress("oclocFreeOutput")))) {
-- std::cout << "Error! Couldn't find OclocFreeOutput function.\n";
-- return;
-- }
-+ ocloc.invoke = oclocInvoke;
-+ ocloc.freeOutput = oclocFreeOutput;
- this->oclocLib = std::move(ocloc);
- }
- };