aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2018-09-18 00:19:31 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2018-09-18 00:19:31 +0000
commitfa9290fee7ab90a9f2ec5b287a9a4d708fad6ac2 (patch)
treecc4d221224fd701a4be3fadf835a4e9d56afe9ce /lang
parentb6d369168580d62bf2729499c07b16c6096edaa7 (diff)
downloadports-fa9290fee7ab90a9f2ec5b287a9a4d708fad6ac2.tar.gz
ports-fa9290fee7ab90a9f2ec5b287a9a4d708fad6ac2.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/ott/Makefile27
-rw-r--r--lang/ott/distinfo3
-rw-r--r--lang/ott/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 97ab8de5f8d3..4e7f0c95c207 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -224,6 +224,7 @@
SUBDIR += oo2c
SUBDIR += opencoarrays
SUBDIR += opendylan
+ SUBDIR += ott
SUBDIR += owl-lisp
SUBDIR += p2c
SUBDIR += p5-Data-JavaScript
diff --git a/lang/ott/Makefile b/lang/ott/Makefile
new file mode 100644
index 000000000000..4a968d641dfa
--- /dev/null
+++ b/lang/ott/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= ott
+PORTVERSION= 0.28
+CATEGORIES= lang
+
+MAINTAINER= domagoj.stolfa@cl.cam.ac.uk
+COMMENT= Tool for writing definitions of programming languages and calculi
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+USES= gmake
+
+ALL_TARGET= world
+
+USE_GITHUB= yes
+GH_ACCOUNT= ott-lang
+
+USE_OCAML= yes
+
+PLIST_FILES= bin/ott
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/ott ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/lang/ott/distinfo b/lang/ott/distinfo
new file mode 100644
index 000000000000..1313a4ff43b9
--- /dev/null
+++ b/lang/ott/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537137485
+SHA256 (ott-lang-ott-0.28_GH0.tar.gz) = 30c7613802cdd7f03eb1df1d634da3e13197e210d5697252382d29b5f03618f2
+SIZE (ott-lang-ott-0.28_GH0.tar.gz) = 3263773
diff --git a/lang/ott/pkg-descr b/lang/ott/pkg-descr
new file mode 100644
index 000000000000..1ae6f3a4798d
--- /dev/null
+++ b/lang/ott/pkg-descr
@@ -0,0 +1,5 @@
+A tool for writing definitions of programming languages and calculi
+
+by Peter Sewell, Francesco Zappa Nardelli, and Scott Owens.
+
+WWW: https://github.com/ott-lang/ott