aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2012-03-17 11:22:17 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2012-03-17 11:22:17 +0000
commit2820a998695b46c750d94d7efcaf8387688e6379 (patch)
treef8b41d010c6476301de1abc9759bc946336d1d6e /lang
parent30047d93995d820a697e9075584c02a6495965bc (diff)
downloadports-2820a998695b46c750d94d7efcaf8387688e6379.tar.gz
ports-2820a998695b46c750d94d7efcaf8387688e6379.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gcc48/Makefile8
-rw-r--r--lang/gcc48/distinfo4
-rw-r--r--lang/gcc48/pkg-descr4
-rw-r--r--lang/gcc48/pkg-plist2
5 files changed, 10 insertions, 9 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 724373fbc9c0..d858936716c5 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -93,6 +93,7 @@
SUBDIR += gcc44
SUBDIR += gcc46
SUBDIR += gcc47
+ SUBDIR += gcc48
SUBDIR += gcl
SUBDIR += gdc
SUBDIR += gforth
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index c6fc1b0e61b4..11cb620e2c1a 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -1,20 +1,20 @@
# ex:ts=8
-# Ports collection makefile for: gcc47
-# Date created: 2011-03-20
+# Ports collection makefile for: gcc48
+# Date created: 2012-03-17
# Whom: Gerald Pfeifer <gerald@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gcc
-PORTVERSION= 4.7.0.20120225
+PORTVERSION= 4.8.0.20120311
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTNAME= gcc-${VERSIONSTRING}
MAINTAINER= gerald@FreeBSD.org
-COMMENT= GNU Compiler Collection 4.7
+COMMENT= GNU Compiler Collection 4.8
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.4:${PORTSDIR}/math/mpfr \
diff --git a/lang/gcc48/distinfo b/lang/gcc48/distinfo
index 7d299ccaf699..93a8902150d9 100644
--- a/lang/gcc48/distinfo
+++ b/lang/gcc48/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-4.7-20120225.tar.bz2) = da53532b956fd87097420606e5ab6abd895201f6dc1f6177f8e9b739891d49a3
-SIZE (gcc-4.7-20120225.tar.bz2) = 78436902
+SHA256 (gcc-4.8-20120311.tar.bz2) = 56caa2f030b64e419a516966d35eab8a17321622418aacf1ab18ac3c6be68eb6
+SIZE (gcc-4.8-20120311.tar.bz2) = 78657842
diff --git a/lang/gcc48/pkg-descr b/lang/gcc48/pkg-descr
index bd20ae3f9a28..5ee8754bde36 100644
--- a/lang/gcc48/pkg-descr
+++ b/lang/gcc48/pkg-descr
@@ -1,6 +1,6 @@
GCC, the GNU Compiler Collection, supports a number of languages. This
-port installs the C, C++, Fortran and Java front ends as gcc47, g++47,
-gfortran47, and gcj47, respectively.
+port installs the C, C++, Fortran and Java front ends as gcc48, g++48,
+gfortran48, and gcj48, respectively.
WWW: http://gcc.gnu.org/
diff --git a/lang/gcc48/pkg-plist b/lang/gcc48/pkg-plist
index 89db48ca89e3..84933811edb3 100644
--- a/lang/gcc48/pkg-plist
+++ b/lang/gcc48/pkg-plist
@@ -49,7 +49,7 @@ share/gcc-%%GCC_VER%%/python/libstdcxx/v6/printers.py
%%JAVA%%bin/jcf-dump%%SUFFIX%%
%%JAVA%%bin/jv-convert%%SUFFIX%%
%%JAVA%%bin/rebuild-gcj-db%%SUFFIX%%
-%%JAVA%%libdata/pkgconfig/libgcj-4.7.pc
+%%JAVA%%libdata/pkgconfig/libgcj-4.8.pc
%%JAVA%%share/java/libgcj-%%GCC_VER%%.jar
%%JAVA%%share/java/libgcj-tools-%%GCC_VER%%.jar
@exec if type ccache-update-links >/dev/null 2>&1; then ccache-update-links -v; fi