aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-18 18:53:12 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-18 18:53:12 +0000
commit9a55e13d3aaa1cd8186e3e1f607b9f5d8f6122f5 (patch)
treee1b00caf100afb732cb584a4ea6ba7bb54c84e3d /lang
parentc7d07cf303817d84f33b1881bf0b331226a74f25 (diff)
downloadports-9a55e13d3aaa1cd8186e3e1f607b9f5d8f6122f5.tar.gz
ports-9a55e13d3aaa1cd8186e3e1f607b9f5d8f6122f5.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/ruby-man/Makefile30
-rw-r--r--lang/ruby-man/distinfo1
-rw-r--r--lang/ruby-man/pkg-comment1
-rw-r--r--lang/ruby-man/pkg-descr6
-rw-r--r--lang/ruby-man/pkg-plist50
6 files changed, 89 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index cf4c73386a4c..61f8d3c6de05 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -97,6 +97,7 @@
SUBDIR += python-doc-postscript-letter
SUBDIR += rexx-imc
SUBDIR += ruby
+ SUBDIR += ruby-man
SUBDIR += ruby-perl
SUBDIR += ruby-python
SUBDIR += scheme48
diff --git a/lang/ruby-man/Makefile b/lang/ruby-man/Makefile
new file mode 100644
index 000000000000..8a38c10e3359
--- /dev/null
+++ b/lang/ruby-man/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: ruby-man
+# Date created: Sat Aug 17 17:10:02 CEST 2000
+# Whom: olgeni@uli.it
+#
+# $FreeBSD$
+#
+
+PORTNAME= ruby-man
+PORTVERSION= 1.4.6
+CATEGORIES+= lang ruby
+MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/doc/
+DISTNAME= ${PORTNAME}-${PORTVERSION}${LANGSUFFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= olgeni@uli.it
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" LANGSUFFIX="${LANGSUFFIX}"
+
+RUBY_VER?= 1.4
+WRKSRC= ${WRKDIR}/${PORTNAME}-${RUBY_VER}${LANGSUFFIX}
+
+NO_BUILD= yes
+
+DOCDIR= ${PREFIX}/share/doc/ruby/ruby-man-${RUBY_VER}${LANGSUFFIX}
+
+do-install:
+ ${MKDIR} ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${DOCDIR}
+
+.include <bsd.port.mk>
diff --git a/lang/ruby-man/distinfo b/lang/ruby-man/distinfo
new file mode 100644
index 000000000000..3ff9c8b5ee30
--- /dev/null
+++ b/lang/ruby-man/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-man-1.4.6.tar.gz) = 8eed63fec14a719df26247fb8384db5e
diff --git a/lang/ruby-man/pkg-comment b/lang/ruby-man/pkg-comment
new file mode 100644
index 000000000000..18c0cf7d1c09
--- /dev/null
+++ b/lang/ruby-man/pkg-comment
@@ -0,0 +1 @@
+Ruby reference manual, in HTML format
diff --git a/lang/ruby-man/pkg-descr b/lang/ruby-man/pkg-descr
new file mode 100644
index 000000000000..b25945eaa480
--- /dev/null
+++ b/lang/ruby-man/pkg-descr
@@ -0,0 +1,6 @@
+Ruby is the interpreted scripting language for quick and easy
+object-oriented programming. It has many features to process text
+files and to do system management tasks. This package contains the
+Ruby reference manual in HTML format.
+
+WWW: http://www.ruby-lang.org/
diff --git a/lang/ruby-man/pkg-plist b/lang/ruby-man/pkg-plist
new file mode 100644
index 000000000000..544464264795
--- /dev/null
+++ b/lang/ruby-man/pkg-plist
@@ -0,0 +1,50 @@
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Array.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Bignum.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Class.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Compar.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Data.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Dir.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/ENV.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Enum.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Errno.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Exception.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/File.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/FileTest.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Fixnum.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Float.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/GC.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Hash.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/IO.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Integer.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Kernel.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Marshal.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Match.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Math.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Module.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/NilClass.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Numeric.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/ObSpace.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Object.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Prec.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Proc.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Process.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Range.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Regexp.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/String.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Struct.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/Time.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/bundle.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/classes.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/dbm.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/function.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/glossary.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/index.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/kconv.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/options.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/preface.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/socket.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/syntax.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/thread.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/variable.html
+share/doc/ruby/ruby-man-%%RUBY_VER%%/yacc.html
+@dirrm share/doc/ruby/ruby-man-%%RUBY_VER%%