aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-18 19:06:37 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-18 19:06:37 +0000
commita0b9c235665060baf86ab16dc141afa53115b3d9 (patch)
treedc32b83c50bd2c36ba8d3468058ca9f29c9be6fe /lang
parente3c89bd5c4aa87a577d00411b72ba80482bf2a51 (diff)
downloadports-a0b9c235665060baf86ab16dc141afa53115b3d9.tar.gz
ports-a0b9c235665060baf86ab16dc141afa53115b3d9.zip
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc9/Makefile2
-rw-r--r--lang/gcc9/files/patch-gcc_configure11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/gcc9/Makefile b/lang/gcc9/Makefile
index bbf434c0b83c..029662650c29 100644
--- a/lang/gcc9/Makefile
+++ b/lang/gcc9/Makefile
@@ -12,7 +12,7 @@ COMMENT= GNU Compiler Collection 9
LICENSE= GPLv3 GPLv3RLE
LICENSE_COMB= multi
-ONLY_FOR_ARCHS= aarch64 amd64 arm armv6 armv7 i386 powerpc powerpc64 sparc64
+ONLY_FOR_ARCHS= aarch64 amd64 arm armv6 armv7 i386 powerpc powerpc64 powerpc64le sparc64
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
diff --git a/lang/gcc9/files/patch-gcc_configure b/lang/gcc9/files/patch-gcc_configure
new file mode 100644
index 000000000000..c83a180b248d
--- /dev/null
+++ b/lang/gcc9/files/patch-gcc_configure
@@ -0,0 +1,11 @@
+--- gcc/configure.orig 2021-04-29 10:19:44 UTC
++++ gcc/configure
+@@ -29405,7 +29405,7 @@ $as_echo "#define HAVE_LD_PPC_GNU_ATTR_LONG_DOUBLE 1"
+ esac
+
+ case "$target:$tm_file" in
+- powerpc64-*-freebsd* | powerpc64*-*-linux* | powerpc*-*-linux*rs6000/biarch64.h*)
++ powerpc64*-*-freebsd* | powerpc64*-*-linux* | powerpc*-*-linux*rs6000/biarch64.h*)
+ case "$target" in
+ *le-*-linux*)
+ emul_name="-melf64lppc"