aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-04-11 07:53:19 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-04-11 07:53:19 +0000
commit2288ee2ec6af401765f502f3c1f335b7914315f4 (patch)
treef3fbeaccc0b8deee60a876f8d893eba5064178e6 /lang
parent40fbdcdd73ca8833c31a8316619a7feaf7758ace (diff)
downloadports-2288ee2ec6af401765f502f3c1f335b7914315f4.tar.gz
ports-2288ee2ec6af401765f502f3c1f335b7914315f4.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile.ext28
-rw-r--r--lang/php53/Makefile.ext28
2 files changed, 0 insertions, 56 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index f5915d4b8018..074baf86071d 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -193,14 +193,6 @@ USE_MYSQL= yes
BROKEN_WITH_MYSQL= 323 40
.endif
-.if ${PHP_MODNAME} == "oci8"
-BUILD_DEPENDS+= ${LOCALBASE}/oracle8-client/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client
-
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
-CONFIGURE_ARGS+=--with-oci8=${LOCALBASE}/oracle8-client
-.endif
-
.if ${PHP_MODNAME} == "odbc"
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
@@ -250,17 +242,6 @@ USE_PHP= pdo
USE_PHP_BUILD= yes
.endif
-.if ${PHP_MODNAME} == "pdo_oci"
-BUILD_DEPENDS+= ${LOCALBASE}/oracle8-client/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client
-
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
-CONFIGURE_ARGS+=--with-pdo-oci=${LOCALBASE}/oracle8-client
-
-USE_PHP= pdo
-USE_PHP_BUILD= yes
-.endif
-
.if ${PHP_MODNAME} == "pdo_odbc"
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
@@ -515,15 +496,6 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
-.if ${PHP_MODNAME} == "oci8" || ${PHP_MODNAME} == "pdo_oci"
-pre-configure:
- @cd ${WRKSRC}; \
- for lib in ${LOCALBASE}/oracle8-client/lib/libclntsh /usr/lib/libpthread; do \
- /usr/bin/ar x $${lib}.a; \
- done; \
- /usr/bin/ar rcs liboci8.a *.o
-.endif
-
.if ${PHP_MODNAME} == "pdo_dblib"
.if defined(WITH_MSSQL)
LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds-msdblib
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index f5915d4b8018..074baf86071d 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -193,14 +193,6 @@ USE_MYSQL= yes
BROKEN_WITH_MYSQL= 323 40
.endif
-.if ${PHP_MODNAME} == "oci8"
-BUILD_DEPENDS+= ${LOCALBASE}/oracle8-client/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client
-
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
-CONFIGURE_ARGS+=--with-oci8=${LOCALBASE}/oracle8-client
-.endif
-
.if ${PHP_MODNAME} == "odbc"
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
@@ -250,17 +242,6 @@ USE_PHP= pdo
USE_PHP_BUILD= yes
.endif
-.if ${PHP_MODNAME} == "pdo_oci"
-BUILD_DEPENDS+= ${LOCALBASE}/oracle8-client/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client
-
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
-CONFIGURE_ARGS+=--with-pdo-oci=${LOCALBASE}/oracle8-client
-
-USE_PHP= pdo
-USE_PHP_BUILD= yes
-.endif
-
.if ${PHP_MODNAME} == "pdo_odbc"
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
@@ -515,15 +496,6 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
-.if ${PHP_MODNAME} == "oci8" || ${PHP_MODNAME} == "pdo_oci"
-pre-configure:
- @cd ${WRKSRC}; \
- for lib in ${LOCALBASE}/oracle8-client/lib/libclntsh /usr/lib/libpthread; do \
- /usr/bin/ar x $${lib}.a; \
- done; \
- /usr/bin/ar rcs liboci8.a *.o
-.endif
-
.if ${PHP_MODNAME} == "pdo_dblib"
.if defined(WITH_MSSQL)
LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds-msdblib