aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-03-17 03:48:02 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-03-17 03:48:02 +0000
commit397293d67bb277fe758a116cf694b73b386d919a (patch)
treee158134845e974db03ce7c89c8ff5f5a4e863a72 /lang
parent13a14328a54d05f2d3a330952f6e128d80559412 (diff)
downloadports-397293d67bb277fe758a116cf694b73b386d919a.tar.gz
ports-397293d67bb277fe758a116cf694b73b386d919a.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/mono/Makefile9
-rw-r--r--lang/mono/bsd.mono.mk2
-rw-r--r--lang/mono/distinfo6
-rw-r--r--lang/mono/files/patch-libgc_dbg_mlc.c82
-rw-r--r--lang/mono/files/patch-libgc_include_private_gcconfig.h36
-rw-r--r--lang/mono/files/patch-libgc_pthread_support.c36
-rw-r--r--lang/mono/files/patch-mcs-class-Managed.Windows.Forms-System.Windows.Forms-MimeIcon.cs11
-rw-r--r--lang/mono/files/patch-mcs_class_System.Web_System.Web.Compilation_AspParser.cs17
-rw-r--r--lang/mono/files/patch-mono_metadata_assembly.c12
-rw-r--r--lang/mono/files/patch-mono_metadata_filewatcher.c13
-rw-r--r--lang/mono/files/patch-mono_mini_aot-runtime.c12
-rw-r--r--lang/mono/files/patch-mono_mini_mini-exceptions.c14
-rw-r--r--lang/mono/files/patch-mono_mini_mini-x86.c20
-rw-r--r--lang/mono/files/patch-mono_utils_mono-codeman.c24
-rw-r--r--lang/mono/files/patch-os_dep.c20
-rw-r--r--lang/mono/pkg-descr8
-rw-r--r--lang/mono/pkg-plist173
17 files changed, 129 insertions, 366 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 918771680b2a..fc31d8882d69 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -3,12 +3,12 @@
# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.71 2007/01/13 21:29:41 tmclau02 Exp $
+# $Id: Makefile,v 1.78 2007/02/26 22:13:36 tmclau02 Exp $
#
PORTNAME= mono
-PORTVERSION= 1.2.2.1
-PORTREVISION= 3
+PORTVERSION= 1.2.3.1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.go-mono.com/sources/mono/ \
${MASTER_SITE_LOCAL}
@@ -51,7 +51,8 @@ MAN1= al.1 cert2spc.1 certmgr.1 chktrust.1 cilc.1 disco.1 dtd2xsd.1 \
mint.1 mkbundle.1 mono-service.1 mono-shlib-cop.1 mono.1 \
monoburg.1 monodis.1 monop.1 monostyle.1 mozroots.1 oldmono.1 \
permview.1 prj2make.1 secutil.1 setreg.1 signcode.1 sn.1 \
- soapsuds.1 sqlsharp.1 wsdl.1 xsd.1 mono-xmltool.1 sgen.1
+ soapsuds.1 sqlsharp.1 wsdl.1 xsd.1 mono-xmltool.1 sgen.1 \
+ httpcfg.1
MAN5= mono-config.5
.include <bsd.port.pre.mk>
diff --git a/lang/mono/bsd.mono.mk b/lang/mono/bsd.mono.mk
index 0eb94140b159..542a6b8408c8 100644
--- a/lang/mono/bsd.mono.mk
+++ b/lang/mono/bsd.mono.mk
@@ -6,7 +6,7 @@
# the FreeBSD ports system.
#
# $FreeBSD$
-# $Id: bsd.mono.mk,v 1.18 2006/12/06 22:07:01 killfill Exp $
+# $Id: bsd.mono.mk,v 1.20 2007/02/07 15:37:10 killfill Exp $
#
# USE_NANT - If set, the port uses nant.
diff --git a/lang/mono/distinfo b/lang/mono/distinfo
index efb3c8cfc1dc..2c0bdc6fc598 100644
--- a/lang/mono/distinfo
+++ b/lang/mono/distinfo
@@ -1,3 +1,3 @@
-MD5 (mono-1.2.2.1.tar.gz) = b67ef657b83ca26249d7b9e9c5e7da69
-SHA256 (mono-1.2.2.1.tar.gz) = d68f597c303678c3f325f552a0e2780b613dbf34d093c2269c002127be4953e5
-SIZE (mono-1.2.2.1.tar.gz) = 19979026
+MD5 (mono-1.2.3.1.tar.gz) = 4e4cdb6f98f1ea62bb1900f214c55e58
+SHA256 (mono-1.2.3.1.tar.gz) = b177ced4e3ec0c2efc6a4e17f1f87f6e852f319332d4f138d25d4a68ffba2c78
+SIZE (mono-1.2.3.1.tar.gz) = 20694945
diff --git a/lang/mono/files/patch-libgc_dbg_mlc.c b/lang/mono/files/patch-libgc_dbg_mlc.c
deleted file mode 100644
index d881ca2ee269..000000000000
--- a/lang/mono/files/patch-libgc_dbg_mlc.c
+++ /dev/null
@@ -1,82 +0,0 @@
---- libgc/dbg_mlc.c.orig Sat Nov 13 13:52:28 2004
-+++ libgc/dbg_mlc.c Thu May 5 17:34:31 2005
-@@ -475,6 +475,23 @@
- GC_register_displacement((word)sizeof(oh) + offset);
- }
-
-+#if defined(__FreeBSD__)
-+#include <dlfcn.h>
-+static void GC_caller_func_offset(ad, symp, offp)
-+const GC_word ad;
-+const char **symp;
-+int *offp;
-+{
-+ Dl_info caller;
-+ if (dladdr((const void *)ad, &caller) && caller.dli_sname != NULL) {
-+ *symp = caller.dli_sname;
-+ *offp = (const char *)ad - (const char *)caller.dli_saddr;
-+ }
-+}
-+#else
-+#define GC_caller_func(ad, symp, offp)
-+#endif
-+
- # ifdef __STDC__
- GC_PTR GC_debug_malloc(size_t lb, GC_EXTRA_PARAMS)
- # else
-@@ -489,6 +506,13 @@
- {
- GC_PTR result = GC_malloc(lb + DEBUG_BYTES);
-
-+#ifdef GC_ADD_CALLER
-+ if (s == NULL) {
-+ GC_caller_func_offset(ra, &s, &i);
-+ if (s == NULL)
-+ s = "unknown";
-+ }
-+#endif
- if (result == 0) {
- GC_err_printf1("GC_debug_malloc(%ld) returning NIL (",
- (unsigned long) lb);
-@@ -858,6 +882,13 @@
- register size_t old_sz;
- register hdr * hhdr;
-
-+#ifdef GC_ADD_CALLER
-+ if (s == NULL) {
-+ GC_caller_func_offset(ra, &s, &i);
-+ if (s == NULL)
-+ s = "unknown";
-+ }
-+#endif
- if (p == 0) return(GC_debug_malloc(lb, OPT_RA s, i));
- if (base == 0) {
- GC_err_printf1(
-@@ -1166,7 +1197,11 @@
- }
-
- #ifdef GC_ADD_CALLER
--# define RA GC_RETURN_ADDR,
-+# ifdef GC_RETURN_ADDR_PARENT
-+# define RA GC_RETURN_ADDR_PARENT,
-+# else
-+# define RA GC_RETURN_ADDR,
-+# endif
- #else
- # define RA
- #endif
-@@ -1174,12 +1209,12 @@
- GC_PTR GC_debug_malloc_replacement(lb)
- size_t lb;
- {
-- return GC_debug_malloc(lb, RA "unknown", 0);
-+ return GC_debug_malloc(lb, RA NULL, 0);
- }
-
- GC_PTR GC_debug_realloc_replacement(p, lb)
- GC_PTR p;
- size_t lb;
- {
-- return GC_debug_realloc(p, lb, RA "unknown", 0);
-+ return GC_debug_realloc(p, lb, RA NULL, 0);
- }
diff --git a/lang/mono/files/patch-libgc_include_private_gcconfig.h b/lang/mono/files/patch-libgc_include_private_gcconfig.h
deleted file mode 100644
index ed305fc6f91a..000000000000
--- a/lang/mono/files/patch-libgc_include_private_gcconfig.h
+++ /dev/null
@@ -1,36 +0,0 @@
---- libgc/include/private/gcconfig.h.orig Wed Jul 5 17:55:42 2006
-+++ libgc/include/private/gcconfig.h Sun Sep 10 10:36:31 2006
-@@ -347,6 +347,10 @@
- # define I386
- # define mach_type_known
- # endif
-+# if defined(FREEBSD) && defined(__x86_64__)
-+# define X86_64
-+# define mach_type_known
-+# endif
- # if defined(__NetBSD__) && (defined(i386) || defined(__i386__))
- # define I386
- # define mach_type_known
-@@ -1988,6 +1992,22 @@
- # define PREFETCH(x) __builtin_prefetch((x), 0, 0)
- # define PREFETCH_FOR_WRITE(x) __builtin_prefetch((x), 1)
- # endif
-+# endif
-+# ifdef FREEBSD
-+# define OS_TYPE "FREEBSD"
-+# ifndef GC_FREEBSD_THREADS
-+# define MPROTECT_VDB
-+# endif
-+# define SIG_SUSPEND SIGTSTP
-+# define SIG_THR_RESTART SIGCONT
-+# define FREEBSD_STACKBOTTOM
-+# define NEED_FIND_LIMIT
-+# ifdef __ELF__
-+# define DYNAMIC_LOADING
-+# endif
-+ extern char etext[];
-+ extern char * GC_FreeBSDGetDataStart();
-+# define DATASTART GC_FreeBSDGetDataStart(0x1000, &etext)
- # endif
- # ifdef NETBSD
- # define OS_TYPE "NETBSD"
diff --git a/lang/mono/files/patch-libgc_pthread_support.c b/lang/mono/files/patch-libgc_pthread_support.c
deleted file mode 100644
index 472933ccd949..000000000000
--- a/lang/mono/files/patch-libgc_pthread_support.c
+++ /dev/null
@@ -1,36 +0,0 @@
---- libgc/pthread_support.c.orig Mon Sep 11 02:58:08 2006
-+++ libgc/pthread_support.c Mon Sep 11 02:59:51 2006
-@@ -597,23 +597,6 @@
- * gcc-3.3.6 miscompiles the &GC_thread_key+sizeof(&GC_thread_key) expression so
- * put it into a separate function.
- */
--# if defined(__GNUC__) && defined(THREAD_LOCAL_ALLOC) && !defined(DBG_HDRS_ALL)
--static __attribute__((noinline)) unsigned char* get_gc_thread_key_addr GC_PROTO((void))
--{
-- return (unsigned char*)&GC_thread_key;
--}
--
--void GC_push_thread_structures GC_PROTO((void))
--{
-- GC_push_all((ptr_t)(GC_threads), (ptr_t)(GC_threads)+sizeof(GC_threads));
--# if defined(THREAD_LOCAL_ALLOC) && !defined(DBG_HDRS_ALL)
-- GC_push_all((ptr_t)get_gc_thread_key_addr(),
-- (ptr_t)(get_gc_thread_key_addr())+sizeof(&GC_thread_key));
--# endif
--}
--
--#else
--
- void GC_push_thread_structures GC_PROTO((void))
- {
- GC_push_all((ptr_t)(GC_threads), (ptr_t)(GC_threads)+sizeof(GC_threads));
-@@ -622,9 +605,6 @@
- (ptr_t)(&GC_thread_key)+sizeof(&GC_thread_key));
- # endif
- }
--
--#endif
--
- #ifdef THREAD_LOCAL_ALLOC
- /* We must explicitly mark ptrfree and gcj free lists, since the free */
- /* list links wouldn't otherwise be found. We also set them in the */
diff --git a/lang/mono/files/patch-mcs-class-Managed.Windows.Forms-System.Windows.Forms-MimeIcon.cs b/lang/mono/files/patch-mcs-class-Managed.Windows.Forms-System.Windows.Forms-MimeIcon.cs
deleted file mode 100644
index 15628801e521..000000000000
--- a/lang/mono/files/patch-mcs-class-Managed.Windows.Forms-System.Windows.Forms-MimeIcon.cs
+++ /dev/null
@@ -1,11 +0,0 @@
---- mcs/class/Managed.Windows.Forms/System.Windows.Forms/MimeIcon.cs.orig Wed Dec 6 15:06:58 2006
-+++ mcs/class/Managed.Windows.Forms/System.Windows.Forms/MimeIcon.cs Wed Dec 6 15:27:58 2006
-@@ -394,7 +394,7 @@
- [DllImport(librsvg)]
- static extern IntPtr rsvg_pixbuf_from_file_at_size (string file_name, int width, int height, out IntPtr error);
-
-- [DllImport(libgdk)]
-+ [DllImport("libgdk_pixbuf-2.0.so")]
- static extern bool gdk_pixbuf_save_to_buffer (IntPtr pixbuf, out IntPtr buffer, out UIntPtr buffer_size, string type, out IntPtr error, IntPtr option_dummy);
-
- [DllImport(libglib)]
diff --git a/lang/mono/files/patch-mcs_class_System.Web_System.Web.Compilation_AspParser.cs b/lang/mono/files/patch-mcs_class_System.Web_System.Web.Compilation_AspParser.cs
new file mode 100644
index 000000000000..0406d04f70f9
--- /dev/null
+++ b/lang/mono/files/patch-mcs_class_System.Web_System.Web.Compilation_AspParser.cs
@@ -0,0 +1,17 @@
+--- mcs/class/System.Web/System.Web.Compilation/AspParser.cs.orig Fri Dec 29 22:13:43 2006
++++ mcs/class/System.Web/System.Web.Compilation/AspParser.cs Fri Dec 29 22:14:41 2006
+@@ -454,8 +454,12 @@
+ tokenizer.Verbatim = false;
+ id = inside_tags;
+ attributes = null;
+- tagtype = (databinding ? TagType.DataBinding :
+- (varname ? TagType.CodeRenderExpression : TagType.CodeRender));
++ if (databinding)
++ tagtype = TagType.DataBinding;
++ else if (varname)
++ tagtype = TagType.CodeRenderExpression;
++ else
++ tagtype = TagType.CodeRender;
+ }
+
+ public event ParseErrorHandler Error;
diff --git a/lang/mono/files/patch-mono_metadata_assembly.c b/lang/mono/files/patch-mono_metadata_assembly.c
deleted file mode 100644
index 4b8f05b5db2d..000000000000
--- a/lang/mono/files/patch-mono_metadata_assembly.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- mono/metadata/assembly.c.orig Tue May 3 15:42:51 2005
-+++ mono/metadata/assembly.c Thu May 5 17:34:31 2005
-@@ -174,7 +174,8 @@
- const char *path;
- char **splitted;
-
-- path = g_getenv ("MONO_GAC_PREFIX");
-+ path = g_strjoin(G_SEARCHPATH_SEPARATOR_S, "%%X11BASE%%", g_getenv("MONO_GAC_PREFIX"), NULL);
-+
- if (!path)
- return;
-
diff --git a/lang/mono/files/patch-mono_metadata_filewatcher.c b/lang/mono/files/patch-mono_metadata_filewatcher.c
index b7c1f9eadf21..a4c4218c61be 100644
--- a/lang/mono/files/patch-mono_metadata_filewatcher.c
+++ b/lang/mono/files/patch-mono_metadata_filewatcher.c
@@ -1,23 +1,24 @@
---- mono/metadata/filewatcher.c.orig Thu Dec 1 18:51:19 2005
-+++ mono/metadata/filewatcher.c Sun Dec 18 01:54:10 2005
-@@ -99,9 +99,6 @@
+--- mono/metadata/filewatcher.c.orig Fri Dec 29 19:52:48 2006
++++ mono/metadata/filewatcher.c Fri Dec 29 20:25:18 2006
+@@ -44,9 +44,6 @@
gint
ves_icall_System_IO_FSW_SupportsFSW (void)
{
-#if HAVE_KQUEUE
- return 3;
-#else
- GModule *fam_module;
+ MonoDl *fam_module;
gchar *filename;
int lib_used = 4; /* gamin */
-@@ -119,13 +116,19 @@
+@@ -76,14 +73,20 @@
}
if (fam_module == NULL)
- return 0;
+ goto nofam;
- g_module_symbol (fam_module, "FAMNextEvent", (gpointer *) &FAMNextEvent);
+ err = mono_dl_symbol (fam_module, "FAMNextEvent", (gpointer *) &FAMNextEvent);
+ g_free (err);
if (FAMNextEvent == NULL)
- return 0;
+ goto nofam;
diff --git a/lang/mono/files/patch-mono_mini_aot-runtime.c b/lang/mono/files/patch-mono_mini_aot-runtime.c
deleted file mode 100644
index 950773b16a5f..000000000000
--- a/lang/mono/files/patch-mono_mini_aot-runtime.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- mono/mini/aot-runtime.c.orig Sun Oct 22 13:10:53 2006
-+++ mono/mini/aot-runtime.c Sun Oct 22 13:16:25 2006
-@@ -19,6 +19,9 @@
- #include <winsock2.h>
- #include <windows.h>
- #endif
-+#ifdef PLATFORM_BSD
-+#include <sys/wait.h>
-+#endif
-
- #include <errno.h>
- #include <sys/stat.h>
diff --git a/lang/mono/files/patch-mono_mini_mini-exceptions.c b/lang/mono/files/patch-mono_mini_mini-exceptions.c
deleted file mode 100644
index c221fbf8875e..000000000000
--- a/lang/mono/files/patch-mono_mini_mini-exceptions.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- mono/mini/mini-exceptions.c.orig Tue Nov 1 09:07:14 2005
-+++ mono/mini/mini-exceptions.c Wed Nov 16 21:17:13 2005
-@@ -915,7 +915,11 @@
- tls->stack_size = stsize + getpagesize ();
-
- /* Setup an alternate signal stack */
-+#if defined(__FreeBSD__)
-+ tls->signal_stack = mmap (0, MONO_ARCH_SIGNAL_STACK_SIZE, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_ANON, -1, 0);
-+#else
- tls->signal_stack = mmap (0, MONO_ARCH_SIGNAL_STACK_SIZE, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0);
-+#endif
- tls->signal_stack_size = MONO_ARCH_SIGNAL_STACK_SIZE;
-
- g_assert (tls->signal_stack);
diff --git a/lang/mono/files/patch-mono_mini_mini-x86.c b/lang/mono/files/patch-mono_mini_mini-x86.c
deleted file mode 100644
index 15c2c58fe673..000000000000
--- a/lang/mono/files/patch-mono_mini_mini-x86.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- mono/mini/mini-x86.c.orig Thu Nov 2 15:09:51 2006
-+++ mono/mini/mini-x86.c Sun Dec 17 19:51:08 2006
-@@ -113,7 +113,7 @@
-
- static X86_Reg_No param_regs [] = { 0 };
-
--#ifdef PLATFORM_WIN32
-+#if defined(PLATFORM_WIN32) || defined(PLATFORM_BSD)
- static X86_Reg_No return_regs [] = { X86_EAX, X86_EDX };
- #endif
-
-@@ -179,7 +179,7 @@
- else
- size = mono_type_stack_size (&klass->byval_arg, NULL);
-
--#ifdef PLATFORM_WIN32
-+#if defined(PLATFORM_WIN32) || defined(PLATFORM_BSD)
- if (sig->pinvoke && is_return) {
- MonoMarshalType *info;
-
diff --git a/lang/mono/files/patch-mono_utils_mono-codeman.c b/lang/mono/files/patch-mono_utils_mono-codeman.c
deleted file mode 100644
index c5f06b3335ab..000000000000
--- a/lang/mono/files/patch-mono_utils_mono-codeman.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- mono/utils/mono-codeman.c.orig Tue Aug 2 17:52:22 2005
-+++ mono/utils/mono-codeman.c Tue Aug 2 17:52:29 2005
-@@ -40,7 +40,11 @@
- #endif
- #endif
-
--#ifdef __x86_64__
-+#if defined(__x86_64__) && defined(__FreeBSD__)
-+#define FORCE_MALLOC
-+#endif
-+
-+#if defined(__x86_64__) && !defined(__FreeBSD__)
- #define ARCH_MAP_FLAGS MAP_32BIT
- #else
- #define ARCH_MAP_FLAGS 0
-@@ -282,7 +286,7 @@
- chunk->pos = bsize;
- chunk->bsize = bsize;
-
-- /*printf ("code chunk at: %p\n", ptr);*/
-+ //printf ("code chunk at: %p\n", ptr);
- return chunk;
- }
-
diff --git a/lang/mono/files/patch-os_dep.c b/lang/mono/files/patch-os_dep.c
deleted file mode 100644
index c830c9380808..000000000000
--- a/lang/mono/files/patch-os_dep.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- libgc/os_dep.c.orig Wed Jul 5 17:55:43 2006
-+++ libgc/os_dep.c Sun Sep 10 11:04:32 2006
-@@ -84,7 +84,7 @@
- # define NEED_FIND_LIMIT
- # endif
-
--#if defined(FREEBSD) && (defined(I386) || defined(powerpc) || defined(__powerpc__))
-+#if defined(FREEBSD) && (defined(I386) || defined(X86_64) || defined(powerpc) || defined(__powerpc__))
- # include <machine/trap.h>
- # if !defined(PCR)
- # define NEED_FIND_LIMIT
-@@ -1396,7 +1396,7 @@
- }
- # endif
-
--# if defined(FREEBSD) && (defined(I386) || defined(powerpc) || defined(__powerpc__)) && !defined(PCR)
-+# if defined(FREEBSD) && (defined(I386) || defined(X86_64) || defined(powerpc) || defined(__powerpc__)) && !defined(PCR)
- /* Its unclear whether this should be identical to the above, or */
- /* whether it should apply to non-X86 architectures. */
- /* For now we don't assume that there is always an empty page after */
diff --git a/lang/mono/pkg-descr b/lang/mono/pkg-descr
index 269d125d530e..5d31ce4175c0 100644
--- a/lang/mono/pkg-descr
+++ b/lang/mono/pkg-descr
@@ -1,5 +1,9 @@
-An open source implementation of .NET Development Framework.
+Mono is an open source implementation of .NET Development Framework. Its
+objective is to enable UNIX developers to build and deploy cross-platform
+.NET Applications. The project implements various technologies developed by
+Microsoft that have now been submitted to the ECMA for standardization.
-This is a development release leading to the next production milestone.
+Mono provides the necessary software to develop and run .NET client and
+server applications on BSD, Linux, Solaris, Mac OS X, Windows, and Unix.
WWW: http://www.mono-project.com/
diff --git a/lang/mono/pkg-plist b/lang/mono/pkg-plist
index a680ff287651..fc71ae1c456c 100644
--- a/lang/mono/pkg-plist
+++ b/lang/mono/pkg-plist
@@ -1,4 +1,5 @@
bin/al
+bin/al2
bin/caspol
bin/cert2spc
bin/certmgr
@@ -10,6 +11,7 @@ bin/dtd2xsd
bin/gacutil
bin/genxs
bin/gmcs
+bin/httpcfg
bin/ilasm
bin/ilasm2
bin/jay
@@ -58,71 +60,71 @@ etc/mono/2.0/machine.config
etc/mono/2.0/web.config
etc/mono/browscap.ini
etc/mono/config
-include/mono/cil/opcode.def
-include/mono/interpreter/embed.h
-include/mono/io-layer/access.h
-include/mono/io-layer/atomic.h
-include/mono/io-layer/collection.h
-include/mono/io-layer/context.h
-include/mono/io-layer/critical-sections.h
-include/mono/io-layer/error.h
-include/mono/io-layer/events.h
-include/mono/io-layer/handles.h
-include/mono/io-layer/io-layer.h
-include/mono/io-layer/io-portability.h
-include/mono/io-layer/io.h
-include/mono/io-layer/macros.h
-include/mono/io-layer/mono-mutex.h
-include/mono/io-layer/mutexes.h
-include/mono/io-layer/processes.h
-include/mono/io-layer/security.h
-include/mono/io-layer/semaphores.h
-include/mono/io-layer/sockets.h
-include/mono/io-layer/status.h
-include/mono/io-layer/system.h
-include/mono/io-layer/threads.h
-include/mono/io-layer/timefuncs.h
-include/mono/io-layer/types.h
-include/mono/io-layer/uglify.h
-include/mono/io-layer/versioninfo.h
-include/mono/io-layer/wait.h
-include/mono/io-layer/wapi.h
-include/mono/jit/jit.h
-include/mono/metadata/appdomain.h
-include/mono/metadata/assembly.h
-include/mono/metadata/blob.h
-include/mono/metadata/class.h
-include/mono/metadata/debug-helpers.h
-include/mono/metadata/debug-mono-symfile.h
-include/mono/metadata/environment.h
-include/mono/metadata/exception.h
-include/mono/metadata/image.h
-include/mono/metadata/loader.h
-include/mono/metadata/mempool.h
-include/mono/metadata/metadata.h
-include/mono/metadata/mono-debug.h
-include/mono/metadata/mono-gc.h
-include/mono/metadata/object.h
-include/mono/metadata/opcodes.h
-include/mono/metadata/profiler.h
-include/mono/metadata/reflection.h
-include/mono/metadata/row-indexes.h
-include/mono/metadata/threads.h
-include/mono/metadata/tokentype.h
-include/mono/metadata/verify.h
-include/mono/metadata/mono-config.h
-include/mono/metadata/attrdefs.h
-include/mono/utils/mono-codeman.h
-include/mono/utils/mono-counters.h
-include/mono/utils/mono-digest.h
-include/mono/utils/mono-hash.h
-include/mono/utils/mono-logger.h
-include/mono/utils/mono-math.h
-include/mono/utils/mono-path.h
-include/mono/utils/mono-poll.h
-include/mono/utils/mono-stdlib.h
-include/mono/utils/mono-uri.h
-include/mono/utils/monobitset.h
+include/mono-1.0/mono/cil/opcode.def
+include/mono-1.0/mono/interpreter/embed.h
+include/mono-1.0/mono/io-layer/access.h
+include/mono-1.0/mono/io-layer/atomic.h
+include/mono-1.0/mono/io-layer/collection.h
+include/mono-1.0/mono/io-layer/context.h
+include/mono-1.0/mono/io-layer/critical-sections.h
+include/mono-1.0/mono/io-layer/error.h
+include/mono-1.0/mono/io-layer/events.h
+include/mono-1.0/mono/io-layer/handles.h
+include/mono-1.0/mono/io-layer/io-layer.h
+include/mono-1.0/mono/io-layer/io-portability.h
+include/mono-1.0/mono/io-layer/io.h
+include/mono-1.0/mono/io-layer/macros.h
+include/mono-1.0/mono/io-layer/mono-mutex.h
+include/mono-1.0/mono/io-layer/mutexes.h
+include/mono-1.0/mono/io-layer/processes.h
+include/mono-1.0/mono/io-layer/security.h
+include/mono-1.0/mono/io-layer/semaphores.h
+include/mono-1.0/mono/io-layer/sockets.h
+include/mono-1.0/mono/io-layer/status.h
+include/mono-1.0/mono/io-layer/system.h
+include/mono-1.0/mono/io-layer/threads.h
+include/mono-1.0/mono/io-layer/timefuncs.h
+include/mono-1.0/mono/io-layer/types.h
+include/mono-1.0/mono/io-layer/uglify.h
+include/mono-1.0/mono/io-layer/versioninfo.h
+include/mono-1.0/mono/io-layer/wait.h
+include/mono-1.0/mono/io-layer/wapi.h
+include/mono-1.0/mono/jit/jit.h
+include/mono-1.0/mono/metadata/appdomain.h
+include/mono-1.0/mono/metadata/assembly.h
+include/mono-1.0/mono/metadata/attrdefs.h
+include/mono-1.0/mono/metadata/blob.h
+include/mono-1.0/mono/metadata/class.h
+include/mono-1.0/mono/metadata/debug-helpers.h
+include/mono-1.0/mono/metadata/debug-mono-symfile.h
+include/mono-1.0/mono/metadata/environment.h
+include/mono-1.0/mono/metadata/exception.h
+include/mono-1.0/mono/metadata/image.h
+include/mono-1.0/mono/metadata/loader.h
+include/mono-1.0/mono/metadata/mempool.h
+include/mono-1.0/mono/metadata/metadata.h
+include/mono-1.0/mono/metadata/mono-config.h
+include/mono-1.0/mono/metadata/mono-debug.h
+include/mono-1.0/mono/metadata/mono-gc.h
+include/mono-1.0/mono/metadata/object.h
+include/mono-1.0/mono/metadata/opcodes.h
+include/mono-1.0/mono/metadata/profiler.h
+include/mono-1.0/mono/metadata/reflection.h
+include/mono-1.0/mono/metadata/row-indexes.h
+include/mono-1.0/mono/metadata/threads.h
+include/mono-1.0/mono/metadata/tokentype.h
+include/mono-1.0/mono/metadata/verify.h
+include/mono-1.0/mono/utils/mono-codeman.h
+include/mono-1.0/mono/utils/mono-counters.h
+include/mono-1.0/mono/utils/mono-digest.h
+include/mono-1.0/mono/utils/mono-hash.h
+include/mono-1.0/mono/utils/mono-logger.h
+include/mono-1.0/mono/utils/mono-math.h
+include/mono-1.0/mono/utils/mono-path.h
+include/mono-1.0/mono/utils/mono-poll.h
+include/mono-1.0/mono/utils/mono-stdlib.h
+include/mono-1.0/mono/utils/mono-uri.h
+include/mono-1.0/mono/utils/monobitset.h
lib/libMonoPosixHelper.a
lib/libMonoPosixHelper.la
lib/libMonoPosixHelper.so
@@ -291,11 +293,18 @@ lib/mono/2.0/I18N.Rare.dll
lib/mono/2.0/I18N.West.dll
lib/mono/2.0/I18N.dll
lib/mono/2.0/ICSharpCode.SharpZipLib.dll
+lib/mono/2.0/MSBuild/Microsoft.Build.CommonTypes.xsd
+lib/mono/2.0/MSBuild/Microsoft.Build.Core.xsd
lib/mono/2.0/Microsoft.Build.Engine.dll
lib/mono/2.0/Microsoft.Build.Framework.dll
lib/mono/2.0/Microsoft.Build.Tasks.dll
lib/mono/2.0/Microsoft.Build.Utilities.dll
+lib/mono/2.0/Microsoft.Build.xsd
+lib/mono/2.0/Microsoft.CSharp.targets
+lib/mono/2.0/Microsoft.Common.targets
+lib/mono/2.0/Microsoft.Common.tasks
lib/mono/2.0/Microsoft.JScript.dll
+lib/mono/2.0/Microsoft.VisualBasic.targets
lib/mono/2.0/Microsoft.VisualC.dll
lib/mono/2.0/Microsoft.Vsa.dll
lib/mono/2.0/Mono.C5.dll
@@ -336,6 +345,8 @@ lib/mono/2.0/System.Web.dll
lib/mono/2.0/System.Windows.Forms.dll
lib/mono/2.0/System.Xml.dll
lib/mono/2.0/System.dll
+lib/mono/2.0/al.exe
+lib/mono/2.0/al.exe.mdb
lib/mono/2.0/cscompmgd.dll
lib/mono/2.0/gmcs.exe
lib/mono/2.0/gmcs.exe.config
@@ -362,6 +373,7 @@ lib/mono/2.0/wsdl.exe
lib/mono/2.0/wsdl.exe.mdb
lib/mono/2.0/xbuild.exe
lib/mono/2.0/xbuild.exe.mdb
+lib/mono/2.0/xbuild.rsp
lib/mono/compat-1.0/ICSharpCode.SharpZipLib.dll
lib/mono/compat-2.0/ICSharpCode.SharpZipLib.dll
lib/mono/gac/Accessibility/1.0.5000.0__b03f5f7f11d50a3a/Accessibility.dll
@@ -598,12 +610,6 @@ lib/mono/gac/nunit.mocks/2.2.8.0__96d09a1eb7f44a77/nunit.mocks.dll
lib/mono/gac/nunit.mocks/2.2.8.0__96d09a1eb7f44a77/nunit.mocks.dll.mdb
lib/mono/gac/nunit.util/2.2.0.0__96d09a1eb7f44a77/nunit.util.dll
lib/mono/gac/nunit.util/2.2.0.0__96d09a1eb7f44a77/nunit.util.dll.mdb
-lib/mono/xbuild/MSBuild/Microsoft.Build.CommonTypes.xsd
-lib/mono/xbuild/MSBuild/Microsoft.Build.Core.xsd
-lib/mono/xbuild/Microsoft.Build.xsd
-lib/mono/xbuild/Microsoft.CSharp.targets
-lib/mono/xbuild/Microsoft.Common.tasks
-lib/mono/xbuild/xbuild.rsp
libdata/pkgconfig/dotnet.pc
libdata/pkgconfig/mono-cairo.pc
libdata/pkgconfig/mono-nunit.pc
@@ -647,13 +653,12 @@ share/libgc-mono/leak.html
share/libgc-mono/scale.html
share/libgc-mono/simple_example.html
share/libgc-mono/tree.html
-%%DATADIR%%/cil/cil-opcodes.xml
-@dirrm share/mono/cil
-@dirrm share/mono
+share/mono-1.0/mono/cil/cil-opcodes.xml
+@dirrm share/mono-1.0/mono/cil
+@dirrm share/mono-1.0/mono
+@dirrm share/mono-1.0
@dirrm share/libgc-mono
@dirrm share/jay
-@dirrm lib/mono/xbuild/MSBuild
-@dirrm lib/mono/xbuild
@dirrm lib/mono/gac/nunit.util/2.2.0.0__96d09a1eb7f44a77
@dirrm lib/mono/gac/nunit.util
@dirrm lib/mono/gac/nunit.mocks/2.2.8.0__96d09a1eb7f44a77
@@ -838,16 +843,18 @@ share/libgc-mono/tree.html
@dirrmtry lib/mono/gac
@dirrmtry lib/mono/compat-2.0
@dirrmtry lib/mono/compat-1.0
+@dirrmtry lib/mono/2.0/MSBuild
@dirrmtry lib/mono/2.0
@dirrmtry lib/mono/1.0
@dirrmtry lib/mono
-@dirrm include/mono/utils
-@dirrm include/mono/metadata
-@dirrm include/mono/jit
-@dirrm include/mono/io-layer
-@dirrm include/mono/interpreter
-@dirrm include/mono/cil
-@dirrm include/mono
+@dirrm include/mono-1.0/mono/utils
+@dirrm include/mono-1.0/mono/metadata
+@dirrm include/mono-1.0/mono/jit
+@dirrm include/mono-1.0/mono/io-layer
+@dirrm include/mono-1.0/mono/interpreter
+@dirrm include/mono-1.0/mono/cil
+@dirrm include/mono-1.0/mono
+@dirrm include/mono-1.0
@dirrm etc/mono/2.0
@dirrm etc/mono/1.0
@dirrm etc/mono