aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2011-01-06 19:11:42 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2011-01-06 19:11:42 +0000
commit8b04cb32a6b07847e29546d6053fd6939a5a03a7 (patch)
tree0350f77772a2712984e202a39512551cdd539681 /lang
parent07959b9d8e6e6e1b9d87fe9cea8c886582fddd10 (diff)
downloadports-8b04cb32a6b07847e29546d6053fd6939a5a03a7.tar.gz
ports-8b04cb32a6b07847e29546d6053fd6939a5a03a7.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gpc/Makefile8
-rw-r--r--lang/gpc/distinfo6
-rw-r--r--lang/gpc/files/patch-gcc__config.gcc290
-rw-r--r--lang/gpc/files/patch-gcc__config__freebsd-spec.h51
4 files changed, 12 insertions, 343 deletions
diff --git a/lang/gpc/Makefile b/lang/gpc/Makefile
index c23afc9fb8d6..21a24aa998e2 100644
--- a/lang/gpc/Makefile
+++ b/lang/gpc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gpc
PORTVERSION= 20060325
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= http://www.gnu-pascal.de/alpha/:gpc \
${MASTER_SITE_GCC}
@@ -25,6 +25,8 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
DEPRECATED= development has ceased; use lang/fpc instead
EXPIRATION_DATE= 2011-04-11
+LICENSE= GPLv2
+
USE_BISON= build
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,8 +47,8 @@ INFO= gpc gpcs gpcs-de gpcs-es gpcs-hr
PLIST_SUB= GCC_VER="${GCC_VER}" GNU_HOST="${CONFIGURE_TARGET}"
-# This port can be compiled with GCC versions 2.8.1 to 2.95 and 3.2 to 3.4.3.
-GCC_VER?= 3.4.3
+# This port can be compiled with GCC versions 2.8.1 to 2.95 and 3.2 to 3.4.4.
+GCC_VER?= 3.4.4
.include <bsd.port.pre.mk>
diff --git a/lang/gpc/distinfo b/lang/gpc/distinfo
index 2e2478c856fc..24a2fa428ec8 100644
--- a/lang/gpc/distinfo
+++ b/lang/gpc/distinfo
@@ -1,6 +1,4 @@
-MD5 (gpc-20060325.tar.bz2) = 8a564824c66e804caf27e14befc0a007
SHA256 (gpc-20060325.tar.bz2) = 18fddcb63e1f718905f191a0ca7734c4ec59cf7488742a969d070150f99d4ded
SIZE (gpc-20060325.tar.bz2) = 2767216
-MD5 (gcc-core-3.4.3.tar.bz2) = d2cbfe8fc3205c1d7969b26377405778
-SHA256 (gcc-core-3.4.3.tar.bz2) = 42e1259c15a59096e3115eec4d0b87afd04d39567a07665ca5d9b358fd02bce0
-SIZE (gcc-core-3.4.3.tar.bz2) = 13040222
+SHA256 (gcc-core-3.4.4.tar.bz2) = a390ca6123fe71c665f4422e124ced31efbbe98dd08e8f8d171caeba892ab472
+SIZE (gcc-core-3.4.4.tar.bz2) = 13153342
diff --git a/lang/gpc/files/patch-gcc__config.gcc b/lang/gpc/files/patch-gcc__config.gcc
index 3404a40b6b68..1cff74521c38 100644
--- a/lang/gpc/files/patch-gcc__config.gcc
+++ b/lang/gpc/files/patch-gcc__config.gcc
@@ -1,26 +1,6 @@
---- ./gcc/config.gcc.orig Fri Oct 20 15:51:53 2006
-+++ ./gcc/config.gcc Fri Oct 20 15:52:15 2006
-@@ -244,6 +244,7 @@
- # machines.
- tm_p_file=
- cpu_type=`echo ${target} | sed 's/-.*$//'`
-+cpu_is_64bit=
- case ${target} in
- alpha*-*-*)
- cpu_type=alpha
-@@ -300,6 +301,11 @@
- cpu_type=rs6000
- extra_headers="ppc-asm.h altivec.h spe.h"
- need_64bit_hwint=yes
-+ case x$with_cpu in
-+ xpowerpc64|xdefault64|x6[23]0|x970|xG5|xpower[345]|xrs64a)
-+ cpu_is_64bit=yes
-+ ;;
-+ esac
- ;;
- rs6000*-*-*)
- need_64bit_hwint=yes
-@@ -400,6 +406,12 @@
+--- ./gcc/config.gcc.orig 2005-04-25 04:47:59.000000000 +0000
++++ ./gcc/config.gcc 2011-01-04 11:06:36.000000000 +0000
+@@ -406,6 +406,12 @@
tm_defines="${tm_defines} FBSD_MAJOR=5" ;;
*-*-freebsd6 | *-*-freebsd[6].*)
tm_defines="${tm_defines} FBSD_MAJOR=6" ;;
@@ -33,267 +13,3 @@
*)
echo 'Please update *-*-freebsd* in gcc/config.gcc'
exit 1
-@@ -680,7 +692,7 @@
- ;;
- arm*-*-rtems*)
- tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/aout.h arm/arm.h arm/rtems-elf.h rtems.h"
-- tmake_file="arm/t-arm-elf t-rtems"
-+ tmake_file="arm/t-arm-elf t-rtems arm/t-rtems"
- ;;
- arm*-*-elf | ep9312-*-elf)
- tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/aout.h arm/arm.h"
-@@ -700,12 +712,16 @@
- tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/aout.h arm/arm.h kaos.h arm/kaos-arm.h"
- tmake_file=arm/t-arm-elf
- ;;
-+avr-*-rtems*)
-+ tm_file="avr/avr.h dbxelf.h avr/rtems.h rtems.h"
-+ tmake_file="avr/t-avr t-rtems avr/t-rtems"
-+ ;;
- avr-*-*)
- tm_file="avr/avr.h dbxelf.h"
- use_fixproto=yes
- ;;
- c4x-*-rtems* | tic4x-*-rtems*)
-- tmake_file="c4x/t-c4x t-rtems"
-+ tmake_file="c4x/t-c4x t-rtems c4x/t-rtems"
- tm_file="c4x/c4x.h c4x/rtems.h rtems.h"
- c_target_objs="c4x-c.o"
- cxx_target_objs="c4x-c.o"
-@@ -1678,20 +1694,16 @@
- pdp11-*-*)
- use_fixproto=yes
- ;;
--avr-*-*)
-- use_fixproto=yes
-- ;;
- # port not yet contributed
- #powerpc-*-openbsd*)
- # tmake_file="${tmake_file} rs6000/t-fprules "
- # extra_headers=
- # ;;
- powerpc64-*-linux*)
-- tm_file="rs6000/biarch64.h ${tm_file} dbxelf.h elfos.h svr4.h freebsd-spec.h rs6000/sysv4.h"
-- case x$with_cpu in
-- x|xpowerpc64|xdefault64) tm_file="${tm_file} rs6000/default64.h";;
-- esac
-- tm_file="${tm_file} rs6000/linux64.h"
-+ tm_file="${tm_file} dbxelf.h elfos.h svr4.h freebsd-spec.h rs6000/sysv4.h"
-+ test x$with_cpu != x || cpu_is_64bit=yes
-+ test x$cpu_is_64bit != xyes || tm_file="${tm_file} rs6000/default64.h"
-+ tm_file="rs6000/biarch64.h ${tm_file} rs6000/linux64.h"
- tmake_file="rs6000/t-fprules t-slibgcc-elf-ver t-linux rs6000/t-ppccomm rs6000/t-linux64"
- ;;
- powerpc64-*-gnu*)
-@@ -1765,8 +1777,20 @@
- tmake_file="rs6000/t-fprules rs6000/t-ppcos t-slibgcc-elf-ver t-linux rs6000/t-ppccomm"
- ;;
- powerpc-*-linux*)
-- tm_file="${tm_file} dbxelf.h elfos.h svr4.h freebsd-spec.h rs6000/sysv4.h rs6000/linux.h"
-+ tm_file="${tm_file} dbxelf.h elfos.h svr4.h freebsd-spec.h rs6000/sysv4.h"
- tmake_file="rs6000/t-fprules rs6000/t-ppcos t-slibgcc-elf-ver t-linux rs6000/t-ppccomm"
-+ case ${enable_targets}:${cpu_is_64bit} in
-+ *powerpc64* | all:* | *:yes)
-+ if test x$cpu_is_64bit = xyes; then
-+ tm_file="${tm_file} rs6000/default64.h"
-+ fi
-+ tm_file="rs6000/biarch64.h ${tm_file} rs6000/linux64.h"
-+ tmake_file="$tmake_file rs6000/t-linux64"
-+ ;;
-+ *)
-+ tm_file="${tm_file} rs6000/linux.h"
-+ ;;
-+ esac
- ;;
- powerpc-*-gnu-gnualtivec*)
- tm_file="${cpu_type}/${cpu_type}.h elfos.h svr4.h freebsd-spec.h gnu.h rs6000/sysv4.h rs6000/linux.h rs6000/linuxaltivec.h rs6000/gnu.h"
-@@ -2007,7 +2031,7 @@
- with_cpu=ultrasparc
- ;;
- sparc-*-elf*)
-- tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/elf.h"
-+ tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/sol2-gld.h sparc/elf.h"
- tmake_file="sparc/t-elf sparc/t-crtfm"
- extra_parts="crti.o crtn.o crtbegin.o crtend.o"
- use_fixproto=yes
-@@ -2017,7 +2041,7 @@
- tmake_file="t-slibgcc-elf-ver t-linux sparc/t-crtfm"
- ;;
- sparc-*-rtems*)
-- tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/elf.h sparc/rtemself.h rtems.h"
-+ tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/sol2-gld.h sparc/elf.h sparc/rtemself.h rtems.h"
- tmake_file="sparc/t-elf sparc/t-crtfm t-rtems"
- extra_parts="crti.o crtn.o crtbegin.o crtend.o"
- ;;
-@@ -2106,13 +2130,13 @@
- tmake_file=sparc/t-sparclite
- ;;
- sparclite-*-elf*)
-- tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/elf.h sparc/liteelf.h"
-+ tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/sol2-gld.h sparc/elf.h sparc/liteelf.h"
- tmake_file="sparc/t-sparclite sparc/t-crtfm"
- extra_parts="crtbegin.o crtend.o"
- use_fixproto=yes
- ;;
- sparc86x-*-elf*)
-- tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/elf.h sparc/sp86x-elf.h"
-+ tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/sol2-gld.h sparc/elf.h sparc/sp86x-elf.h"
- tmake_file="sparc/t-sp86x sparc/t-crtfm"
- extra_parts="crtbegin.o crtend.o"
- use_fixproto=yes
-@@ -2122,7 +2146,7 @@
- use_fixproto=yes
- ;;
- sparc64-*-elf*)
-- tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/sp64-elf.h"
-+ tm_file="${tm_file} dbxelf.h elfos.h svr4.h sparc/sysv4.h sol2.h sparc/sol2.h sparc/sol2-gld.h sparc/sp64-elf.h"
- tmake_file="${tmake_file} sparc/t-crtfm"
- extra_parts="crtbegin.o crtend.o"
- use_fixproto=yes
-@@ -2398,24 +2422,24 @@
- esac
- fi
-
-- # Similarly for --with-schedule.
-- if test x$with_schedule = x; then
-- case ${target} in
-- hppa1* | parisc1*)
-- # Override default PA8000 scheduling model.
-- with_schedule=7100LC
-- ;;
-- esac
-- fi
-+# Similarly for --with-schedule.
-+if test x$with_schedule = x; then
-+ case ${target} in
-+ hppa1* | parisc1*)
-+ # Override default PA8000 scheduling model.
-+ with_schedule=7100LC
-+ ;;
-+ esac
-+fi
-
-- # Validate and mark as valid any --with options supported
-- # by this target. In order to use a particular --with option
-- # you must list it in supported_defaults; validating the value
-- # is optional. This case statement should set nothing besides
-- # supported_defaults.
-+# Validate and mark as valid any --with options supported
-+# by this target. In order to use a particular --with option
-+# you must list it in supported_defaults; validating the value
-+# is optional. This case statement should set nothing besides
-+# supported_defaults.
-
-- supported_defaults=
-- case "${target}" in
-+supported_defaults=
-+case "${target}" in
- alpha*-*-*)
- supported_defaults="cpu tune"
- for which in cpu tune; do
-@@ -2569,8 +2593,7 @@
- eval $with_which=
- ;;
- "" | common \
-- | power | power2 | power3 | power4 \
-- | powerpc | powerpc64 \
-+ | power | power[2345] | powerpc | powerpc64 \
- | rios | rios1 | rios2 | rsc | rsc1 | rs64a \
- | 401 | 403 | 405 | 405fp | 440 | 440fp | 505 \
- | 601 | 602 | 603 | 603e | ec603e | 604 \
-@@ -2655,11 +2678,11 @@
- ;;
- esac
- ;;
-- esac
-+esac
-
-- # Set some miscellaneous flags for particular targets.
-- target_cpu_default2=
-- case ${target} in
-+# Set some miscellaneous flags for particular targets.
-+target_cpu_default2=
-+case ${target} in
- alpha*-*-*)
- if test x$gas = xyes
- then
-@@ -2771,44 +2794,45 @@
- ;;
- esac
- ;;
-- esac
-+esac
-
-- t=
-- all_defaults="abi cpu arch tune schedule float mode"
-- for option in $all_defaults
-- do
-- eval "val=\$with_$option"
-- if test -n "$val"; then
-- case " $supported_defaults " in
-- *" $option "*)
-- ;;
-- *)
-- echo "This target does not support --with-$option." 2>&1
-- exit 1
-- ;;
-- esac
-+t=
-+all_defaults="abi cpu arch tune schedule float mode"
-+for option in $all_defaults
-+do
-+ eval "val=\$with_$option"
-+ if test -n "$val"; then
-+ case " $supported_defaults " in
-+ *" $option "*)
-+ ;;
-+ *)
-+ echo "This target does not support --with-$option." 2>&1
-+ exit 1
-+ ;;
-+ esac
-
-- if test "x$t" = x
-- then
-- t="{ \"$option\", \"$val\" }"
-- else
-- t="${t}, { \"$option\", \"$val\" }"
-- fi
-+ if test "x$t" = x
-+ then
-+ t="{ \"$option\", \"$val\" }"
-+ else
-+ t="${t}, { \"$option\", \"$val\" }"
- fi
-- done
-- if test "x$t" = x
-- then
-- configure_default_options="{ { NULL, NULL} }"
-- else
-- configure_default_options="{ ${t} }"
- fi
-+done
-
-- if test "$target_cpu_default2" != ""
-+if test "x$t" = x
-+then
-+ configure_default_options="{ { NULL, NULL} }"
-+else
-+ configure_default_options="{ ${t} }"
-+fi
-+
-+if test "$target_cpu_default2" != ""
-+then
-+ if test "$target_cpu_default" != ""
- then
-- if test "$target_cpu_default" != ""
-- then
-- target_cpu_default="(${target_cpu_default}|${target_cpu_default2})"
-- else
-- target_cpu_default=$target_cpu_default2
-- fi
-+ target_cpu_default="(${target_cpu_default}|${target_cpu_default2})"
-+ else
-+ target_cpu_default=$target_cpu_default2
- fi
-+fi
diff --git a/lang/gpc/files/patch-gcc__config__freebsd-spec.h b/lang/gpc/files/patch-gcc__config__freebsd-spec.h
index f2dd37c2e2ae..8b8075a4ab7c 100644
--- a/lang/gpc/files/patch-gcc__config__freebsd-spec.h
+++ b/lang/gpc/files/patch-gcc__config__freebsd-spec.h
@@ -1,5 +1,5 @@
---- ./gcc/config/freebsd-spec.h.orig Fri Oct 20 15:51:07 2006
-+++ ./gcc/config/freebsd-spec.h Fri Oct 20 15:51:23 2006
+--- ./gcc/config/freebsd-spec.h.orig 2005-05-01 21:52:41.000000000 +0000
++++ ./gcc/config/freebsd-spec.h 2011-01-04 11:36:10.000000000 +0000
@@ -51,7 +51,13 @@
#define FBSD_TARGET_OS_CPP_BUILTINS() \
do \
@@ -15,50 +15,3 @@
builtin_define ("__FreeBSD__=6"); \
else if (FBSD_MAJOR == 5) \
builtin_define ("__FreeBSD__=5"); \
-@@ -107,12 +113,12 @@
- 500016, select the appropriate libc, depending on whether we're
- doing profiling or need threads support. At __FreeBSD_version
- 500016 and later, when threads support is requested include both
-- -lc and -lc_r instead of only -lc_r. To make matters interesting,
-- we can't actually use __FreeBSD_version provided by <osreldate.h>
-- directly since it breaks cross-compiling. As a final twist, make
-- it a hard error if -pthread is provided on the command line and gcc
-- was configured with --disable-threads (this will help avoid bug
-- reports from users complaining about threading when they
-+ -lc and the threading lib instead of only -lc_r. To make matters
-+ interesting, we can't actually use __FreeBSD_version provided by
-+ <osreldate.h> directly since it breaks cross-compiling. As a final
-+ twist, make it a hard error if -pthread is provided on the command
-+ line and gcc was configured with --disable-threads (this will help
-+ avoid bug reports from users complaining about threading when they
- misconfigured the gcc bootstrap but are later consulting FreeBSD
- manual pages that refer to the mythical -pthread option). */
-
-@@ -129,13 +135,7 @@
- %{pg: -lc_p} \
- }"
- #else
--#if FBSD_MAJOR >= 5
--#define FBSD_LIB_SPEC " \
-- %{!shared: \
-- %{!pg: %{pthread:-lc_r} -lc} \
-- %{pg: %{pthread:-lc_r_p} -lc_p} \
-- }"
--#else
-+#if FBSD_MAJOR < 5
- #define FBSD_LIB_SPEC " \
- %{!shared: \
- %{!pg: \
-@@ -144,6 +144,12 @@
- %{pg: \
- %{!pthread:-lc_p} \
- %{pthread:-lc_r_p}} \
-+ }"
-+#else
-+#define FBSD_LIB_SPEC " \
-+ %{!shared: \
-+ %{!pg: %{pthread:-lpthread} -lc} \
-+ %{pg: %{pthread:-lpthread_p} -lc_p} \
- }"
- #endif
- #endif