aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorEric Reardon <rizor.reardon@yahoo.com>2022-05-31 05:05:10 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-06-01 16:28:50 +0000
commita82b2847de01b169947611f893bb342f0818cfcd (patch)
treef0a7809f74972b99bac86877e2275a0fdd1b852e /lang
parentfc0939a065084b039f909f562ffb87051e8a6cb9 (diff)
downloadports-a82b2847de01b169947611f893bb342f0818cfcd.tar.gz
ports-a82b2847de01b169947611f893bb342f0818cfcd.zip
lang/julia: Update to 1.7.3
ChangeLog: https://github.com/JuliaLang/julia/compare/v1.7.2...v1.7.3 PR: 264352 Reported by: rizor.reardon@yahoo.com (maintainer) (cherry picked from commit 6f22f6eb1bbd996d87ddf08a7b3d3f4a1168bcc1)
Diffstat (limited to 'lang')
-rw-r--r--lang/julia/Makefile11
-rw-r--r--lang/julia/distinfo6
-rw-r--r--lang/julia/files/patch-Makefile4
-rw-r--r--lang/julia/files/patch-deps_llvm.mk11
-rw-r--r--lang/julia/files/patch-stdlib_Downloads-26d79afcde9cf837a331fce023b31f1d3699700c_src_Curl_Multi.jl16
-rw-r--r--lang/julia/files/patch-stdlib_Zlib__jll_src_Zlib__jll.jl11
-rw-r--r--lang/julia/pkg-plist5
7 files changed, 31 insertions, 33 deletions
diff --git a/lang/julia/Makefile b/lang/julia/Makefile
index a3f48476d009..3b7bcf5025e9 100644
--- a/lang/julia/Makefile
+++ b/lang/julia/Makefile
@@ -1,7 +1,7 @@
# Created by: Iblis Lin <iblis@hs.ntnu.edu.tw>
PORTNAME= julia
-DISTVERSION= 1.7.2
+DISTVERSION= 1.7.3
DISTVERSIONSUFFIX= -full
CATEGORIES= lang math
MASTER_SITES= https://github.com/JuliaLang/julia/releases/download/v${DISTVERSION}/
@@ -74,6 +74,7 @@ MAKE_ARGS+= NO_GIT=1 \
USE_SYSTEM_BLAS=1 \
USE_SYSTEM_NGHTTP2=1 \
USE_SYSTEM_CSL=1 \
+ USE_SYSTEM_ZLIB=1 \
USE_SYSTEM_LIBUNWIND=1
OPTIONS_DEFINE= DEBUG DOCS NATIVE GPL_LIBS
@@ -95,12 +96,6 @@ GPL_LIBS_MAKE_ARGS= USE_SYSTEM_LIBSUITESPARSE=1 \
NATIVE_DESC= Build with native CPU JIT tuning
NATIVE_MAKE_ARGS= MARCH=native
-post-extract:
- ${MKDIR} ${WRKSRC}/stdlib/Downloads-26d79afcde9cf837a331fce023b31f1d3699700c/
- ${TAR} -C ${WRKSRC}/stdlib/Downloads-26d79afcde9cf837a331fce023b31f1d3699700c/ --strip-components 1 \
- -xf ${WRKSRC}/stdlib/srccache/Downloads-26d79afcde9cf837a331fce023b31f1d3699700c.tar.gz
- echo "1" > ${WRKSRC}/stdlib/Downloads-26d79afcde9cf837a331fce023b31f1d3699700c/source-extracted
-
post-patch:
echo "override TAGGED_RELEASE_BANNER=\"FreeBSD port lang/${PORTNAME} build\"" >> ${WRKSRC}/Make.user
# unset ARCH for auto-detection
@@ -135,7 +130,7 @@ post-install-DOCS-off:
post-install-DEBUG-off:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/julia*
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libjulia.so*
-.for bin in libccalltest.so libllvmcalltest.so libjulia-internal.so* libblastrampoline.so libdSFMT.so libuv.so* libz.so* libLLVM* sys.so
+.for bin in libccalltest.so libllvmcalltest.so libjulia-internal.so* libblastrampoline.so libdSFMT.so libuv.so* libLLVM* sys.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/julia/${bin}
.endfor
diff --git a/lang/julia/distinfo b/lang/julia/distinfo
index 104b4279e12c..dd6153b55eec 100644
--- a/lang/julia/distinfo
+++ b/lang/julia/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1644261836
-SHA256 (julia-1.7.2-full.tar.gz) = c1b4f1f75aac34c40e81805cba2d87f1e72f9ce1405a525273c3688eee12366f
-SIZE (julia-1.7.2-full.tar.gz) = 255681484
+TIMESTAMP = 1653507008
+SHA256 (julia-1.7.3-full.tar.gz) = 4be529b0716de1ec48ba52e83a0fafd4be2269be9cc43074ad15ce788aeca093
+SIZE (julia-1.7.3-full.tar.gz) = 256584516
diff --git a/lang/julia/files/patch-Makefile b/lang/julia/files/patch-Makefile
index 1248a6e671cf..d294118b6f98 100644
--- a/lang/julia/files/patch-Makefile
+++ b/lang/julia/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2021-11-30 12:13:06 UTC
+--- Makefile.orig 2022-05-18 05:08:54 UTC
+++ Makefile
@@ -226,7 +226,7 @@ define stringreplace
endef
@@ -31,7 +31,7 @@
# Update RPATH entries and JL_SYSTEM_IMAGE_PATH if $(private_libdir_rel) != $(build_private_libdir_rel)
ifneq ($(private_libdir_rel),$(build_private_libdir_rel))
-@@ -384,26 +376,15 @@ ifeq ($(BUNDLE_DEBUG_LIBS),1)
+@@ -386,26 +378,15 @@ ifeq ($(BUNDLE_DEBUG_LIBS),1)
endif
endif
diff --git a/lang/julia/files/patch-deps_llvm.mk b/lang/julia/files/patch-deps_llvm.mk
new file mode 100644
index 000000000000..a8e5ad8efe61
--- /dev/null
+++ b/lang/julia/files/patch-deps_llvm.mk
@@ -0,0 +1,11 @@
+--- deps/llvm.mk.orig 2022-05-18 05:08:54 UTC
++++ deps/llvm.mk
+@@ -277,7 +277,7 @@ $(eval $(call LLVM_PATCH,llvm7-symver-jlprefix))
+ endif
+
+ # declare that all patches must be applied before running ./configure
+-$(LLVM_BUILDDIR_withtype)/build-configured: | $(LLVM_PATCH_PREV) $(build_prefix)/manifest/zlib
++$(LLVM_BUILDDIR_withtype)/build-configured: | $(LLVM_PATCH_PREV)
+
+ $(LLVM_BUILDDIR_withtype)/build-configured: $(SRCCACHE)/$(LLVM_SRC_DIR)/source-extracted | $(llvm_python_workaround)
+ mkdir -p $(dir $@)
diff --git a/lang/julia/files/patch-stdlib_Downloads-26d79afcde9cf837a331fce023b31f1d3699700c_src_Curl_Multi.jl b/lang/julia/files/patch-stdlib_Downloads-26d79afcde9cf837a331fce023b31f1d3699700c_src_Curl_Multi.jl
deleted file mode 100644
index da0227e7c083..000000000000
--- a/lang/julia/files/patch-stdlib_Downloads-26d79afcde9cf837a331fce023b31f1d3699700c_src_Curl_Multi.jl
+++ /dev/null
@@ -1,16 +0,0 @@
---- stdlib/Downloads-26d79afcde9cf837a331fce023b31f1d3699700c/src/Curl/Multi.jl.orig 2021-10-26 22:48:36 UTC
-+++ stdlib/Downloads-26d79afcde9cf837a331fce023b31f1d3699700c/src/Curl/Multi.jl
-@@ -142,12 +142,7 @@ function timer_callback(
- )::Cint
- multi = unsafe_pointer_to_objref(multi_p)::Multi
- @assert multi_h == multi.handle
-- if timeout_ms == 0
-- lock(multi.lock) do
-- @check curl_multi_socket_action(multi.handle, CURL_SOCKET_TIMEOUT, 0)
-- check_multi_info(multi)
-- end
-- elseif timeout_ms >= 0
-+ if timeout_ms >= 0
- timeout_cb = @cfunction(timeout_callback, Cvoid, (Ptr{Cvoid},))
- uv_timer_start(multi.timer, timeout_cb, max(1, timeout_ms), 0)
- elseif timeout_ms == -1
diff --git a/lang/julia/files/patch-stdlib_Zlib__jll_src_Zlib__jll.jl b/lang/julia/files/patch-stdlib_Zlib__jll_src_Zlib__jll.jl
new file mode 100644
index 000000000000..65523f1da6b4
--- /dev/null
+++ b/lang/julia/files/patch-stdlib_Zlib__jll_src_Zlib__jll.jl
@@ -0,0 +1,11 @@
+--- stdlib/Zlib_jll/src/Zlib_jll.jl.orig 2022-05-16 12:16:57 UTC
++++ stdlib/Zlib_jll/src/Zlib_jll.jl
+@@ -22,7 +22,7 @@ if Sys.iswindows()
+ elseif Sys.isapple()
+ const libz = "@rpath/libz.1.dylib"
+ else
+- const libz = "libz.so.1"
++ const libz = "libz.so"
+ end
+
+ function __init__()
diff --git a/lang/julia/pkg-plist b/lang/julia/pkg-plist
index 767e20865788..8f5609de8d3b 100644
--- a/lang/julia/pkg-plist
+++ b/lang/julia/pkg-plist
@@ -79,9 +79,6 @@ lib/julia/libstdc++.so.6
lib/julia/libuv.so
lib/julia/libuv.so.2
lib/julia/libuv.so.2.0.0
-lib/julia/libz.so
-lib/julia/libz.so.1
-lib/julia/libz.so.1.2.11
%%DEBUG%%lib/julia/sys-debug.so
lib/julia/sys.so
%%DEBUG%%lib/libjulia-debug.so
@@ -370,7 +367,7 @@ libexec/7z
%%DATADIR%%/stdlib/v%%VERSION%%/Distributed/test/runtests.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Distributed/test/splitrange.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Distributed/test/topology.jl
-%%DATADIR%%/stdlib/v%%VERSION%%/Downloads/.ci/change-uuid.jl
+%%DATADIR%%/stdlib/v%%VERSION%%/Downloads/.ci/test_and_change_uuid.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Downloads/LICENSE
%%DATADIR%%/stdlib/v%%VERSION%%/Downloads/Project.toml
%%DATADIR%%/stdlib/v%%VERSION%%/Downloads/README.md