aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-04-18 11:42:37 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-04-18 11:42:37 +0000
commit1a830c3a8c1698b1b8896c4e645d5293aaee3d95 (patch)
treeb0114d9ab6a12350c93d1638dd97156364b62668 /lang
parenta9433bf853ad68cad861698eccd9ad66cd1e429b (diff)
downloadports-1a830c3a8c1698b1b8896c4e645d5293aaee3d95.tar.gz
ports-1a830c3a8c1698b1b8896c4e645d5293aaee3d95.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python-devel/Makefile1
-rw-r--r--lang/python/Makefile1
-rw-r--r--lang/python23/Makefile1
-rw-r--r--lang/python24/Makefile1
-rw-r--r--lang/python25/Makefile1
-rw-r--r--lang/python26/Makefile1
-rw-r--r--lang/python27/Makefile1
-rw-r--r--lang/python30/Makefile1
-rw-r--r--lang/python31/Makefile1
-rw-r--r--lang/python32/Makefile1
10 files changed, 10 insertions, 0 deletions
diff --git a/lang/python-devel/Makefile b/lang/python-devel/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python-devel/Makefile
+++ b/lang/python-devel/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 3495e7ec11c2..5bee1a4457bc 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -20,6 +20,7 @@ CONFLICTS= stackless_python-*
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 3495e7ec11c2..5bee1a4457bc 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -20,6 +20,7 @@ CONFLICTS= stackless_python-*
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 3495e7ec11c2..5bee1a4457bc 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -20,6 +20,7 @@ CONFLICTS= stackless_python-*
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"