aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-05-31 04:55:04 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-05-31 04:55:04 +0000
commitc35abcc9a37e071b1bb1afabe6919d8507a5bf22 (patch)
treee78528828ac97c277b9b581bf390ec23ea888bfe /lang
parent147273eda9f41a57c3d509d3284136effff222b5 (diff)
downloadports-c35abcc9a37e071b1bb1afabe6919d8507a5bf22.tar.gz
ports-c35abcc9a37e071b1bb1afabe6919d8507a5bf22.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc32/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index f34c8f3581fc..541f34535a80 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -35,11 +35,6 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
-.else
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-.endif
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64" || ${ARCH} == "amd64"
# libgcj is built on all platforms except sparc64 and ia64 and amd64
@@ -52,8 +47,12 @@ BROKEN= gcj does not build.
.if ${PORTOBJFORMAT} == "aout"
CONFIGURE_TARGET= ${ARCH}-portbld-freebsdaout${OSREL}
.else
+.if ${ARCH} == "amd64"
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
+.endif
GCC_REV= ${PORTVERSION:C/\.0$//}
SRCDIR= ${WRKDIR}/gcc-${GCC_REV}